Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

Hi all,

I am trying to configure etherchannel on 2 2960S connected by a flexstack with 2 ports g1/0/52 and g2/0/52 on each 2960.

these switch are connected to a CAT4500, I know that I can only use LACP because of cross-stack but when I force the switch to use LACP witch channel-group 2 Mode active the switch do this :

%With PAgP enabled, all ports in the Channel should belong to the same switch
Command rejected (Port-channel2, Gi1/0/52): Invalid etherchnl mode

% Range command terminated because it failed on GigabitEthernet1/0/52

I don't know how to bundle the 2 ports on the 2960 stack. each time I use : channel-group 2 mode on there is no error

but the switch do this :

*Mar  1 00:45:32.290: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:32.531: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:32.908: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:33.050: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:33.286: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:33.669: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic

*Mar  1 00:45:32.290: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:32.531: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:32.908: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:33.050: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:33.286: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic, Po2 is trunk)

*Mar  1 00:45:33.669: %EC-5-CANNOT_BUNDLE2: Gi2/0/52 is not compatible with Po2 and will be suspended (trunk mode of Gi2/0/52 is dynamic

If you have an idea

thanks

9 REPLIES
Cisco Employee

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

Hello Yann,

Please avoid the channel-group mode on at all costs.

Would you care posting either your entire switch stack configuration, or at least the output of the following commands?

show ether sum

show run int gi1/0/52

show run int gi2/0/52

show run int po2

Thank you!

Best regards,

Peter

Community Member

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

here is what you ask, I will send the configuration later if needed

NEILM-SW00001#sh ether summ
% Ambiguous command:  "sh ether summ"
NEILM-SW00001#sh ether summar ?
% Ambiguous command:  "sh ether summar "
NEILM-SW00001#sh etherch     
NEILM-SW00001#sh etherchannel ?
  <1-6>         Channel group number
  detail        Detail information
  load-balance  Load-balance/frame-distribution scheme among ports in
                port-channel
  port          Port information
  port-channel  Port-channel information
  protocol      protocol enabled
  summary       One-line summary per channel-group
  |             Output modifiers
 

NEILM-SW00001#sh etherchannel summ
NEILM-SW00001#sh etherchannel summary ?
  |  Output modifiers
 

NEILM-SW00001#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SD)          -        Gi1/0/52(s) Gi2/0/52(D)

NEILM-SW00001#sh run int g1/0/52
Building configuration...

Current configuration : 105 bytes
!
interface GigabitEthernet1/0/52
description SW_ETAGE2B_Gig1/0/52-2/0/52
channel-group 2 mode on
end

NEILM-SW00001#sh run int g2/0/52
Building configuration...

Current configuration : 105 bytes
!
interface GigabitEthernet2/0/52
description SW_ETAGE2B_Gig1/0/52-2/0/52
channel-group 2 mode on
end

NEILM-SW00001#sh run int po2
Building configuration...

Current configuration : 233 bytes
!
interface Port-channel2
description SW_ETAGE2B_Gig1/0/52-2/0/52
switchport trunk native vlan 389
switchport trunk allowed vlan 300-330,389
switchport mode trunk
switchport nonegotiate
load-interval 30
speed nonegotiate
end

Cisco Employee

Re: 2960S 12.2(55)SE3 flexstack unable to configure etherchannel

Hello Yann,

Thank you for the output, and I apologize for posting an incomplete command.

Your physical ports differ in their configuration from the configuration of the Port-channel interface and that is causing the "suspended" messages. A key thing to remember when configuring EtherChannels is that the physical ports and the Port-channel port must be configured identically.

Let us try creating the LACP EtherChannel once again. Please paste the following lines into your configuration (please be aware that this will temporarily shutdown your Gi1/0/52 and Gi2/0/52 interfaces so make sure you do not lose connectivity to your switch):

no interface Port-channel2

!

interface range Gi1/0/52 , Gi2/0/52

no shutdown

switchport trunk native vlan 389

switchport trunk allowed vlan 300-330,389

switchport mode trunk

switchport nonegotiate

load-interval 30

channel-protocol lacp

channel-group 2 mode active

!

end

Please keep me informed about the outcome of this configuration change. Also if this does not work as expected, include the same set of command outputs as before.

Best regards,

Peter

Community Member

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

the behavior seems to be better but the Po2 is still down :

NEILM-SW00001#sh etherchannel summa
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SD)         LACP      Gi1/0/52(I) Gi2/0/52(I)

Cisco Employee

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

Hello Yann,

This looks good indeed. The "I" state means that our ports are ready to be bundled into EtherChannel but the opposite device did not agree to bundle them using LACP.

Note that the opposite device (the 4500 switch) also has to use LACP in order for this EtherChannel to come up. In a similar way as with 2960, I recommend removing the corresponding Port-channel from the 4500 switch altogether, configuring the physical ports with all necessary commands that formerly appeared on the Port-channel, and then bundling them together into a new Port-channel with LACP.

Good work so far!

Best regards,

Peter

Community Member

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

hi peter,

thank you for your help but on the other side on the CAT4

Jan 16 10:36:54.114: %EC-5-L3DONTBNDL2: Gi1/2 suspended: LACP currently not  enabled on the remote port.

Jan 16 10:37:01.319: %EC-5-L3DONTBNDL2: Gi2/2 suspended: LACP currently not  enabled on the remote port.

my port configuration

!
interface GigabitEthernet1/2
description  bundle-etage2B
switchport trunk native vlan 389
switchport trunk allowed  vlan 300-330,389
switchport mode trunk
switchport  nonegotiate
load-interval 30
speed nonegotiate
channel-protocol  lacp
channel-group 12 mode active
end

NEILM-CORE00001#sh run int g2/2
Building configuration...

Current configuration : 278 bytes
!
interface  GigabitEthernet2/2
description bundle-etage2B
switchport trunk native  vlan 389
switchport trunk allowed vlan 300-330,389
switchport mode  trunk
switchport nonegotiate
load-interval 30
speed  nonegotiate
channel-protocol lacp
channel-group 12 mode  active
end

NEILM-CORE00001#sh run int po12
Building configuration...

Current configuration : 62 bytes
!
interface  Port-channel12
switchport
load-interval 30
end

Community Member

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

hi,

I didn't have the time to check more but can you tell me why on the other side the 4500 says that the remote port is not LACP configured ?

thanks

Cisco Employee

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

Hello Yann,

Try adding the switchport command both to Gi1/2 and Gi2/2 interfaces and see what happens.

Best regards,

Peter

Cisco Employee

2960S 12.2(55)SE3 flexstack unable to configure etherchannel

Hi Yann,

Did you have any luck or progress?

Best regards,

Peter

1753
Views
0
Helpful
9
Replies
CreatePlease to create content