Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

2960S FlexStack Issue

                   Hi,

I have two WS-C2960S-24PS-L switches. One was set up with a configuration that worked for our network, but we now have need of the additional ports in the second.

I installed the FlexStack modules, as per the instructions, and connected the cables, then powered on the second switch. All seems OK, to a level.

I can browse to the web interface and see the drop down menu for the Member 2 switch. I can TELNET onto the master and see all the interfaces for the second switch, and also see the 'show switch details' for both switches.

Here's the annoying part though. I have an Avaya IP phone connected to one ports in the Member switch and I have the VLAN set for it. The phone manages to pick up a DHCP address, but fails to connect tot he TFTP server. This behaviour is also happening for a laptop I connected. It can acquire an IP from DHCP, but fails to do anything else further than that.

What's the likliest configuration I've put onto the Master switch that would be preventing the second switch from doing it's role properly? If you need to see the config, that can be provided on request. Thanks.

Chris

Everyone's tags (2)
18 REPLIES
VIP Super Bronze

2960S FlexStack Issue

Hi,

Do both switches have the same exact IOS loaded?

Do they also have the same license level?

Community Member

2960S FlexStack Issue

Both have exact same IOS as they were bought together.

Not 100% sure about the licensing. When I do 'show license' I get the following:

CORE1#show license

Index 1 Feature: lanlite

        Period left: 0  minute  0  second

Index 2 Feature: lanbase

        Period left: Life time

        License Type: Permanent

        License State: Active, In Use

        License Priority: Medium

        License Count: Non-Counted

Not sure if this is just showing the licenses for Switch1 or for both.

Community Member

Re: 2960S FlexStack Issue

Did the phone work when it was just one switch (no stack)? Are all of the ports configured for the same access vlan and/or voice vlan? Can you ping the TFTP server? A 'show running-config' would be helpful.

Community Member

Re: 2960S FlexStack Issue

The phones work fine (as do all other devices, WAP, Servers, Router, Laptops, etc) when plugged into the Master switch. It's only devices attached to the second switch (The Member switch) that are having the issues.

There is only one active VLAN (Vlan159), and all devices run on this VLAN. Ports are configured via the web interface for Cisco Phone+ Desktop, so I have both Voice VLAN and Data VLAN set to 159, which as stated, works nicely for all devices attached to the Master. Config for the stack is this:

CORE1#show run
Building configuration...

Current configuration : 17256 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CORE1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$.P7W$DozTgSPjWF/KdeV9MTxgH/
enable password ############
!
!
!
no aaa new-model
switch 1 provision ws-c2960s-24ps-l
switch 2 provision ws-c2960s-24ps-l
ip routing
!
!
vtp mode transparent
!
mls qos map policed-dscp  0 10 18 24 46 to 8
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20
mls qos
!
crypto pki trustpoint TP-self-signed-125214208
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-125214208
revocation-check none
rsakeypair TP-self-signed-125214208
!
!
crypto pki certificate chain TP-self-signed-125214208
certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31323532 31343230 38301E17 0D393330 33303130 30303233
  325A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3132 35323134
  32303830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  A1FD3049 F06B1A49 1DB7F159 1FB89A96 AE6F9665 404E4D49 F5A716C8 8663A056
  8D72AE30 CBB5F55C 7C9BA2A0 BEC05670 A4DC6853 33BD5951 B30B8D1A 0BD60498
  BD1F38E6 18E4E351 20DFB492 47A9C51C C816D6D0 EA64B2FE 23A192E6 5FBD3F6B
  501BFF9E BBB18083 AB380A98 1AAC0096 A2FC4CCF 89DE3F86 9733E51A 16D2187B
  02030100 01A36630 64300F06 03551D13 0101FF04 05300301 01FF3011 0603551D
  11040A30 08820643 4F524531 2E301F06 03551D23 04183016 80145D7D 67FB2912
  D8EC944B 6065ACE2 974751CF 3C83301D 0603551D 0E041604 145D7D67 FB2912D8
  EC944B60 65ACE297 4751CF3C 83300D06 092A8648 86F70D01 01040500 03818100
  7AE98888 978CEF2E 1E22F3B2 A869685A CB37FD79 EADFDB07 BFF9AA2C C9C05B8B
  20D83ECC 6634EEBF B0147839 11160E49 B4BDE272 0F5B0D79 16426E79 D7DD433B
  3AECD7AC CECF6850 0F7E46F1 A574035B E58977DF DB9B15B6 1D2327FA CF684838
  FE6AA1F2 C1A43F81 C8C32B51 245D9810 7935F0EF CF327437 413C577A EA67EE2D
  quit
spanning-tree mode pvst
spanning-tree extend system-id
auto qos srnd4
!
!
!
!
vlan internal allocation policy ascending
!
!
vlan 151
name CTDS-Vlan
!
vlan 159
name Vlan159
!
!
class-map match-all AUTOQOS_VOIP_DATA_CLASS
match ip dscp ef
class-map match-all AUTOQOS_DEFAULT_CLASS
match access-group name AUTOQOS-ACL-DEFAULT
class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
match ip dscp cs3
!
!
policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
class AUTOQOS_VOIP_DATA_CLASS
  set dscp ef
  police 128000 8000 exceed-action policed-dscp-transmit
class AUTOQOS_VOIP_SIGNAL_CLASS
  set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
class AUTOQOS_DEFAULT_CLASS
  set dscp default
  police 10000000 8000 exceed-action policed-dscp-transmit
!
!
!
interface FastEthernet0
no ip address
no ip route-cache cef
no ip route-cache
!
interface GigabitEthernet1/0/1
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/2
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/3
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/4
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/5
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/6
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/7
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/8
switchport trunk native vlan 159
switchport mode trunk
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
macro description cisco-switch
auto qos trust
spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/9
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/10
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/11
switchport trunk native vlan 159
switchport mode trunk
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
macro description cisco-switch
auto qos trust
spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/12
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/13
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/14
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/15
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/16
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/17
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/18
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/19
description WLAN
switchport trunk native vlan 159
switchport mode trunk
switchport nonegotiate
power inline never
speed 100
duplex full
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
macro description cisco-wireless | cisco-wireless
auto qos trust
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/20
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/21
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/22
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/23
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/24
description BT Router
switchport access vlan 159
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
spanning-tree portfast
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet2/0/1
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
switchport access vlan 159
switchport mode access
switchport voice vlan 159
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet2/0/13
!
interface GigabitEthernet2/0/14
!
interface GigabitEthernet2/0/15
!
interface GigabitEthernet2/0/16
!
interface GigabitEthernet2/0/17
!
interface GigabitEthernet2/0/18
!
interface GigabitEthernet2/0/19
!
interface GigabitEthernet2/0/20
!
interface GigabitEthernet2/0/21
!
interface GigabitEthernet2/0/22
!
interface GigabitEthernet2/0/23
!
interface GigabitEthernet2/0/24
!
interface GigabitEthernet2/0/25
!
interface GigabitEthernet2/0/26
!
interface GigabitEthernet2/0/27
!
interface GigabitEthernet2/0/28
!
interface Vlan1
no ip address
!
interface Vlan159
ip address 10.77.147.2 255.255.255.0
standby 0 ip 10.77.147.3
!
ip route 0.0.0.0 0.0.0.0 10.77.147.1
ip http server
ip http secure-server
!
ip access-list extended AUTOQOS-ACL-DEFAULT
permit ip any any
!
line con 0
password ###############
login
line vty 0 4
password ###############
login
length 0
line vty 5 15
password ##############
login
!
end

As you can see, the 'show running-config' displays the switch ports on the second switch, but I just can't get them to talk to anything other than DHCP.

Hall of Fame Super Blue

2960S FlexStack Issue

1.  I presume the clients you were trying to connect into the 2nd stack members where in the ports with a configuration (and NOT in the ports WITHOUT any configurations)?

2.  Can you post the complete output to the command "sh version" and "sh switch detail"?

Community Member

2960S FlexStack Issue

1 - Obviously I've only been using Ports 1 and 5 for testing so far.

2 - 'Show Version':

CORE1#show version
Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(55)SE5,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Thu 09-Feb-12 19:22 by prod_rel_team
Image text-base: 0x00003000, data-base: 0x01B00000

ROM: Bootstrap program is Alpha board boot loader
BOOTLDR: C2960S Boot Loader (C2960S-HBOOT-M) Version 12.2(55r)SE, RELEASE SOFTWA
RE (fc1)

CORE1 uptime is 4 days, 17 hours, 23 minutes
System returned to ROM by power-on
System image file is "flash:/c2960s-universalk9-mz.122-55.SE5/c2960s-universalk9
-mz.122-55.SE5.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C2960S-24PS-L (PowerPC) processor (revision E0) with 131072K bytes of m
emory.
Processor board ID FOC1633X4MU
Last reset from power-on
2 Virtual Ethernet interfaces
1 FastEthernet interface
56 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 20:3A:07:76:9E:00
Motherboard assembly number     : 73-11908-08
Power supply part number        : 341-0393-02
Motherboard serial number       : FOC16336ZQD
Power supply serial number      : DCA1631U1HJ
Model revision number           : E0
Motherboard revision number     : A0
Model number                    : WS-C2960S-24PS-L
Daughterboard assembly number   : 73-11933-04
Daughterboard serial number     : FOC16341PWM
System serial number            : FOC1633X4MU
Top Assembly Part Number        : 800-30945-03
Top Assembly Revision Number    : A0
Version ID                      : V03
CLEI Code Number                : COMGE00ARC
Daughterboard revision number   : A0
Hardware Board Revision Number  : 0x01


Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 28    WS-C2960S-24PS-L   12.2(55)SE5           C2960S-UNIVERSALK9-M
     2 28    WS-C2960S-24PS-L   12.2(55)SE5           C2960S-UNIVERSALK9-M


Switch 02
---------
Switch Uptime                   : 23 hours, 29 minutes
Base ethernet MAC Address       : 20:3A:07:AC:3C:00
Motherboard assembly number     : 73-11908-08
Power supply part number        : 341-0393-02
Motherboard serial number       : FOC16332VA2
Power supply serial number      : DCA1631U1GF
Model revision number           : E0
Motherboard revision number     : A0
Model number                    : WS-C2960S-24PS-L
Daughterboard assembly number   : 73-11933-04
Daughterboard serial number     : FOC16340X31
System serial number            : FOC1633X4NY
Top assembly part number        : 800-30945-03
Top assembly revision number    : A0
Version ID                      : V03
CLEI Code Number                : COMGE00ARC
Daughterboard revision number   : A0

Configuration register is 0xF

'show switch detail':

Switch/Stack Mac Address : 203a.0776.9e00
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master 203a.0776.9e00     14     1       Ready
2       Member 203a.07ac.3c00     1      1       Ready

         Stack Port Status             Neighbors
Switch#  Port 1     Port 2           Port 1   Port 2
--------------------------------------------------------
  1        Ok         Ok                2        2
  2        Ok         Ok                1        1

Community Member

Re: 2960S FlexStack Issue

Bump.

Been reading round the forums, and I've done all the other recommended things so far. Just not sure what's causing this.

Could it be an issue with Spanning Tree?

Community Member

Re: 2960S FlexStack Issue

Connect the switches with a copper dot1q trunk and see if you still have an issue. Can you talk about the issue you're having more? You get a DHCP address but you can't access the Internet? Can you ping your default gateway? Can you ping any other link local clients? Does your MAC address make it to any other upstream switches?

Sent from Cisco Technical Support iPhone App

Community Member

2960S FlexStack Issue

Yes, I can get an IP from the DHCP server, and I can see the device listed in the DHCP Console on the server.

I can't PING the device and I can't PING from the device.

At the moment, I only have a VOIP phone connected, and it's constantly trying to connect to a TFTP server located on a different IP range (Phones connected to the Master in this 2-switch stack can connect to the TFTP without issue).

This is also how I know DHCP has worked, as the TFTP address is assigned to the phone through DHCP too.

In this environment, there are only these two switches. Connected to the Master, I have my Cisco Wireless Access Point, several VOIP phones and around 4-5 workstations. There is one server, which is using 4 of the Gigabit ports, the WAN link and the CCTV system. All of these things work fine when connected to the Master switch in this stack.

This was all pre-configured before we added the stack though, so it would seem to me, there is something in the original configuration we have applied that is causing the restriction.

When I connected my laptop to this switch, I wasn't able to PING anything, not even the DHCP server which had assigned me my IP.

Community Member

2960S FlexStack Issue

Connect the switches with a copper dot1q trunk and see if you still have an issue.

Community Member

2960S FlexStack Issue

I've got none of those available, but wouldn't that create a cluster, and not a stack?

I don't have a config on Switch 2, as I believe is requirement for Stacking, so if I attach it as a secondary switch, I wouldn't have any connectivity anyway would I?

Community Member

2960S FlexStack Issue

Yes, it would no longer be a stack, but we're just testing your switch here. You don't necessarily need a configuration on the switch. Just disconnect your flexstack cables, find a port thats not being used on the master and issue a 'no spanning-tree bpduguard enable' on that port, then plug your second switch in to that. Plug your laptop in to a port on the second switch and see what happens.

Community Member

2960S FlexStack Issue

I've probably done something wrong, but the phone can't even pick up a DHCP address now.

I've cleared the config from Interface GigabitEthernet1/0/6 and connected that to a unconfigured port on the second switch witha  Cat5e cable.

I've done 'Conf T' > 'Interface GigabitEthernet1/0/6' > 'no spanning-tree bpduguard enable' > End > Write Mem

Now there's no connectivity at all.

Oddly though, even though I've disconnected the Stack cables, I can still see all of Switch2's ports when I do a 'show config' *Shrug*

Community Member

Re: 2960S FlexStack Issue

Well you still would have needed some config on gi1/0/6:

switchport access vlan 159

switchport mode access

spanning-tree portfast

If it was defaulted, it goes to vlan 1 instead of 159.

edit: Did you ever try restarting the stack after you added the second switch?

1176
Views
0
Helpful
18
Replies
CreatePlease to create content