Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2960X VoIP quality

I have an unusual problem happening on two 2960X switches. VoIP calls are very poor quality (jittery, robotic sounding, "sounds like they are under water). Our first assumption was that the QoS needed some tweaking, but that wasn't the case. 

Facts:

  • Two 2960X stacks (2 switches in each stack)
  • Both stacks are connected to a 4510 via fiber.
  • Phone are Avaya 9608 IP phones.
  • Users are not having any problems with data connections (even when connected through the IP phones).
    • Tested data connections passing through phones. Results were 96 mbps down 93 mbps up.

Last night we used a 2960S switch to test. We connected the 2960S to the same port on the 4510 one of the 2960X was using. We connected one of the phones experiencing issues and the quality was good. When then moved to the perimeter closet and repeated the test using the fiber connection from the 2960X uplink, phone was quality good. Next we moved the fiber back to the 2960X and plugged the same phone into it, phone quality poor (we expected it to be bad since nothing had changed). Since it was after hours, we shut every port on the 2960x but one port for the phone and the uplink, phone quality still bad. 

At this point, we are stumped. I searched for known caveats but I didn't see any related to this issue. Lastly, I have 2960X stacks in other locations in our facility running the same version with exactly the same configuration.

Model: WS-C2960X-48FPS

SW Version: 15.0(2)EX5

 

Suggestions? 

 

5 REPLIES

Hey,What is the switch up

Hey,

What is the switch up time? Also have you tried reloading?

Regards,
RS.

Hall of Fame Super Gold

Load a software-based VoIP

Load a software-based VoIP and test.  If the results are the same, it ain't the switch.  It could potentially be your call server.  

 

How is the call server set up?  What happens if you put the phone and the call server in the same IP subnet?

New Member

Yes, we reloaded the switch

Yes, we reloaded the switch (several times actually). 

 

 

New Member

I have no idea why this has

I have no idea why this has worked for us but...

 

We noticed the mac address table was not populating very many addresses. We removed spanning-tree portfast from all the switches in our network and the mac tables updated. We haven't been able to replicate the problem on the switches after we removed spanning-tree portfast. 

 

New Member

Re: 2960X VoIP quality

Could you post your QoS policy
370
Views
0
Helpful
5
Replies
CreatePlease to create content