Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

3500xl switch will not accept interface range

I get a invalid input  range

   &nbSwPodx(config)# SwPodx(config)#int SwPodx(config)#interface range fastethernet 0/2 - 24     

                                                          ^ % Invalid input detected at '^' marker. SwPodx(config)#sp;  

7 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Re: 3500xl switch will not accept interface range

Phillip

The 3500XL is a very old switch and there is a strong possibility that the range feature was not supported on them.

If you do -

switch(config)# int ?

do you see the "range" option ? If not i suspect it is because the "range" feature was added after these switches had been phased out.

Edit - if that is the case then you will just have to do it port by port to allocate each port into it's correct vlan.

Jon

VIP Purple

3500xl switch will not accept interface range

Hi Phillip,

Interface range is supported only in 12.1(x). No plans to include interface range option in the XLs which cannot run 12.1.

To support the interface range command, your IOS must be at least release 12.1 or better.

Regards

Dont forget to arte helpful posts

Hall of Fame Super Gold

3500xl switch will not accept interface range

Interface "range", even if you are using the final IOS (WC17), is/will not be supprted.   This includes 2900XL and 3500XL switches.

The interface "range" option was supported only from the 2940/2950/2955, 2970 and 3550 switches. 

Hall of Fame Super Blue

3500xl switch will not accept interface range

Phillip

If the range command is not supported you need to do it one by one eg.

int fa0/1

switchport mode access

switchport access vlan 10

etc...

you could use a text editor and do it in there an copy and paste to the switch but it doesn't take that long.

Note from your configuration at the end the ports cannot be in both vlans at the same time ie they are either in one or the other.

Jon

VIP Purple

Re: 3500xl switch will not accept interface range

Hi phillip,

You must do manually on each interface.

Conf t

Int fa0/1

switchport mode access

switchport access vlan 10

...

Regards

Hall of Fame Super Blue

3500xl switch will not accept interface range

Phillip

See this thread for how to configure each port. Because the switch is quite old people have reported using the "switchport voice vlan x" command did not work.

So you can see the solution in the following thread -

https://supportforums.cisco.com/thread/2181858

note that you will have configure each port one by one because there is no "range" option on your switch.

Jon

VIP Purple

3500xl switch will not accept interface range

Hi Phillip,

Normally it should work like this:

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#switchport voice vlan 15

But I think its a verz old swicth,Correct?  OLDER switches must specifically configure the trunk in order to work.

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport voice vlan 15

Switch(config-if)#spanning-tree portfast

Regards

20 REPLIES
Hall of Fame Super Blue

Re: 3500xl switch will not accept interface range

Phillip

The 3500XL is a very old switch and there is a strong possibility that the range feature was not supported on them.

If you do -

switch(config)# int ?

do you see the "range" option ? If not i suspect it is because the "range" feature was added after these switches had been phased out.

Edit - if that is the case then you will just have to do it port by port to allocate each port into it's correct vlan.

Jon

Community Member

Re: 3500xl switch will not accept interface range

Jon this is a voice lab and think I will be using Ip Phone and PC together. 

vlan 10 is Data for PC

vlan 15 is Voice for IP Phone

vlan 11 is Management for gateway

Maybe this is why I have to assign 0/2 - 24 to vlan 10 and 15

correct ??    

my vlan config for 3500xl switch is

vlan

name Data 10

vlan

name Management 11

vlan

name Voice 15

interface fa0/1

switchport trunk encapsualtion dot1q

switchport mode trunk

___

I need to imput range below, what is the quickest way.  Thanks

int range 0/2 -24

switchport mode access

switchport access vlan 10

switchport access vlan 15

Super Bronze

Re: 3500xl switch will not accept interface range

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Per chance, did you clip and copy your config text from any word processors, e.g. Word?

Reason I ask, some of those will change a hyphen character to a dash character, and the latter isn't recognized in the range command.

Hall of Fame Super Blue

Re: 3500xl switch will not accept interface range

Joseph

I don't know whether you saw/read a recent thread on oversubscription on 6500 linecard but the idea was raised of using rate limiting to control oversubscription.

Personally i have never done this and i don't think it is particularly practical but then i am no expert on QOS. If you get a chance could you have a look at it and see if there is anything i have missed or perhaps mislead the OP -

https://supportforums.cisco.com/thread/2262043?tstart=30

not a problem if you don't have the time.

Jon

VIP Purple

3500xl switch will not accept interface range

Hi Phillip,

Interface range is supported only in 12.1(x). No plans to include interface range option in the XLs which cannot run 12.1.

To support the interface range command, your IOS must be at least release 12.1 or better.

Regards

Dont forget to arte helpful posts

Hall of Fame Super Gold

3500xl switch will not accept interface range

Interface "range", even if you are using the final IOS (WC17), is/will not be supprted.   This includes 2900XL and 3500XL switches.

The interface "range" option was supported only from the 2940/2950/2955, 2970 and 3550 switches. 

Hall of Fame Super Blue

3500xl switch will not accept interface range

Phillip

If the range command is not supported you need to do it one by one eg.

int fa0/1

switchport mode access

switchport access vlan 10

etc...

you could use a text editor and do it in there an copy and paste to the switch but it doesn't take that long.

Note from your configuration at the end the ports cannot be in both vlans at the same time ie they are either in one or the other.

Jon

Community Member

3500xl switch will not accept interface range

Is the configration asking me to assign int fa0/2 -24 to both vlan 10 and vlan 15

Hall of Fame Super Blue

3500xl switch will not accept interface range

Phillip

Not sure i follow. A port is either a trunk where it can be in multiple vlans or it is an access port where it is one vlan. The only exception to this is if you are configuring a port with an IP phone connected where you have a data vlan and a voice vlan.

But your configuration doesn't look like there is a voice vlan so you can only assign each port into one vlan not both at the same time.

Do you need them to be in both for all ports ?

Jon

VIP Purple

Re: 3500xl switch will not accept interface range

Hi phillip,

You must do manually on each interface.

Conf t

Int fa0/1

switchport mode access

switchport access vlan 10

...

Regards

Hall of Fame Super Blue

Re: 3500xl switch will not accept interface range

Hi Sandeep

How does that work ie. you are entering two "switchport access vlan x" lines where a port can only be in one vlan unless the additional vlan is a voice vlan.

Jon

VIP Purple

Re: 3500xl switch will not accept interface range

HI John,

that was typo error, thaks for correction , I just copied from Philip post.

Regards

Community Member

Re: 3500xl switch will not accept interface range

Jon this is a voice lab and think I will be using Ip Phone and PC together. 

vlan 10 is Data for PC

vlan 15 is Voice for IP Phone

vlan 11 is Management for gateway

Maybe this is why I have to assign 0/2 - 24 to vlan 10 and 15

correct ??    

my vlan config for 3500xl switch is

vlan

name Data 10

vlan

name Management 11

vlan

name Voice 15

interface fa0/1

switchport trunk encapsualtion dot1q

switchport mode trunk

___

I need to imput range below, what is the quickest way.  Thanks

int range 0/2 -24

switchport mode access

switchport access vlan 10

switchport access vlan 15

VIP Purple

3500xl switch will not accept interface range

Hi Phillip,

Normally it should work like this:

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#switchport voice vlan 15

But I think its a verz old swicth,Correct?  OLDER switches must specifically configure the trunk in order to work.

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport voice vlan 15

Switch(config-if)#spanning-tree portfast

Regards

Community Member

Re: 3500xl switch will not accept interface range

Looks like in for a lot of work arounds and trouble with this switch,  what is the next level switch that will support the lastest ios commands,  also would GNS3 be a better option, because this just lab 3 in the book and im spending to much time reshearching.

This is a voice lab and think I will be using Ip Phone and PC together. 

vlan 10 is Data for PC

vlan 15 is Voice for IP Phone

vlan 11 is Management for gateway

Maybe this is why I have to assign 0/2 - 24 to vlan 10 and 15

correct ??    

my vlan config for 3500xl switch is

vlan

name Data 10

vlan

name Management 11

vlan

name Voice 15

interface fa0/1

switchport trunk encapsualtion dot1q

switchport mode trunk

___

I need to imput range below, what is the quickest way.  Thanks

int range 0/2 -24

switchport mode access

switchport access vlan 10

switchport access vlan 15

VIP Purple

Re: 3500xl switch will not accept interface range

As you are looking for your home lab then u must be looking for cheap Switch: Then go fo 3560.

Then you can configure:

Fa0/1

switchport access vlan 10

switchport voice vlan 15

I think that this switch will support Interface range feature. Then you can configure all interface at once.

More about config:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_52_se/configuration/guide/swvoip.html

Rgerads

Community Member

Re: 3500xl switch will not accept interface range

This is a voice lab and think I will be using Ip Phone and PC together.  vlan 10 is Data for PC vlan 15 is Voice for IP Phone vlan 11 is Management for gateway Maybe this is why I have to assign 0/2 - 24 to vlan 10 and 15 correct ??    my vlan config for 3500xl switch is vlan name Data 10 vlan name Management 11 vlan name Voice 15 interface fa0/1 switchport trunk encapsualtion dot1q switchport mode trunk ___ I need to imput range below, for each port 02 - 24, because its vioce lab, AM i correct,  once i get pass this I should be ok I hope.  Thanks for the help int fa0/2 Switch(config-if)#switchport trunk encapsulation dot1q Switch(config-if)#switchport mode trunk Switch(config-if)#switchport voice vlan 10 Switch(config-if)#spanning-tree portfast int fa0/2 Switch(config-if)#switchport trunk encapsulation dot1q Switch(config-if)#switchport mode trunk Switch(config-if)#switchport voice vlan 15 Switch(config-if)#spanning-tree portfast

Hall of Fame Super Blue

3500xl switch will not accept interface range

Phillip

See this thread for how to configure each port. Because the switch is quite old people have reported using the "switchport voice vlan x" command did not work.

So you can see the solution in the following thread -

https://supportforums.cisco.com/thread/2181858

note that you will have configure each port one by one because there is no "range" option on your switch.

Jon

Community Member

Re: 3500xl switch will not accept interface range

Looks like in for a lot of work arounds and trouble with this switch,  what is the next level switch that will support the lastest ios commands,  also would GNS3 be a better option, because this just lab 3 in the book and im spending to much time researching.  thanks

This is a voice lab and think I will be using Ip Phone and PC together. 

vlan 10 is Data for PC

vlan 15 is Voice for IP Phone

vlan 11 is Management for gateway

Maybe this is why I have to assign 0/2 - 24 to vlan 10 and 15

correct ??    

my vlan config for 3500xl switch is

vlan

name Data 10

vlan

name Management 11

vlan

name Voice 15

interface fa0/1

switchport trunk encapsualtion dot1q

switchport mode trunk

___

I need to imput range below, what is the quickest way.  Thanks

int range 0/2 -24

switchport mode access

switchport access vlan 10

switchport access vlan 15

Community Member

Re: 3500xl switch will not accept interface range

Looks like in for a lot of work arounds and trouble with this switch,  what is the next level switch that will support the lastest ios commands,  also would GNS3 be a better option, because this just lab 3 in the book and im spending to much time reshearching.  pease advise this switch will work for a voice lab, This is a voice lab and think I will be using Ip Phone and PC together.

vlan 10 is Data for PC

vlan 15 is Voice for IP Phone

vlan 11 is Management

my vlan config for 3500xl switch is

vlan name Data 10

vlan name Management 11

vlan name Voice 15

interface fa0/1 switchport trunk encapsualtion dot1q

switchport mode trunk

___ I need to imput range below, what is the quickest way since this switch (3500xl) doesnt support the Int range command

will this work

int range 0/2  to 24

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport voice vlan 10

Switch(config-if)#spanning-tree portfast.

int 0/2  to 24

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport voice vlan 15

Switch(config-if)#spanning-tree portfast the range command.

do this for each port 2 t0 24?      

1365
Views
0
Helpful
20
Replies
CreatePlease to create content