Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3550-2950 duplex mismatch when both sides hardset

Hi,

I have inherited a 3550 trunked to a MAN with an extended vlan access port crossed over to a 2950 vlan 1 access port.

With both sides hardset to 100/full, the 2950 runs in 100/half causing the 3550 to see collisions and log %CDP-4-DUPLEX_MISMATCH.

When I set the port on the 3550 to auto speed/duplex, both sides came up at 100/full and the errors stopped.

Can someone explain this?

Thanks, Steve

c3550#show run int fas 0/2

Building configuration...

Current configuration : 206 bytes

!

interface FastEthernet0/2

description cross-over to c2950 fas0/1

switchport access vlan 2054

switchport mode access

switchport nonegotiate

no ip address

duplex full

speed 100

spanning-tree portfast

spanning-tree bpdufilter enable

end

c2950#show run int fas 0/1

Building configuration...

Current configuration : 157 bytes

!

interface FastEthernet0/1

description cross-over to c3550 fas0/2

switchport mode access

switchport nonegotiate

no ip address

duplex full

speed 100

end

6 REPLIES
Silver

Re: 3550-2950 duplex mismatch when both sides hardset

Hi Steve ,

The %CDP-4-DUPLEX_MISMATCH messages may be generated repeatedly when Cisco Discovery Protocol (CDP) has discovered a mismatch of duplex configuration between CDP neighbors.

This message occurs when a duplex mismatch is detected between CDP neighbors. It can also occur when switches are separated by a non-Cisco switch or hub. If CDP version 2 reports the link as a half-duplex when a port or interface on a CDP-enabled device has been configured or auto negotiated to full-duplex, the alternate device may not support CDP version 2. This causes the error to occur. It is a cosmetic issue.

CDP is useful for detecting errors as well as port and system statistics on neighboring Cisco devices. CDP is Cisco proprietary and works be sending packets to a well-known MAC address 01-00-0C-CC-CC-CC.

To resolve this issue, perform these steps:

To disable CDP version 2, issue the no cdp advertise-v2 command.

To check the CDP version running on the device, issue the show cdp command.

By default, Cisco switch ports and interfaces are set to Auto-negotiate.

**You must match the speed and duplex settings on both sides by setting both sides to Auto-negotiate or by hardcoding.

Note: This error message also occurs in Switches running CatOS system software.

Hope it helps you.

Thanks,

satish

New Member

Re: 3550-2950 duplex mismatch when both sides hardset

Thanks, Satish,

Are you certain it's only cosmetic?

show interface Fast 0/2 on the 3550 was picking up about 1000 input errors/CRC per hour. Both sides were hard coded to 100/full.

The input errors/CRC's stopped after I configured Fast 0/2 to auto speed and duplex and leaving the corresponding port on the 2950

hard coded to 100/full. CDP also stopped complaining.

Both switches are connected by a cat5 cross-over cable with no third party gear in the path.

Thanks again, Steve

Silver

Re: 3550-2950 duplex mismatch when both sides hardset

Hi Steve ,

The problem which you are facing may be a bug ? I searched for known issues ,but couldn't able to find it out.Open a TAC case with cisco to resolve the issue.

Thanks,

satish

Purple

Re: 3550-2950 duplex mismatch when both sides hardset

I would check to see if someone hasn't stuck another switch or hub between the 2950 and the 3550 .

Silver

Re: 3550-2950 duplex mismatch when both sides hardset

Hi,

Try the following command in 3550 switch side.

no power inline never

It is used during the bug on some IOS versions. Typicaly seen when the devices are hardset to 100 MB / full duplex and are running CDP-v2

Try this and let us know,

Rate if it does,

Rgs

New Member

Re: 3550-2950 duplex mismatch when both sides hardset

c3550(config-if)#no power inline

Command rejected: Not a Inline Power supported port.

Thank you all: I will pursue this TAC

673
Views
0
Helpful
6
Replies