Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

The real question is this. I know turning off STP can be dangerous, but my switch is actually connecting via one cable into the wall. Where it goes from there I'm not sure as I only manage the servers and PCs connected to my switch.

One day it stopped working and that's the error that showed up. Before then I was using it unmanaged and it was working fine.

If I can just disable STP, will that solve my problem? If not, what do I have to do to make this work? Each port connects to a machine on a different subnet, but they all got to the outside world over the same port connected into the wall. Each network has its own default gateway but I think they're virtual (I didn't set that up) so they all eventually end up at the same place. Any ideas?

7 REPLIES

Re: 3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

Hi,

configuring spanning-tree portfast on the "uplink" port would disable the normal spanning-tree mechanism.

New Member

Re: 3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

But is it ok to do, that's what I really need to know.

Re: 3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

If you are sure there is only ONE! uplink cabling, then it is ok. If you are not sure, than it is a risk to do it.

about den spanning tree log entry: i dont think that this is a problem. But if you would have more informations about that the configurationfrom both sides (your switchports and that one on the other side of the wall) would be necessary.

New Member

Re: 3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

From my switch to the wall, there is only cable. There isn't even a second port on the wall. But I don't know what's going beyond the wall.

Re: 3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

I think the best thing is that you try to get the information what is behind that wall ;)

Re: 3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

Hi Steve,

I searched a docuemnt regarding the error captured by syslog. This is what it says.

Lets say there are 2 switches, 1 operating with PVST+ & one with Common STP. now these 2 switches have to be connected with dot1Q trunk on both ends with same native VLAN.

The switch with PVST+ sends BPDU which contains VLAN ID that helps it recognise the native vlans. In case of discrepancy, the corresponding ports are put into a "PVID-inconsistent" or "type-inconsistent" state, which effectively blocks the traffic in the corresponding VLAN on a corresponding port.

here is the link for your reference:

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00801d11a0.shtml

how to avoid this porobably experts can answer.

New Member

Re: 3550 switch complaining about %SPANTREE-2-RECV_1Q_NON_TRUNK

Well, I got it working. All I had to do was filter BPDU messages.

856
Views
0
Helpful
7
Replies
CreatePlease to create content