Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3560/3750 IP Base - PIM Stub Routing

I'm trying to understand how far I can push these 3560/3750 switches running ip base.

I know they now support OSPF -- which is great.  But for ip multicast, they only support "PIM Stub Routing".

I've read and re-read the config guide.  But I still don't completely understand.  Quotes are from the config guide. 

The IP base image contains only PIM stub routing. The IP services image contains complete multicast routing. On a switch running the IP base image, if you try to configure a VLAN interface with PIM dense-mode, sparse-mode, or dense-sparse-mode, the configuration is not allowed.

OK, so I can only configure full PIM mode on routed "uplinks" (physical ports configured with an ip address).  SVI's (interface vlan x) can only have "ip pim passive".

In a network using PIM stub routing, the only allowable route for IP traffic to the user is through a switch that is configured with PIM stub routing.

Huh?  Is that an attempt at saying the switch should be the user's default gateway?  Or a default route must be learned through a physical routed uplink?

PIM passive interfaces are connected to Layer 2 access domains, such as VLANs, or to interfaces that are connected to other Layer 2 devices. Only directly connected multicast (IGMP) receivers and sources are allowed in the Layer 2 access domains. The PIM passive interfaces do not send or process any received PIM control packets.

OK, so if I have 2 SVI's on a switch (SVI x and SVI y) with "ip pim passive" configured on each, I can have a source in SVI x and a receiver in SVI y and shouldn't have a problem.  IGMP is needed, but not PIM for this to work.  Correct?

When using PIM stub routing, you should configure the distribution and remote routers to use IP multicast routing and configure only the switch as a PIM stub router. The switch does not route transit traffic between distribution routers. You also need to configure a routed uplink port on the switch. The switch uplink port cannot be used with SVIs. If you need PIM for an SVI uplink port, you should upgrade to the IP services feature set.

OK.  That makes sense.  Sacrifices must be made.

You must also configure EIGRP stub routing when configuring PIM stub routing on the switch.

What?!?!?  Is there some special interaction between EIGRP stub routing and PIM stub routing?  A default route through OSPF isn't good enough?

The redundant PIM stub router topology is not supported. The redundant topology exists when there is more than one PIM router forwarding multicast traffic to a single access domain. PIM messages are blocked, and the PIM asset and designated router election mechanisms are not supported on the PIM passive interfaces. Only the nonredundant access router topology is supported by the PIM stub feature. By using a nonredundant topology, the PIM passive interface assumes that it is the only interface and designated router on that access domain.

OK, since I can't have PIM neighbors on SVI interfaces, we can't have redundant "default gateways" for the subnet.  With the stacks providing most of the redundancy, I can probably live with this.

The PIM stub feature is enforced in the IP base image. If you upgrade to a higher software version, the PIM stub configuration remains until you reconfigure the interfaces.

This makes sense.

9 REPLIES
Cisco Employee

3560/3750 IP Base - PIM Stub Routing

Hello,

I am reading the following document:

http://www.cisco.com/en/US/partner/products/hw/switches/ps5023/products_configuration_example09186a008089a65f.shtml

OK, so I can only configure full PIM mode on routed "uplinks" (physical  ports configured with an ip address).  SVI's (interface vlan x) can only  have "ip pim passive".

Yes. "Uplinks" will be full PIM, "downlinks" will be PIM passive.

In a network using PIM stub routing,  the only allowable route for IP traffic to the user is through a switch  that is configured with PIM stub routing.

Huh?  Is  that an attempt at saying the switch should be the user's default  gateway?  Or a default route must be learned through a physical routed  uplink?

I guess what they are saying here that the multicast traffic must flow through the switch running the PIM stub. In particular, it is not allowed to have a VLAN with multiple gateways (possibly bundled in some FHRP) with the multicast arriving through a different gateway than the PIM stub-enabled device. The reason is that because the PIM stub does not speak PIM at all on its passive interfaces, it does not elect any PIM designated routers, forwarders, nor does it engage into Assert mechanism, thereby opening a hole for duplication of multicast stream delivery.

OK, so if I have 2 SVI's on a switch (SVI x and SVI y) with "ip pim  passive" configured on each, I can have a source in SVI x and a receiver  in SVI y and shouldn't have a problem.  IGMP is needed, but not PIM for  this to work.  Correct?

This should be correct. PIM is not necessary at all in this scenario as no PIM is essentially required here.

What?!?!?  Is there some special interaction between EIGRP stub routing  and PIM stub routing?  A default route through OSPF isn't good enough?

I do not believe that there is any interaction between the EIGRP stub and PIM stub. However, Cisco obviously tries to avoid the possibility of the access switch becoming a backup routed path between the distribution switches. This is trivially avoided by the EIGRP stub feature. The document I've referenced at the beginning says specifically:

The PIM stub router does not route the transit  traffic between distribution routers. This behavior is enforced by  unicast (EIGRP) stub routing. The proper unicast stub routing  configuration is required to assist this PIM stub router behavior. The  PIM stub feature does not prevent router administrator configuring RIP,  static routes, or PIM RP to bypass this restriction.

Best regards,

Peter

New Member

3560/3750 IP Base - PIM Stub Routing

OK, so if I have 2 SVI's on a switch (SVI x and SVI y) with "ip pim passive" configured on each, I can have a source in SVI x and a receiver in SVI y and shouldn't have a problem. IGMP is needed, but not PIM for this to work. Correct?

So I gave this a go on a 3750 with IP Base

!

ip multicast-routing distributed

!

interface Vlan2129

ip address 10.66.129.1 255.255.255.0

ip pim passive

!

interface Vlan2130

ip address 10.66.130.1 255.255.255.0

ip helper-address 10.66.129.10

ip pim passive

No joy using MDT Multicast across vlans - (within the VLAN fine)

switch#sh ip multicast

  Multicast Routing: enabled

  Multicast Multipath: disabled

  Multicast Route limit: No limit

  Multicast Triggered RPF check: enabled

  Multicast Fallback group mode: Sparse

Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface

*,239.255.255.254              10.66.129.10    01:18:37 02:36 2A     Vl2129

*,239.0.0.108                  10.66.129.11    00:09:43 02:36 2A     Vl2129

need IP Services I reckon

New Member

3560/3750 IP Base - PIM Stub Routing

The assumption is you have PIM neighbors upstream off a physical routed interface.

I've made this work without by adding a loopback on the stub switch and putting regular ip-pim sparse-mode on it.  Then "announce" an rp.

interface Loopback0

ip address 10.255.255.101 255.255.255.255

ip pim sparse-mode

ip pim bsr-candidate Loopback0 32 101

ip pim rp-candidate Loopback0 interval 10 priority 101

Then put "pim passive" on your other interfaces.

New Member

3560/3750 IP Base - PIM Stub Routing

Perfect ds6123!! thankyou!

worked a treat, MDT across vlans using multicast on a 3750

New Member

3560/3750 IP Base - PIM Stub Routing

Hi DS


I’m trying to put multicast MDT into production on 2 x 4507 core switches (+ 3 x 4500 access switches)


 interface Loopback0
ip address 10.255.255.101 255.255.255.255
ip pim sparse-mode

ip pim bsr-candidate Loopback0 32 101
ip pim rp-candidate Loopback0 interval 10 priority 101

worked on my 3750 test environment as you suggested

Is it the same for new 4500’s?
I only have

Ip multicast-routing

With

ip pim sparse-dense-mode
on each data vlan on the one core so far


Kind Regards

New Member

I have a similar situation

I have a similar situation with 3750x ipbase switches, but i cannot use phisical IP interfaces for the uplink. 

Any way to achieve this with SVI uplinks?

szenario:

http://imgur.com/a/gl4tg

New Member

Did you find an answer for

Did you find an answer for this,samuel? I'm in a similar situation.

Let me know what your solution was.

New Member

I have a similar situation

I have a similar situation with 3750x ipbase switches, but i cannot use phisical IP interfaces for the uplink. 

Any way to achieve this with SVI uplinks?

szenario:

http://imgur.com/a/gl4tg

New Member

3560/3750 IP Base - PIM Stub Routing

Hi

Catalyst 3750 stack will be running IP Base image configured as EIGRP stub with one physical link to two 6500 switches. Catalyst 6500 combined to form VSS. Hence connection between 3750 stack and VSS will be a  single layer 3 logical connection  (Layer 3 Port Channel).

Multicast Stub (PIM-DM) will be configured on the Port Channel interface at both ends of the EtherChannel link with the VSS end configured for passive mode.

Should this work?

Has anybody got this working?

Thanks

Gurmakh

5894
Views
5
Helpful
9
Replies