Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

3560 Interface Input & CRC error

Dear all,

We are facing problem with one of switch port.

Our Server is directly connected to switch port 0/30 ,after couple of hours we found input & CRC errors on the interface and port goes down and restart automatically.

We have cleared the counters many times but input,crc error came again.

I have one question regarding this. Are Input & CRC errors the reason for the port restart? I am not sure that input error is capable to restart the port.

Your help is highly appreciated

With regards,

kareem

7 REPLIES

Re: 3560 Switch port is flapping and going down

Dear all,

We are facing problem with one of switch port.

our Server is directly connected to switch port 0/30 ,after couople of hours the port went down .

Status of port is notconnected . I cheked the logs on switch . Port flapped for 2 to 3 times and went down.

There were input and output errors on port. We cleared counters and changed cable but same issue persist.

We want to known:

  • Because of  input and output errors port will go down
  • how to check wheather the problem is from server's NIC interface, because we change switch port and tried.
  • Why port is flapping and going down

Your help is highly appreciated

With regards,

kareem

Hi Kareem,

Flaping of ports by server can be a reason that server NIC is connected to two switch ports at switch and proper teaming is not been done at server end and also check the duplex and speed setting at switch end with server connected to it.

and if possible can you paste your show interface output in which server port is connected.

Hope to Help

Ganesh.H

Community Member

Re: 3560 Switch port is flapping and going down

Dear Ganesh,

Yes, Server is connected to two different switches. But we are getting errors on only one switch. Configuration is simple:

!
interface GigabitEthernet0/30
description "connected to server"
switchport access vlan 100
switchport mode access
spanning-tree portfast
end

!

Switch#show interfaces gi0/30 status

Port      Name                         Status       Vlan       Duplex   Speed   Type
Gi0/30  "connected to server" connected    100        a-full     a-1000 10/100/1000Base


We have just changed the switch interface to port gi 0/31 from gi 0/30 for testing.

What do you recommend to test on server end?

Regards,

Anser

Re: 3560 Switch port is flapping and going down

Dear Ganesh,

Yes, Server is connected to two different switches. But we are getting errors on only one switch. Configuration is simple:

!
interface GigabitEthernet0/30
description "connected to server"
switchport access vlan 100
switchport mode access
spanning-tree portfast
end

!

Switch#show interfaces gi0/30 status

Port      Name                         Status       Vlan       Duplex   Speed   Type
Gi0/30  "connected to server" connected    100        a-full     a-1000 10/100/1000Base


We have just changed the switch interface to port gi 0/31 from gi 0/30 for testing.

What do you recommend to test on server end?

Regards,

Anser

Hi Anser,

Just check the Teaming configuration at server end if it is Active/Active then configure it into Active/Passive fashion at server end and then check.

If possible please paste the show interface gi0/30 output.

HTH

Ganesh.H

Community Member

Re: 3560 Switch port is flapping and going down

Dear Ganesh,

Switch#show interfaces gi0/31
GigabitEthernet0/31 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000a.b8xx.xxxx (bia 000a.b8xx.xxxx)
  Description: "connected to server"
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2000 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 2 packets/sec
     633786019 packets input, 894843224 bytes, 0 no buffer
     Received 38866 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 7 multicast, 0 pause input
     0 input packets with dribble condition detected
     454528365 packets output, 3750704538 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Regards,

Anser

Re: 3560 Switch port is flapping and going down

Re: 3560 Switch port is flapping and going down                                                                                                                                                                                                                                                                

                                                                  

Dear Ganesh,

Switch#show interfaces gi0/31
GigabitEthernet0/31 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000a.b8xx.xxxx (bia 000a.b8xx.xxxx)
  Description: "connected to server"
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2000 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 2 packets/sec
     633786019 packets input, 894843224 bytes, 0 no buffer
     Received 38866 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 7 multicast, 0 pause input
     0 input packets with dribble condition detected
     454528365 packets output, 3750704538 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Regards,

Anser

Hi Anser,

Above output is not having any error in the shown log, I would suggests you to check the Teaming or Bonding configuration at server end.

Tell me onething Is your server both the nic is connected to same switch or different switch,If same switch then i would suggests to make etherchannel between the switch port end and server end and if different then configure at server end as Active/passive fashion and then check.

HTH

Ganesh.H

Community Member

Re: 3560 Switch port is flapping and going down

Dear Ganesh,

As I said to you that we have changed to switch interface to gi0/31 from gi0/30 for test the input errors.

Server is connected to two different switches. I will forward your queries to Systems team to check the server end.

Thanks for the response.

Regards,

Anser

Hall of Fame Super Gold

Re: 3560 Switch port is flapping and going down

I'm going to agree with Ganesh.  Check the configuration of your server.  Disconnect/disable 1 of 2 and verify if the ports are still flapping.  If you want to test the cable, the 3560 support "test cable-diagnostic tdr interface" command.  You can see the result by using the command "sh cable-diagnostic tdr interface".

2876
Views
3
Helpful
7
Replies
CreatePlease to create content