Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3560 not passing large packets across trunk port

Hi all, I have a strange problem:

I have a 3560 with 8 VLANs configured. Each VLAN has a Layer 3 (IP) interface configured. On 4 of the 24-ports in the switch I have them configured to support a voice and data vlan (dot1q trunked) as I have Mitel 5224 IP phones plugged into the these ports. Users of these 4 phones have there data connection via the switch on the Mitel phone. The phones all work fine, register, get an ip and are in the correct VLAN. The PCs connected to them do get a DHCP address from the data VLAN but after testing cannot send pings or connect to many TCP services that use packets larger than 1468.

.

Here is the IOS port configuration for one of these 4 ports that are causing the problem:

******

interface GigabitEthernet0/10

switchport trunk encapsulation dot1q

switchport trunk native vlan 6

switchport mode trunk

switchport voice vlan 100

spanning-tree portfast

*****

Here is my Layer3 VLAN config for VLAN 6 (DATA):

****

interface Vlan6

ip address 10.6.0.1 255.255.0.0

ip helper-address 10.1.1.251

ip dhcp relay information trusted

****

As a test, if I configured one of these ports in access mode, then I all data, large of small, TCP or ICMP and routing between other VLANs on the 3560 all works fine, as soon as I configure it is a trunk port, then the problem comes!!

VLAN 1 - 6 are for data, VLAN 100 is voice

Any ideas?

3 REPLIES

Re: 3560 not passing large packets across trunk port

Are these the only ports with Mittel phones?

In that case, you should try what happens when you connect a PC directly, perhaps it is the IP phone that is causing this.

Regards,

Leo

Re: 3560 not passing large packets across trunk port

Hi

Pls increase your switch's system mtu to support jumbo frames.

system mtu 9000

regards

vanesh k

New Member

Re: 3560 not passing large packets across trunk port

I have been doing some more testing and I have now discovered that large packet transmission was something to do with dot1q tagging of the native vlan. I thought this was disabled but wasn'.

.

I used the command "no vlan dot1q tag native" and this has fixed this issue!!

263
Views
0
Helpful
3
Replies
CreatePlease to create content