Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Hall of Fame Super Silver

3560 Upgrade Recovery

Hello Netpros,

I am attempting to upgrade a 3560 switch. I initially tried to use the CLI procedure ("archive download-sw /overwrite /reload ftp://" ... etc.) but then realized after that failed that I did not have access to my ftp server from the switch's location. So, I thought I would go in via the switch's http interface and upgrade there using an image on my workstation. Unfortunately, the switch believes the first attempt is still in progress. It reports "software upgrade is in progress in another session". How can I reset that state so that I can perform the upgrade via the web UI? A reload of the switch did not do it. Everything else is operating normally. A dir of the file system did not show me any obvious stub directories or files that might flag this condition.

I am upgrading from 12.2(25)SEB4 to 12.2(55)SE on a WS-C3560G-48TS. The 12.2(55)SE image I am using is valid as it has been used on multiple other 3560s in other locations.

Here is the current file listing on the problem switch:


#dir flash:
Directory of flash:/

    2  -rwx         676   Mar 1 1993 00:02:22 +00:00  vlan.dat
    3  -rwx        2772   Mar 1 1993 01:29:41 +00:00  config.text.old
    5  drwx         192   Mar 1 1993 00:08:47 +00:00  c3560-ipservices-mz.122-25.SEB4
  358  -rwx       11726  Sep 16 2010 21:13:54 +00:00  config.text
  359  -rwx          27  Sep 16 2010 21:13:54 +00:00  private-config.text

32514048 bytes total (24587776 bytes free)

4 REPLIES
VIP Super Bronze

Re: 3560 Upgrade Recovery

Hi,

Can you telnet to the switch and do a "sh tcp" and then "clear tcp local x.x.x.xx 21 remote x.x.x.xx ?

HTH

Reza

Hall of Fame Super Silver

Re: 3560 Upgrade Recovery

Thanks for the suggestion.

I checked that. There is no tcp port 21 (ftp) session active:


#sh tcp br                                        
TCB       Local Address           Foreign Address        (state)
029B8470  10.10.63.5.11071        172.17.25.13.49        TIMEWAIT
0321B420  10.10.63.5.11070        172.17.25.13.49        TIMEWAIT
030A80C0  10.10.63.5.23           10.10.49.159.50681     ESTAB

The port 49 connections are to my TACACS server. The port 23 connection is my telnet session.

Re: 3560 Upgrade Recovery

This is probably one of the fuzzy problems with the web GUI.

Try to setup a tftp server on a connected subnet and retry from CLI using that instead of ftp.

It has always worked fine for me that way.

regards,

Leo

Hall of Fame Super Silver

Re: 3560 Upgrade Recovery

I'll probably have to fall back to an ftp server-based upgrade. I don't have one under my own adminstration handy, so I'll need to get a sys admin to add a route on the one I usually use so it can get to this remote office subnet.

The status of an upgrade being in progress must be stored somewhere in nvram, but I can't figure out where. I navigated all though the flash filesystem looking for any new files and saw nothing. I would think the reload I did should have cleared any volatile memory storage.

Thanks for the advice.

452
Views
5
Helpful
4
Replies
CreatePlease login to create content