Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Blue

3640 Terminal Server

Hello:

I never knew a Cisco 3640 router can act as a terminal server. I am confused.

When I telnet to this terminal server device in the lab, this is the configuration I see.

testlab#sh run

Building configuration...

Current configuration : 3726 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname testlab

!

enable password

!

ip subnet-zero

!

!

!

!

!

!

interface BRI0/0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet0/0

ip address 10.36.250.22 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.36.250.250

ip http server

!

!

menu testlabTS title ^CCCCCC

You are currently logged into the ACS Tarrytown testLAB Terminal

^C

menu testlabTS text 1 Press 1 to console into R1

menu testlabTS command 1 telnet 10.36.250.22 2033

menu testlabTS text 2 Press 2 to console into R2

menu testlabTS command 2 telnet 10.36.250.22 2034

menu testlabTS text 3 Press 3 to console into R3

menu testlabTS command 3 telnet 10.36.250.22 2035

menu testlabTS text 4 Press 4 to console into R4

menu testlabTS command 4 telnet 10.36.250.22 2036

menu testlabTS text 5 Press 5 to console into R5

menu testlabTS command 5 telnet 10.36.250.22 2037

menu testlabTS text 6 Press 6 to console into R6

menu testlabTS command 6 telnet 10.36.250.22 2038

menu testlabTS text 7 Press 7 to console into Frame Cloud

menu testlabTS command 7 telnet 10.36.250.22 2039

menu testlabTS text 8 Press 8 to console into BGP1

menu testlabTS command 8 telnet 10.36.250.22 2040

menu testlabTS text 9 Press 9 to console into BGP2

menu testlabTS command 9 telnet 10.36.250.22 2056

menu testlabTS text 10 Press 10 to console into SW1 (3750)

menu testlabTS command 10 telnet 10.36.250.22 2041

menu testlabTS text 11 Press 11 to console into SW2 (3550)

menu testlabTS command 11 telnet 10.36.250.22 2042

menu testlabTS text 12 Press 12 to console into SW3 (3750)

menu testlabTS command 12 telnet 10.36.250.22 2043

menu testlabTS text 13 Press 13 to console into SW4 (3550)

menu testlabTS command 13 telnet 10.36.250.22 2044

menu testlabTS text 14 Press 14 to console into cable1/5 (not connected)

menu testlabTS command 14 telnet 10.36.250.22 2045

menu testlabTS text 15 Press 15 to console into cable1/6 (not connected)

menu testlabTS command 15 telnet 10.36.250.22 2046

menu testlabTS text 16 Press 16 to console into cable1/7 (not connected)

menu testlabTS command 16 telnet 10.36.250.22 2047

menu testlabTS text 17 Press 17 to console into cable1/8 (not connected)

menu testlabTS command 17 telnet 10.36.250.22 2048

menu testlabTS text 18 Press 18 to console into cable2/1 MOJEF301-WR01

menu testlabTS command 18 telnet 10.36.250.22 2049

menu testlabTS text 19 Press 19 to console into cable2/2 NJLEO2CH-WR01

menu testlabTS command 19 telnet 10.36.250.22 2050

menu testlabTS text 20 Press 20 to console into Louisiana-FW01

menu testlabTS command 20 telnet 10.36.250.22 2051

menu testlabTS text X Press X to exit the menu

menu testlabTS command X menu-exit

menu testlabTS clear-screen

alias exec mt menu testlabTS

!

line con 0

line 33 64

session-timeout 20

flush-at-activation

no exec

transport input telnet

transport output telnet

autohangup

line aux 0

no exec

transport input all

line vty 0 4

password

login

autocommand menu testlabTS

line vty 5 15

password

login

autocommand menu testlabTS

!

end

testlab#

I do remember the old Cisco 2511s that had a dozen or so ASYNC ports to which you would connect the console ports of the devices you want to access remotely.

I dont see any such interfaces on this 3640.

Any thoughts?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: 3640 Terminal Server

I am trying to find a link to a Cisco page that will explain that configuration above. I mean the "menu......" jazz that dictates what the output is that the user will see when telneting to the box.

See:

http://www.cisco.com/en/US/docs/ios/fundamentals/configuration/guide/cf_connections_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1001601

4 REPLIES
Hall of Fame Super Bronze

Re: 3640 Terminal Server

Victor,

This portion is the terminal server connection:

line 33 64

session-timeout 20

flush-at-activation

no exec

transport input telnet

transport output telnet

autohangup

Here is more information on Terminal Server on 3600 Series router:

http://www.cisco.com/en/US/products/hw/routers/ps274/products_tech_note09186a00801ca70b.shtml

HTH,

__

Edison.

Blue

Re: 3640 Terminal Server

Edison:

Thank you very much, my friend. That helps a lot. I see then that the 3640 is using an NM32A virtual ASYNC module that uses a high density connector cable with RJ-45s on the other end ( a spider cable, as we used to call them). Got it.

I am trying to find a link to a Cisco page that will explain that configuration above. I mean the "menu......" jazz that dictates what the output is that the user will see when telneting to the box.

Thanks

Victor

Hall of Fame Super Bronze

Re: 3640 Terminal Server

I am trying to find a link to a Cisco page that will explain that configuration above. I mean the "menu......" jazz that dictates what the output is that the user will see when telneting to the box.

See:

http://www.cisco.com/en/US/docs/ios/fundamentals/configuration/guide/cf_connections_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1001601

Blue

Re: 3640 Terminal Server

Thanks, Edison!

I couldnt find this link if my life depended on it! lol

VL

1103
Views
5
Helpful
4
Replies
CreatePlease login to create content