Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

3650 routed port sending eigrp advertisements from SVI

My production setup involves a 3560 connected to a 4506 via routed fiber ports on both devices.  The 4506 is throwing EIGRP neighbor not on common subnet from that interface.  The address that is showing is from an SVI on the 3560.  I was able to reproduce this at my desk with 2 3560s.  Relevant config snippets are below.  The switches are connected with sx optics in G0/1.  I can't reproduce this when using a copper crossover between two Fe ports.  The switches are running c3560-ipservicesk9-mz.122-53.SE  Any ideas?  This has got me stumped.

SW 1:
interface GigabitEthernet0/1
no switchport
ip address 10.0.0.1 255.255.255.252
!
interface Vlan5
ip address 10.0.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0

Geting this error on SW1:
EIGRP-IPv4(1): Neighbor 10.0.2.1 not on common subnet for GigabitEthernet0/1


SW2:
interface GigabitEthernet0/1
no switchport
ip address 10.0.0.2 255.255.255.252
!
interface Vlan6
ip address 10.0.2.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0


Getting this error on SW2:
EIGRP-IPv4(1): Neighbor 10.0.1.1 not on common subnet for GigabitEthernet0/1

Thanks in advance!

Rick

2 REPLIES
Hall of Fame Super Silver

Re: 3650 routed port sending eigrp advertisements from SVI

hello Rick,

this looks like to be a SW bug, because routed ports are not member of any Vlans and should not sent packets originated by an SVI.

What is the frequency of the message every 5 seconds or from time to time (5sec default EIGRP hello timers on lan interfaces)

if you post a sh ver | inc image it is possible to look for possible SW bugs

Hope to help

Giuseppe

Purple

Re: 3650 routed port sending eigrp advertisements from SVI

   Verify ip classless is configured also you should passive interface any interfaces  including SVI's that are not connecting links to other network routing devices..  See if the messages are still there after  you passive interface the SVI's .  I have seen that before and I can't remember what we did to fix it .

710
Views
0
Helpful
2
Replies
CreatePlease to create content