cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1360
Views
0
Helpful
8
Replies

3745 & NM-ESW-16 Issues

3745 Running 12.3(14)T7. I have a NM-ESW-16 (16-Port FE Network Module w/ Inline Power). I created a VLAN interface, DHCP Scope. Connected clients show up in the DHCP lease table, but clients do not get an address, the client ARP table shows an all-zeros MAC address for the routers VLAN interface. I do not want to enable the 3745 FE0/1 or 0/0 interface as this will be a stand-alone network. Anyhow, I had this working on a previos IOS release with another config. I must be missing something as the connected clients cannot ping the VLAN interface - even with a static address. Here's a snippet of the config ... the Unity Express NM interface config is related as it's tied to the VLAN interface:

ip dhcp excluded-address 10.1.10.1 10.1.10.10

ip dhcp pool VOICE

network 10.1.10.0 255.255.255.0

default-router 10.1.10.1

option 150 ip 10.1.10.1

interface FastEthernet3/0 (0 through 15 all the same)

switchport access vlan 100

spanning-tree portfast

interface Vlan1

no ip address

!

interface Vlan100

ip address 10.1.10.1 255.255.255.0

interface Service-Engine2/0

ip unnumbered Vlan100

service-module ip address 10.1.10.2 255.255.255.0

service-module ip default-gateway 10.1.10.1

ip classless

ip route 10.1.10.2 255.255.255.255 Service-Engine2/0

8 Replies 8

glen.grant
VIP Alumni
VIP Alumni

Did you actually create vlan 100 in the vlan database ? Won't work unless you do .

conf t

vlan database

vlan 100

exit

Sorry - yes, I did.

VLAN ISL Id: 100

Name: VOICE

Media Type: Ethernet

VLAN 802.10 Id: 100100

State: Operational

MTU: 1500

amit-singh
Level 8
Level 8

What does " show interface vlan 100 " tells you.

Also " show vlan "

-amit singh

Router#show interface vlan 100

Vlan100 is up, line protocol is up

Hardware is EtherSVI, address is 000d.ede3.d670 (bia 000d.ede3.d670)

Internet address is 10.1.10.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:19, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 306

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

324 packets input, 112710 bytes, 0 no buffer

Received 324 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 packets output, 0 bytes, 0 underruns

0 output errors, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

Router#

"Show VLAN" isn't valid, though here's the "VLAN DATABASE - SHOW CURRENT" for VLAN 100

VLAN ISL Id: 100

Name: VOICE

Media Type: Ethernet

VLAN 802.10 Id: 100100

State: Operational

MTU: 1500

amit-singh
Level 8
Level 8

Why you have given, ip unnumbered under the serice-engine interface when you already have an IP assign to it. Could you try taking this command out of that interface, just for testing purpose and see if that works.

Let us know. Also try to paste the whole router confoguration.

-amit singh

Amit,

Thanks. Actually I did remove the Service Engine to make sure it wasn't affecting anything.

I erased the config and started over ... here's the new basic config:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no logging buffered

!

no aaa new-model

!

resource policy

!

no network-clock-participate slot 1

no network-clock-participate wic 1

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.1.10.1 10.1.10.10

!

ip dhcp pool VOICE

network 10.1.10.0 255.255.255.0

option 150 ip 10.1.10.1

!

!

no ftp-server write-enable

voice-card 1

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0

framing sf

linecode ami

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet3/0

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/1

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/2

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/3

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/4

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/5

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/6

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/7

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/8

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/9

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/10

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/11

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/12

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/13

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/14

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet3/15

switchport access vlan 100

spanning-tree portfast

!

interface FastEthernet4/0

!

interface FastEthernet4/1

!

interface FastEthernet4/2

!

interface FastEthernet4/3

!

interface FastEthernet4/4

!

interface FastEthernet4/5

!

interface FastEthernet4/6

!

interface FastEthernet4/7

!

interface FastEthernet4/8

!

interface FastEthernet4/9

!

interface FastEthernet4/10

!

interface FastEthernet4/11

!

interface FastEthernet4/12

!

interface FastEthernet4/13

!

interface FastEthernet4/14

!

interface FastEthernet4/15

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

ip address 10.1.10.1 255.255.255.0

!

ip classless

!

ip http server

!

!

!

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

Thanks!

Might try doing a debug dhcp and see if that sheds any light on what may be going on .

Problem solved; I had added a second NM-ESW-16 around the time of my upgrade (and when the issue started). Turns out dual NM-ESW-16 modules without the use of the external GB link cable causes a corruption in the VLAN routing (a bug of sorts), according to TAC. I removed the second NM-ESW-16 and all worked fine. Thanks all...

Review Cisco Networking products for a $25 gift card