Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750/3750E stack - feature mismatch

I have a 3750E-24PD-E switch that I'm trying to create a stack with a 3750-48P-E.  Whenever the new switch is attached and booted, it fails to join the stack with a "feature mismatch" error.  I don't have anything configured (to my knowledge) on the 3750E that should preclude the addition of the 3750.  I'm running basically the identical configuration in several other 3750 stacks that contain 3750Es and 3750s.

Both are running the same code version (122-55.SE4) and both are licensed for ipservices.

The output of 'sh switch detail':

Switch/Stack Mac Address : 0025.8489.9400

                                           H/W   Current

Switch#  Role   Mac Address     Priority Version  State

----------------------------------------------------------

*1       Master 0025.8489.9400     5      1       Ready

2       Member 0021.a12a.b600     2      0       Feature Mismatch

I've tried two different 3750s and both produce the same results.  I've also tried provisioning a 3750 into the stack before connecting and booting it with a '(config)# switch 2 provision ws-c3750-48P', and get the following error:

HCOMP: hcomp_switch_provision_req hw ver(0) not compatible with switch (2)

%Command rejected: feature compatibility check failed for switch 2

I can provision a 'ws-c3750e-48PD', so there's something going on with the 3750E where it just won't deal with the addition of a non-E 3750.  Any ideas?

Everyone's tags (2)
8 REPLIES
Purple

3750/3750E stack - feature mismatch

  You have some feature on the 3750E stack that the 3750 cannot do so you get a feature mismatch.  This doc explains a little about it.

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps5023/prod_presentation09186a0080161372.pdf

New Member

3750/3750E stack - feature mismatch

Thanks for the response and link.  I read through that document yesterday to no avail.  I really can't see what feature the 3750E would be running that the the 3750 doesn't support.  Like I said above, I'm running basically the same config in a bunch of other stacks.  Maybe I'm overlooking something--here's the running-config from the 3750E in question:

!

! Last configuration change at 10:35:42 CST Fri Jan 27 2012 by xxx

! NVRAM config last updated at 10:20:19 CST Fri Jan 27 2012 by xxx

!

version 12.2

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname s1

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret 5 xxxxxxxxxxxxxxxxxxx

!

username jtw password 7 xxxxxxxxxxxxxxxxxxxxx

!

!

macro global description cisco-global

aaa new-model

!

!

!

!

!

aaa session-id common

clock timezone CST -6

clock summer-time CDT recurring

switch 1 provision ws-c3750e-24pd

system mtu routing 1500

no ip source-route

ip routing

!

!

no ip domain-lookup

ip domain-name xxx.xxx

ip multicast-routing distributed

vtp mode transparent

udld aggressive

!

mls qos map cos-dscp 0 8 16 24 32 46 46 56

!

crypto pki trustpoint TP-self-signed-2223608832

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2223608832

revocation-check none

rsakeypair TP-self-signed-2223608832

!

!

crypto pki certificate chain TP-self-signed-2223608832

certificate self-signed 01

  ![redacted]

  quit

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree portfast bpduguard default

spanning-tree extend system-id

!

!

!

errdisable recovery cause bpduguard

errdisable recovery cause link-flap

errdisable recovery cause storm-control

errdisable recovery interval 60

!

vlan internal allocation policy ascending

!

vlan 2

name access-vlan

!

vlan 50

name management

!

vlan 100

name WirelessAccessPoints

!

vlan 110

name SecurityCameras

!

ip ssh time-out 60

ip ssh version 2

!

!

!

interface Loopback0

ip address 10.6.0.66 255.255.255.255

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

!

interface GigabitEthernet1/0/1

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/2

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/3

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/4

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/5

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/6

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/7

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/8

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/9

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/10

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/11

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/12

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/13

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/14

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/15

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/16

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/17

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/18

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/19

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/20

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/21

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/22

switchport access vlan 100

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/23

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/24

switchport access vlan 2

power inline port maximum 20000

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

!

interface GigabitEthernet1/0/25

description core1

no switchport

ip address 10.6.0.2 255.255.255.252

no ip redirects

ip pim sparse-dense-mode

!

interface GigabitEthernet1/0/26

description core2

no switchport

ip address 10.6.0.6 255.255.255.252

no ip redirects

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface TenGigabitEthernet1/0/1

!

interface TenGigabitEthernet1/0/2

!

interface Vlan1

no ip address

!

interface Vlan2

ip address 10.6.6.1 255.255.255.0

ip verify unicast source reachable-via any

ip helper-address 10.10.1.22

ip helper-address 10.10.1.31

no ip redirects

ip directed-broadcast 102

ip pim sparse-dense-mode

!

interface Vlan50

ip address 10.6.50.1 255.255.255.0

ip access-group vlan50out out

no ip redirects

!

interface Vlan100

description WirelessAccessPoints

ip address 10.6.100.1 255.255.255.0

ip access-group vlan100in in

ip access-group vlan100out out

ip helper-address 10.10.1.22

ip helper-address 10.10.1.31

no ip redirects

!

interface Vlan110

description SecurityCameras

ip address 10.6.110.1 255.255.255.0

ip access-group vlan110in in

ip access-group vlan110out out

ip helper-address 10.10.1.22

ip helper-address 10.10.1.31

no ip redirects

!

router ospf 1

router-id 10.6.0.66

log-adjacency-changes

network 10.0.0.0 0.255.255.255 area 0

!

ip classless

!

no ip http server

no ip http secure-server

!

ip access-list extended vlan100in

![redacted]

ip access-list extended vlan100out

![redacted]

!

ip sla enable reaction-alerts

logging facility local5

logging source-interface Loopback0

!

!

!

line con 0

line vty 0 4

exec-timeout 0 0

transport input ssh

line vty 5 15

exec-timeout 0 0

transport input ssh

!

end

Hall of Fame Super Gold

3750/3750E stack - feature mismatch

Can you kindly show the complete output of the "sh version" of both units of 3750?

If your 3750E is running the "universal" IOS file, can you also add the command "sh license"?

New Member

3750/3750E stack - feature mismatch

Here's the output from the 3750E.  I don't have access to the 3750 right now but since the 3750E won't even accept a provisional 3750 I don't think it's an issue with one of the two actual 3750s I've tried.

Here's the output from sh ver and sh license on the 3750E:

Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 12.2(55)SE4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Tue 06-Sep-11 02:09 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x02800000

ROM: Bootstrap program is C3750E boot loader

BOOTLDR: C3750E Boot Loader (C3750E-HBOOT-M) Version 12.2(44r)SE3, RELEASE SOFTWARE (fc3)

s1 uptime is 4 weeks, 2 days, 4 hours, 4 minutes

System returned to ROM by power-on

System restarted at 13:50:16 CST Wed Dec 28 2011

System image file is "flash:/c3750e-universalk9-mz.122-55.SE4.bin"

[trimmed]

License Level: ipservices

License Type: Permanent

Next reload license Level: ipservices

cisco WS-C3750E-24PD (PowerPC405) processor (revision G0) with 262144K bytes of memory.

Processor board ID FDO1320R095

Last reset from power-on

5 Virtual Ethernet interfaces

1 FastEthernet interface

28 Gigabit Ethernet interfaces

2 Ten Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : 00:25:84:89:94:00

Motherboard assembly number     : 73-11176-13

Motherboard serial number       : FDO13200AZ7

Model revision number           : G0

Motherboard revision number     : A0

Model number                    : WS-C3750E-24PD-E

Daughterboard assembly number   : 800-29737-01

Daughterboard serial number     : FDO131701UL

System serial number            : xxxxxx

Top Assembly Part Number        : 800-28922-01

Top Assembly Revision Number    : C0

Version ID                      : V03

CLEI Code Number                : COMSF00ARB

Hardware Board Revision Number  : 0x00

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 30    WS-C3750E-24PD     12.2(55)SE4           C3750E-UNIVERSALK9-M

Configuration register is 0xF

Index 1 Feature: advipservices

        Period left: 0  minute  0  second

Index 2 Feature: ipservices

        Period left: Life time

        License Type: Permanent

        License State: Active, In Use

        License Priority: Medium

        License Count: Non-Counted

Index 3 Feature: ipbase

        Period left: 0  minute  0  second

Hall of Fame Super Gold

3750/3750E stack - feature mismatch

Ok.  This means your 3750E has IP Services and I'm suspecting your 3750 is running IP Base.

If this is the case, then you have one of two options.  They are:

1.  Contact license@cisco.com and downgrade the license of your 3750E to run IP Base; or

2.  Contact license@cisco.com and purchase the IP Services license of yoru 3750.

New Member

3750/3750E stack - feature mismatch

It's not.  It's licensed for and running ipservices--the exact same version as the 3750E (12.2(55)SE4).

Also, as I indicated in my first post, I can't even use the 'switch 2 provision ws-c3750-48p' config command on the offending 3750E without generating an error (this is without any switch attached to the stack ports):

Here's the output from trying to provision a non-E 3750 into the stack (notice nothing is even connected at this point):

s1#sh switch

Switch/Stack Mac Address : 0025.8489.9400

                                           H/W   Current

Switch#  Role   Mac Address     Priority Version  State

----------------------------------------------------------

*1       Master 0025.8489.9400     5      1       Ready

s1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

s1(config)#switch 2 provision ws-c3750-48p

%Command rejected: feature compatibility check failed for switch 2

Hall of Fame Super Gold

3750/3750E stack - feature mismatch

Here's the output from trying to provision a non-E 3750 into the stack

Can you post the following commands:

1.  sh version (non-E 3750);

2.  sh switch detail (both).

New Member

3750/3750E stack - feature mismatch

For the sake of the archives:

The problem was the configuration of unicast rpf (ip verify unicast source reachable-via any) on the 3750E which isn't supported on non-E 3750 switches.

'show platform stack compatibility' showed the incompatible configuration.

4121
Views
0
Helpful
8
Replies