Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

3750 and 3850 fiber trunk

I currently have two 3750's (stacked). We recently purchased two new 3850's and have stacked them as well. My question is, how to I trunk them? I want to be able to use the new switches with the same vlans and IP addresses as the existing. The new switches are in the same rack as the existing ones.  

The current 3750's are the gateway for my network (and they will remain as such, for the time being). 

I connected a fiber uplink from switch to switch as in: 

3750a (gi 1/0/49) --> 3850a (gi 1/1/1)

3750b (gi 2/0/49) --> 3850b (gi 2/1/1)

I gave the fiber ports the following settings: 

3750a:
int gi1/0/49
switchport trunk encaps dot1q
switchport trunk allowed vlan add ALL
switchport mode trunk
switchport nonegotiate

3750b
int gi2/0/49
switchport trunk encaps dot1q
switchport trunk allowed vlan add ALL
switchport mode trunk
switchport nonegotiate

3850a / 3850b:
Gi1/1/1   
Gi2/1/1    
switchport trunk allowed vlan add ALL
switchport mode trunk
switchport nonegotiate


At this point, I thought I would be able to ssh into the new (3850) switch and ping the current (3750), but I cannot. Network assistant on the curent 3750 switch "sees" the new 3850, but has it listed as "unsupported device". The swiches are on the same subnet (10.11.1.0 /24).

Gateway switch (3750) is 10.11.1.2 and new 3850 is 10.11.1.14. If I plug my laptop into the 3850 and give myself a 10.11.1.x IP, I can ping the switch itself (10.11.1.14), but I cannot ping the gateway (10.11.1.2). If I SSH into the switches, I cannot ping one another. 

Do I need to set up the fiber uplinks as an Etherchannel? Or are my switchport settings incorrect? I'm not sure what I am missing. I am in no way an expert on this, so even if its something that may be obvious to others, it is entirely possible I overlooked it. 

Hope this makes sense. Any suggestions would be appreciated. Thank you. 

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions

Hey,Provide the following

Hey,

Provide the following information for more insight:

3750 side:

#sh ip int br | ex un

#sh int g1/0/49 trunk

#sh int g2/0/49 trunk

#sh vlan br

3850 side:

#sh ip int br | ex un

#sh int g1/1/1 trunk

#sh int g2/1/1 trunk

#sh vlan br

Regards,
RS.

12 REPLIES

HelloI am not sure i

Hello

I am not sure i undestand your setup- so please confirm

3750's are stacked
3850 are stacked

Now you wish to connect the two stacks together not by adding the stacks into one but by interconecting them via fibre?

 

I am right in saying the 3750 is running as the core switch and is also the stp root with ip routing enabled?

If so the best option would be layer 2 aggregation llinks between the two stacks( etherchannel trunked) and give the 3850 stack a managment ip adress from the one of the 3750 L3 svi interfaces with a default gatway address.

lastly disable ip routing on the 3850 stack and make sure your vtp config is applicable to the 3750.

 

res

Paul

 



 

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Hi Paul, and thanks for your

Hi Paul, and thanks for your reply. See my comments inline: 


3750's are stacked -> YES. 
3850 are stacked -> YES. 

"Now you wish to connect the two stacks together not by adding the stacks into one but by interconecting them via fibre?" -> That is correct. Not stacking them, but fiber uplink. 

"I am right in saying the 3750 is running as the core switch and is also the stp root with ip routing enabled?" -> you are correct. 

 

"If so the best option would be layer 2 aggregation llinks between the two stacks( etherchannel trunked) and give the 3850 stack a managment ip adress from the one of the 3750 L3 svi interfaces with a default gatway address." -> I thought this what I was doing. I wasn't sure if I setup the switchpoort correctly. I know dotq is default on the 3850's, but I'm not so sure if I need to set it to "nonegotiate" or not? Also, I gave the new 3850 an IP address of 10.11.1.14, but I"d like more informaion on how I should give the 3850 an IP from the 3750's l3 svi int? I'm not sure how to do that, nor am I sure how that would affect my existing vlans. (there are about 15 on the 3750). Will the replicate to the 3850? Will I have to create them manually on the 3850? 

 

lastly disable ip routing on the 3850 stack and make sure your vtp config is applicable to the 3750. -> I have to check this. I dont know if routing is disabled on the 3850 or not. Also, the VTP operting mode on the 3750 is "server". Should I make the 3850 vtp mode client? 

I can't get to the 3850, so I may not be able to provide feedback wether this worked or not for a few days. 

THank you!

 

 

Hello  Gaining access to the

Hello

 

 

Gaining access to the 3850 without ip address:
---------------------------------------------------------------
3750
sh cdp neigbours
conf t

cluster enable JDIAZ
do sh cluster  candidates

cluster member x mac-address (3850 mac address) password xxx ( enable password of 3850)
sh cluster members
do rcommand x ( cluster member number from above assigned to 3850

 

 

 

L2 Etherhcannel = both side of the connections must have the same configuration( speed/duplex, lacp/pagp/none)
--------------------------------------------------------------------------------------------------------------------------------------------------------------
both switches

example
int ran gig1/0/1 -2
shut
swtchport
channel-group 1 mode ?

int port-channel 1
switchport trunk encap dot1q
switchport- mode trunk
 

int ran gig1/0/1 -2
no shut

 

 

 

 

 

Disable ip routing/management addrressing
-----------------------------------------------------------

example:

3750
-------

int vlan 900
ip address 1.1.1.254 255.255.255.0

 

3850
------- -

conf t

int vlan 900

ip address 1.1.1.2 255.255.255.0
exi

ip default-gateway 1.1.1.254
 

no ip routing
 

 

res

Paul

 

 

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Hi. Thanks.  Is creating a

Hi. Thanks. 

 

Is creating a cop cluster the only option here? 

WIll this casue downtime on my 3750? This is my main production switch. 

Do I need to reset any of the settings I've already added to the 3850? And, how will this affect if I plan to (evetually) make the 3850 my main, core switch? 

 

Also, is the L2 etherchanel setup you list above an additional step to the cluster configuration, or an alternative to it? 

 

I still dont understand why I need to disable routing on the 3850. Don't the switches need to route between one another? I have a fiber PTP from the 3750 we are talking about, to another 3750 in a different city, and I never disabled routing on them. They have the ability to see eachothers vlans and vmotion servers from one side to the other. 

 

Thank you. 

 

JD

 

 

 

HelloIs creating a cop

Hello

Is creating a cop cluster the only option here?  -Yes Unless you have physical access to the switch
WIll this casue downtime on my 3750? This is my main production switch.  - No

Also, is the L2 etherchanel setup you list above an additional step to the cluster configuration, or an alternative to it? 
No this is what a basic ehterchannel setup should involve so when you do gain access to the 3850 you should check the portchannel config

I still dont understand why I need to disable routing on the 3850. Don't the switches need to route between one another? I have a fiber PTP from the 3750 we are talking about, to another 3750 in a different city, and I never disabled routing on them. They have the ability to see eachothers vlans and vmotion servers from one side to the other. No - As you have explained in your previous posts, The 3850 isnt perfroming any Layer 3  -  its connecting as a host switch stack and just a trunk connecton ( be it physcial or logical like a port-channel interface is requied) - the ip addess you give it is for remote access for managment availablity - so if ip routing is enabled it will be required disabling

you can check this by posting the output of

sh ip route..

once you gain access

 


res

Paul

 

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

I see. That makes a lot more

I see. That makes a lot more sense. Thank you. 

I should have been more specific. I don't have phsical access to the seitch currently, but I will, once I get back in town. 

What would the preffered set up be, if I do have physical access the switch? 

 

I apologize for not being clearer. 

 

Thank you for taking the time on this. 

 

JD

New Member

Hello,  Thank you for your

Hello, 

 

Thank you for your response on this. I still would like to request clarification on my setup. I would also like to add some more information. As mentioned above, the two stacks (3750 & 3850) are connected to one another via fiber cable. The intent is to eventually make (the new) 3850 stack the gateway. This is why I am asking about disabling routing, and whether or not is necessary. The goal is to eventually have the 3850 as the core switch, and the (old) 3750 stack as just a trunk attached. Effectively, reversing their roles. But this is not to happen yet, but in a few weeks \ months as we migrate slowly. 

With that said, I'd like to know if the below way of setting them up will work:

On 3850 stack:

int ran Gi1/1/1 & Gi2/1/1

shut

switchport

channel-group 10 mode active

no shut

exit

int port-channel 10 

switchport trunk enacap dot1q

switchport mode trunk

end

 

3750 (same as above, but on gi 1/0/49 - 2/0/49).

 

At this point, should I be able to ping back and forward? 

 

Hope that makes sense. 

 

Thank you,

 

JD

 

PS: this is the sh ip route output on the 3750

sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.1.254 to network 0.0.0.0

C    192.168.40.0/24 is directly connected, Vlan192
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Vlan172
C    192.168.41.0/24 is directly connected, Vlan41
     10.0.0.0/24 is subnetted, 4 subnets
C       10.11.1.0 is directly connected, Vlan10
C       10.11.2.0 is directly connected, Vlan112
C       10.3.3.0 is directly connected, Vlan310
S       10.7.2.0 [1/0] via 10.11.1.57
S*   0.0.0.0/0 [1/0] via 172.16.1.254
 

 

New Member

Hello, I am still having an

Hello, I am still having an issue with this. Below is the configuration for the 3850. I need to mention that there are some routes that are going from the 3750 (ATL core switch) to our Houston location. I don't want to affect those. Here is the new 3850 config:

3850
cisco 3850 is 10.11.1.14
10.11.1.2 is 3750 (core)

Jon#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.11.1.2 to network 0.0.0.0

S*    0.0.0.0/0 [0/0] via 10.11.1.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.11.1.0/24 is directly connected, Vlan1
L        10.11.1.14/32 is directly connected, Vlan1


Jon#sh int port-chan 11
Port-channel11 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is bc67.1c2c.8f31 (bia bc67.1c2c.8f31)
  MTU 1500 bytes, BW 2000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 44/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/1/1 Gi2/1/1
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 346438000 bits/sec, 60724 packets/sec
  5 minute output rate 219000 bits/sec, 393 packets/sec
     1035330112 packets input, 736325645076 bytes, 0 no buffer
     Received 364858179 broadcasts (342729785 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 342729785 multicast, 0 pause input
     0 input packets with dribble condition detected
     7065898 packets output, 503248621 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
Jon#
Jon#sh int port-chan 11 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po11        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po11        1-4094

Port        Vlans allowed and active in management domain
Po11        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

Port        Vlans in spanning tree forwarding state and not pruned
Po11        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

Jon#sh int port-chan 11 switchport
Name: Po11
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Jon#

Jon#sh vlan br

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/1, Gi1/0/2, Gi1/0/3
                                                Gi1/0/4, Gi1/0/5, Gi1/0/6
                                                Gi1/0/7, Gi1/0/8, Gi1/0/9
                                                Gi1/0/10, Gi1/0/11, Gi1/0/12
                                                Gi1/0/13, Gi1/0/14, Gi1/0/15
                                                Gi1/0/16, Gi1/0/17, Gi1/0/18
                                                Gi1/0/19, Gi1/0/20, Gi1/0/21
                                                Gi1/0/22, Gi1/0/23, Gi1/0/24
                                                Gi1/0/25, Gi1/0/26, Gi1/0/27
                                                Gi1/0/28, Gi1/0/29, Gi1/0/30
                                                Gi1/0/31, Gi1/0/32, Gi1/0/33
                                                Gi1/0/34, Gi1/0/35, Gi1/0/36
                                                Gi1/0/37, Gi1/0/38, Gi1/0/39
                                                Gi1/0/40, Gi1/0/41, Gi1/0/42
                                                Gi1/0/43, Gi1/0/44, Gi1/0/45
                                                Gi1/0/46, Gi1/0/47, Gi1/0/48
                                                Gi1/1/2, Gi1/1/3, Gi1/1/4
                                                Gi2/0/1, Gi2/0/2, Gi2/0/3
                                                Gi2/0/4, Gi2/0/5, Gi2/0/6
                                                Gi2/0/7, Gi2/0/8, Gi2/0/9
                                                Gi2/0/10, Gi2/0/11, Gi2/0/12
                                                Gi2/0/13, Gi2/0/14, Gi2/0/15
                                                Gi2/0/16, Gi2/0/17, Gi2/0/18
                                                Gi2/0/19, Gi2/0/20, Gi2/0/21
                                                Gi2/0/22, Gi2/0/23, Gi2/0/24
                                                Gi2/0/25, Gi2/0/26, Gi2/0/27
                                                Gi2/0/28, Gi2/0/29, Gi2/0/30
                                                Gi2/0/31, Gi2/0/32, Gi2/0/33
                                                Gi2/0/34, Gi2/0/35, Gi2/0/36
                                                Gi2/0/37, Gi2/0/38, Gi2/0/39
                                                Gi2/0/40, Gi2/0/41, Gi2/0/42
                                                Gi2/0/43, Gi2/0/44, Gi2/0/45
                                                Gi2/0/46, Gi2/0/47, Gi2/0/48
                                                Gi2/1/2, Gi2/1/3, Gi2/1/4
10   VLAN0010                         active

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
41   VLAN0041                         active
70   VLAN0070                         active
72   VLAN0072                         active
110  VLAN0110                         active
112  VLAN0112                         active
172  VLAN0172                         active
192  VLAN0192                         active
222  VLAN0222                         active
310  VLAN0310                         active
400  VLAN0400                         active
410  VLAN0410                         active
722  VLAN0722                         active
999  VLAN0999                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Jon#

Jon#sh ip int br | ex un
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  10.11.1.14      YES NVRAM  up                    up


Jon#sh int gi 1/1/1 switchport
Name: Gi1/1/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk (member of bundle Po11)
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Jon#

Jon#sh int gi 2/1/1 switchport
Name: Gi2/1/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk (member of bundle Po11)
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Jon#sh vtp sta
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : SU4
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 6cfa.8961.ae80
Configuration last modified by 10.11.1.3 at 5-10-96 10:46:01

Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 19
Configuration Revision            : 21
MD5 digest                        : 0x91 0x8F 0xCB 0x5F 0x70 0x43 0x35 0x72
                                    0xD2 0xFC 0x18 0x68 0x4B 0xE9 0xED 0x86

 

Here is 3750 config: 

garfield#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.1.254 to network 0.0.0.0

C    192.168.40.0/24 is directly connected, Vlan192
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Vlan172
C    192.168.41.0/24 is directly connected, Vlan41
     10.0.0.0/24 is subnetted, 4 subnets
C       10.11.1.0 is directly connected, Vlan10
C       10.11.2.0 is directly connected, Vlan112
C       10.3.3.0 is directly connected, Vlan310
S       10.7.2.0 [1/0] via 10.11.1.57
S*   0.0.0.0/0 [1/0] via 172.16.1.254
garfield#

garfield#sh int port-chan 10
Port-channel10 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0019.e78d.cc31 (bia 0019.e78d.cc31)
  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 0/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/0/49 Gi2/0/49
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     22417 packets input, 2835668 bytes, 0 no buffer
     Received 22275 broadcasts (22156 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 22156 multicast, 0 pause input
     0 input packets with dribble condition detected
     62724237 packets output, 58026872380 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
garfield#

garfield#sh int port-chan 10 switchport
Name: Po10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
garfield#

garfield#sh int port-chan 10 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po10        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po10        1-4094

Port        Vlans allowed and active in management domain
Po10        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

Port        Vlans in spanning tree forwarding state and not pruned
Po10        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999
garfield#

 

 

I want to be able to use the new 3850 with all of my existing vlans. 

Any suggestions appreciated. Hopefully, I can get another change window approved so I can try out any new ideas. 

 

Thank you, 

 

JD

 

 

 

 

Hey,Provide the following

Hey,

Provide the following information for more insight:

3750 side:

#sh ip int br | ex un

#sh int g1/0/49 trunk

#sh int g2/0/49 trunk

#sh vlan br

3850 side:

#sh ip int br | ex un

#sh int g1/1/1 trunk

#sh int g2/1/1 trunk

#sh vlan br

Regards,
RS.

New Member

Rajeevsh, 3750:#sh ip int br

Rajeevsh, 

3750:

#sh ip int br | ex un

Interface              IP-Address      OK? Method Status                Protocol
Vlan10                 10.11.1.4       YES manual up                    up
Vlan41                 192.168.41.10   YES manual up                    up
Vlan112                10.11.2.7       YES manual up                    up
Vlan172                172.16.1.2      YES NVRAM  up                    up
Vlan192                192.168.40.4    YES manual up                    up
Vlan310                10.3.3.3        YES NVRAM  up                    up

 

 

#sh int g1/0/49 trunk


Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/49    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/49    1-4094

Port        Vlans allowed and active in management domain
Gi1/0/49    1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/49    1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

 

#sh int g2/0/49 trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi2/0/49    on               802.1q         other         1

Port        Vlans allowed on trunk
Gi2/0/49    none

Port        Vlans allowed and active in management domain
Gi2/0/49    none

Port        Vlans in spanning tree forwarding state and not pruned
Gi2/0/49    none

 

#sh vlan br

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/50, Gi1/0/51, Gi1/0/52
                                                Gi2/0/49, Gi2/0/50, Gi2/0/52
10   VLAN0010                         active    Gi1/0/10, Gi1/0/12, Gi1/0/20
                                                Gi1/0/23, Gi1/0/24, Gi1/0/29
                                                Gi1/0/30, Gi1/0/31, Gi1/0/32
                                                Gi1/0/33, Gi1/0/34, Gi1/0/35
                                                Gi1/0/36, Gi1/0/37, Gi1/0/38
                                                Gi1/0/39, Gi1/0/40, Gi1/0/41
                                                Gi1/0/42, Gi1/0/43, Gi1/0/44
                                                Gi1/0/45, Gi1/0/46, Gi1/0/47
                                                Gi1/0/48, Gi2/0/10, Gi2/0/12
                                                Gi2/0/20, Gi2/0/23, Gi2/0/24
                                                Gi2/0/29, Gi2/0/30, Gi2/0/31
                                                Gi2/0/32, Gi2/0/33, Gi2/0/34
                                                Gi2/0/35, Gi2/0/36, Gi2/0/37
                                                Gi2/0/38, Gi2/0/39, Gi2/0/40
                                                Gi2/0/41, Gi2/0/42, Gi2/0/43
                                                Gi2/0/44, Gi2/0/45, Gi2/0/46
                                                Gi2/0/47, Gi2/0/48
41   VLAN0041                         active

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
70   VLAN0070                         active
72   VLAN0072                         active    Gi1/0/1, Gi1/0/2, Gi2/0/1
                                                Gi2/0/2
110  VLAN0110                         active
112  VLAN0112                         active
172  VLAN0172                         active    Gi1/0/5, Gi1/0/6, Gi1/0/7
                                                Gi1/0/8, Gi2/0/5, Gi2/0/6
                                                Gi2/0/7, Gi2/0/8
192  VLAN0192                         active    Gi1/0/3, Gi1/0/4, Gi1/0/9
                                                Gi1/0/11, Gi1/0/13, Gi1/0/14
                                                Gi1/0/15, Gi1/0/16, Gi1/0/17
                                                Gi1/0/18, Gi1/0/19, Gi1/0/21
                                                Gi1/0/22, Gi1/0/25, Gi1/0/26
                                                Gi1/0/27, Gi2/0/3, Gi2/0/4
                                                Gi2/0/9, Gi2/0/11, Gi2/0/13
                                                Gi2/0/14, Gi2/0/15, Gi2/0/16
                                                Gi2/0/17, Gi2/0/18, Gi2/0/19
                                                Gi2/0/21, Gi2/0/22, Gi2/0/25
                                                Gi2/0/26, Gi2/0/27, Gi2/0/28
222  VLAN0222                         active
310  VLAN0310                         active
400  VLAN0400                         active
410  VLAN0410                         active

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
722  VLAN0722                         active
999  VLAN0999                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

 

3850:

I don't have access to it at the moment, since I can't get to it remotly. 

I can tell you that it was new, only has the IP address that we assigned to it, and has had the switchport commands I included in my question. 

There should be no vlans on it. 

JD

 

New Member

Thank you. This is issue is

Thank you. This is issue is resolved. I ended up recreating the port channel, and created layer 3 SVI for the switches, for each VLAN.

For anybody else who may run into this, here is a sample of what I did. 

 

int Gi1/1/1

shut

switchport

switchport trunk allowed vlan ALL

switchport mode trunk

switchport nonegotiate

channel-group 2 mode active

 

int port-channel 2

switchport mode trunk

switchport trunk allowed vlan all

switchport nonegotiate

exit

 

Do the same on for all interfaces. Make sure your port channel numbers are the same and that your IP addresses are on the same vlan. I had my 10.11.1.x IP address on vlan 10 on switch, and the new switch IP of 10.11.1.xx was on vlan 1. 

 

It all works now. 

 

Thanks! 

New Member

Is anybody still monitoring

Is anybody still monitoring this question? Or should I post new question for the items I mentioned below? 

4913
Views
4
Helpful
12
Replies
CreatePlease to create content