Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750 Bond to Ports?

I would like to bond/team 2 ports on my 3750. This is what I current have:

interface Gigabitethernet4/0/21

description "Team Member 1"

Switchport mode access

no ip address

no mdix auto

channel-group 9 mode active

spanning-tree portfast

interface Gigabitethernet4/0/22

description "Team Member 2"

Switchport mode access

no ip address

no mdix auto

channel-group 9 mode active

spanning-tree portfast

Not working tho... any help appreciated. Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: 3750 Bond to Ports?

Hi

Send these outputs to dahuja@cisco.com

"show etherchannel summary"

"show tech-support

What make of NIC are you using on the server

Once I receive the output would be able to analyze the issue and come down to a resolution

Regards

Deepak Ahuja

Cisco TAC

18 REPLIES
bjw Silver
Silver

Re: 3750 Bond to Ports?

It appears as though you're configuring Etherchannel.

Is the 2nd switch, connected to interfaces Gi4/0/21 and Gi4/0/22, configured the same?

3750 Etherchannel ref doc:

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_guide_chapter09186a00801cdea1.html

New Member

Re: 3750 Bond to Ports?

Actually - I have two gig network cards in my backup server that are teamed - and looking to get two ports on the same switch teamed. Just need more bandwidth for my backup agents to use.

Etherchannel does this correct?

New Member

Re: 3750 Bond to Ports?

int g4/0/21

switchport trunk encap dot1q

switchport trunk allowed vlan xx

switchport mode trunk

Channel-protocol lacp

channel-group 9 mode active

no spanning-tree portfast

int g4/0/22

switchport trunk encap dot1q

switchport trunk allowed vlan xx

switchport mode trunk

Channel-protocol lacp

channel-group 9 mode active

no spanning-tree portfast

Vlan xx is the vlan that your server is in.

New Member

Re: 3750 Bond to Ports?

Will give it a whirl. The main switch in on the same network as the server, so don't need a Vlan.

Curious about the addition of:

Switchport trunk encap dot1q

and turning off spanning-tree portfast

Are these recommend settings?

bjw Silver
Silver

Re: 3750 Bond to Ports?

Those are trunk settings, for trunking vlans across switches/routers.

Not sure if the server NIC teaming process is going to work like you need.

I as understand teaming, 1 virtual IP address = 1 virtual MAc address, across 2 physical NIC connections.

AFAIK this is not a throughput enhancement. You may want to read up on the Server NIC teaming and see how they recommend setting it up.

Etherchannel is a L2 switch to L2 switch function.

New Member

Re: 3750 Bond to Ports?

Makes more sense to me. Ah. Yep this is just two network ports coming out out of my backup server going into 1 switch.

Doesn't sound like I can do it through etherchannel then. Thanks!

New Member

Re: 3750 Bond to Ports?

Added the config and could not ping the server. Changed switchport mode trunk back to switchport mode access and could ping but port still show as 1 gig.

New Member

Re: 3750 Bond to Ports?

Hi,

Do you have a Port Channel interface setup?

Take a look at the following link example.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094647.shtml#configs

New Member

Re: 3750 Bond to Ports?

No I don't have a port channel interface setup.

New Member

Re: 3750 Bond to Ports?

channel-group 9 mode active

this automatically creates a port channel group 9 for LACP

bjw Silver
Silver

Re: 3750 Bond to Ports?

I did a little researching. There are several NIC teaming methods, redundancy, load balancing, throughput aggregation.

For the basic port channel to work with a non-PagP/LaCP host, you'll need to change:

channel-group 9 mode active

to

channel-group 9 mode on

on both ports.

Try that, and here's a few refs I stumbled upon.

http://support.citrix.com/article/CTX434260

http://www.velocityreviews.com/forums/t162986-nic-teaming-cisco-6k.html

New Member

Re: 3750 Bond to Ports?

no good - even tho mode on is an option in the list, it does not accept it. Do I need to create the channel first?

New Member

Re: 3750 Bond to Ports?

Hi

Send these outputs to dahuja@cisco.com

"show etherchannel summary"

"show tech-support

What make of NIC are you using on the server

Once I receive the output would be able to analyze the issue and come down to a resolution

Regards

Deepak Ahuja

Cisco TAC

New Member

Re: 3750 Bond to Ports?

Sent Email - Thanks!!

New Member

Re: 3750 Bond to Ports?

Answer was:

Anyhow follow this config as it is and it should solve the issue.

Sw(config) # interface Port-channel9

Sw(config-if)#no description Brain5 Team

Sw(config-if)#no switchport trunk encapsulation dot1q

Sw(config-if)#no switchport mode access

Sw(config)# no interface Port-channel9

Sw(config)#default interface range gi 4/0/21 -22

===========================================

SW(config)#interface range gigabitethernet 4/0/21-22

SW(config-if-range)#switchport mode access

SW(config-if-range)#channel-group 9 mode on

========================================

sw(config)#int port-channel 9

sw (config-if)#no ip address

sw(config-if)#speed full

sw(config-if)#duplex full

end

============================================

New Member

Re: 3750 Bond to Ports?

I try doing that on a cross-stack on 3750Gs and it does not allow me to use "switchport mode access". I have to use a trunk and it works good for LACP

New Member

Re: 3750 Bond to Ports?

no issues with the configuration

check with the teamed adaptors , does your nics support LACP ?

New Member

Re: 3750 Bond to Ports?

Most host/server nicteaming does not support LACP (or any other etherchannel linking protocol) except for a very few servers (the Dell 1655 comes to mind -- except it's really a Dell managed switch built into the multi-blade server). Most ppl will refer to nicteaming as a HSRP-like backup/failover setup. The NIC mfgr utility will usually show the nicteaming capabilities. This is Windows, of course.

Linux has no such problems :)

Anyway, turning off any aggregation protocol will usually work.

3598
Views
0
Helpful
18
Replies
CreatePlease login to create content