cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
212
Views
0
Helpful
1
Replies

3750 config for Voice&data VLans on same ports of the switch

ronniew85
Level 1
Level 1

Hello,

 

 My end goal will come first. Now I'm kind of new to the cisco IOS, but am learning more each day so bare with the lingo. I want my L3 3750 to switch & route any internal traffic because it is faster that going to my router which is offsite. We have Shoretel 565 and 230s for phones with a switchport in the back daisy chained to the PC. So each port on my switches will need Native Vlan and Voice Vlan for this to work properly. I need some direction on how to make sure these Vlans can talk to each other because my Shoretel server will be on Vlan 1 and Phones will be Vlan 100. Help with DHCP & the L3 switching&routing on the switch will be much appreciated. My config is below with some of my settings. If someone could give me direction on how to get the VLan interrouting setup correctly, and get DHCP selecting the right scoops for all ports/devices this would be GREAT!

 

!--------------------------------------------------------------
!   Generic config for Cisco 3750 48 port POE switch
!
!------FE ports 1-46 are general purpose PC/printer/VOIP
!------FE ports 47-48 are for connecting non-fiber switches
!------GE ports 1-4 are for connecting fiber switches
!
!------VLAN 1 is for management, PC, printer and other devices
!------VLAN 100 is for VOIP with QoS
!------VLAN 200 is for video
!--------------------------------------------------------------
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW-nssco-Miles.251
!
!enable secret 5 $xxxxxxxx$$$$$xxxxx$$$$
!
no aaa new-model
clock timezone UTC -6
clock summer-time UTC recurring
switch 1 provision ws-c3750-48p
system mtu routing 1500
ip subnet-zero
ip routing
!
!
vtp domain nssco
vtp mode transparent
!
mls qos trust dscp
mls qos vlan-based
auto qos voip trust

!

spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree uplinkfast
no spanning-tree vlan 227-500
!
vlan internal allocation policy ascending
!
vlan 100-500
!
!

!********** setup QoS for VOIP
class-map match-all VOICE-RTP
 match access-group name VOICE-RTP
class-map match-all VOICE-SIGNALING
 match access-group name VOICE-SIGNALING

!********** More QoS Settings
policy-map DEFAULT
 class VOICE-RTP
  set dscp ef
 class VOICE-SIG
  set dscp cs3

!
!
!
interface FastEthernet1/0/1
 description for PC, printer and VOIP devices
 switchport trunk allowed vlan 1,100
 switchport mode access
 switchport voice vlan 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet1/0/2
 description for PC, printer and VOIP devices
 switchport trunk allowed vlan 1,100
 switchport mode access
 switchport voice vlan 100
 duplex full
 spanning-tree portfast
!


xxx

xxx

!

interface FastEthernet1/0/48
 description ***********  To other switches via copper ***********
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100
 switchport mode trunk
 switchport voice vlan 100
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/1
 description ***********  To other switches via copper/fiber ***********
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-500
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 description ***********  To other switches via copper/fiber ***********
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-500
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 description ***********  To other switches via copper/fiber ***********
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-500
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 description ***********  To other switches via copper/fiber ***********
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-500
 switchport mode trunk
!
interface Vlan1
 description SW-Miles-01
 ip address 10.1.1.1 255.255.255.0
!
interface Vlan100
 ip address 10.100.1.1 255.255.255.0
 ip helper-address 10.1.1.7
!
interface Vlan200
 ip address 10.200.1.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.2
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
snmp-server community public RO
snmp-server community public1 RW
!
banner motd ^CCCCCCCC
     *****            PRIVATE NETWORK              *****
     *****     ACCESS TO NETWORK IS PROHIBITED     *****
     *****   UNAUTHORIZED USE WILL BE PROSECUTED   *****
^C
!
line con 0
line vty 0 4

 login
line vty 5 15

 login
!
end

 

Ron

1 Reply 1

nkarthikeyan
Level 7
Level 7

Hi,

 

One your LAN Access switch you can have

switch port access vlan 1 (not needed to be given) - default

switchport mode access

switchport voice vlan 100

!

in the uplink port of the access-switch, you can have the trunk configured

switchport trunk native vlan 1

switchport trunk allowed vlan 100

!

in access swicth you point the route / gateway as data vlan gaetway address.

configure your gateway as your core and core should have the gateway ip address in vlan configs.

 

Through core intervlan communication will got through.

 

Regards

Karthik

 

Review Cisco Networking products for a $25 gift card