Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

3750 droping IPPREC marking

Hi all

RTR1-SW-RTR2 setup. I mark traffic with various IP prec and can see it leaving RTR1 interface as such. when it gets to RTR2 it is all changed to IP prec 0 which is not teh desired effect. I ghave no policy maps inbound in my RTR2.

My suspect is SW, where mls QOS is disabled...so all shoudl be pass thru. I can see pcakets comimg as various IP prec but exiting to RTR2 as routine traffic. my SW ports are not configured with override.

any thoughts on this might be ?

TIA

Sam

6 REPLIES
Cisco Employee

Re: 3750 droping IPPREC marking

Hi Sam,

Can you please post the "sh run" from the switch?

Regards,

Ankur

Re: 3750 droping IPPREC marking

Hi Ankur

I have snipped what si not needed.

hostname SW01

!

switch 1 provision ws-c3750g-12s-d

vtp domain ESW

vtp mode transparent

udld enable

ip subnet-zero

no ip source-route

ip domain-name msn.sonofon.dk

ip name-server 172.17.30.21

!

!

!

spanning-tree mode mst

spanning-tree extend system-id

!

spanning-tree mst configuration

name ROC

revision 5

instance 1 vlan 1-10, 12, 22-99, 102-500, 900-998

instance 2 vlan 11, 13-21, 100-101, 501-899, 999

!

!

vlan internal allocation policy ascending

!

vlan 405

name [CUSTOMERXXX]

!

!

interface GigabitEthernet1/0/1

description [RTR01]

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

load-interval 30

speed nonegotiate

!

--------------

!

interface GigabitEthernet1/0/10

description [RTR02]

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 405

switchport mode trunk

switchport nonegotiate

logging event trunk-status

logging event spanning-tree

load-interval 30

duplex full

speed 100

!

Cisco Employee

Re: 3750 droping IPPREC marking

Hi Sam,

Is it possible for you to sniff gig1/0/10 interface?

Regards,

Ankur

Re: 3750 droping IPPREC marking

Hi Ankur

I am unable to sniff, but I can look at stats on mls QOS interface. I see all packets under when heading IP prec 0-4.

I will add an output when back at my desk.

Thanks again

Sam

Re: 3750 droping IPPREC marking

i think the prec values are getting overwritten

Can you try trusting the trunk ports

mls qos

mls qos trust cos

HTH

Narayan

Re: 3750 droping IPPREC marking

Hi Narayan

yes I agree they are overwritten...but why?

the switch is configured with no QOS and should be a plain passthru.

I will upgrade IOS just in case, and BTW it is Enhanced image I am running.

Thanks

Sam

192
Views
0
Helpful
6
Replies
CreatePlease login to create content