Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

3750 EtherChannel load-balance algorythm changed and loss of connectivity?

I recently changed the EtherChannel load-balance algorythm on some 3750 switches and lost connectivity. The switches are running the IP Services code and the EtherChannels are Layer-3 and spread over two switches in a stack (Port-Channel 1 is G1/0/1 & G2/0/1 and Port-Channel 2 is G1/0/2 & G2/0/2). They were configured with the default src-mac load-balance algorythm which obviously on a routed link has no load balancing effect since the source MAC never changes. I changed this to src-dst-ip and some hosts lost connectivity - i.e. I could ping from one VLAN to hosts somewhere in the rest of the network and from another VLAN I couldn't. The OSPF adjacencies stayed up on the stack so I am a bit lost as to why the connectivity failed. The load-balance decision is performed locally by the switch so why should I have lost connecivity?

Since this was a live network I removed the command to restore connectivity.

Andy

3 REPLIES
Bronze

Re: 3750 EtherChannel load-balance algorythm changed and loss of

perhaps the 2nd etherchannel member may have some Layer1/Layer2 issues. I would check the 2nd physical link that was actively used after the etherchannel load balancing algorithm was changed to be more effective.

Re: 3750 EtherChannel load-balance algorythm changed and loss of

No, all the links are working fine as we tested the failover of links in the EtherChannel recently. I have also just had a look and no errors are shown (1000BaseSX fibre links).

I will probably change this again later on one of the switch stacks and dig a bit deeper. I have just re-read the documentation hoping there was an advisory or warning about changing the load-balancing algorythm when the channel was up but there is nothing.

Andy

Re: 3750 EtherChannel load-balance algorythm changed and loss of

I managed to get a bit of time to play around with this yesterday and got it working, however I am not sure why what I did fixed it.

I made the changes again and had one of the server guys with me that could quickly detect any loss of connectivity. When I made the change immediately the connectivity issues were visible. To fix it I just shut the first port-channel down and then opened it up again, then repeated it on the 2nd once. Following these interface 'resets' the connectivity returned.

I did the same thing in another location and exactly the same behaviour was experienced - i.e. made the load-balance change and connectivity was affected, reset the etherchannels and connectivity was restored.

I can't find any notes on CCO regarding a warning on changing the etherchannel load-balance algorythm. Has anyone else seen this and has an explanation?

Andy

1429
Views
0
Helpful
3
Replies