Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

3750 > 3550 QoS

Hi All,

I am after some info on QoS setup, i haven't a great deal of experience with QoS so far...

One of our remote sites has a Cisco 3750 that connects back into a 3550 at our main site. There are about 7 VLANs running at the remote site that are routed back to the main site using OSPF.

The only exception is the VoIP VLAN which is actually trunked back to the main site, so bypassing the OSPF routing.

The 3750 has QoS enabled for all of the VoIP ports and the switchport that connects back to main site. I want to change the IP Subnet address of the VoIP VLAN and place it into the OSPF area so it becomes a routed subnet and is no longer trunked back to our main site. The main reason for this is to bring the addressing of the subnets in line, as the current VoIP subnet is not really compatible with the rest of our network.

What i need to know is what we need to do for the QoS setup for it to continue working when we route as opposed to trunk the VoIP traffic.

Here is parts of the config of the 3750:

mls qos map policed-dscp 0 24 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 1 2 4

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 20 22 25 32 34 36

mls qos srr-queue output dscp-map queue 2 threshold 1 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24 26

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 3 10 12 14

mls qos queue-set output 1 threshold 2 70 80 100 100

mls qos queue-set output 1 threshold 4 40 100 100 100

mls qos

***VoIP interface****

interface FastEthernet1/0/6

switchport access vlan dynamic

switchport mode access

switchport voice vlan 102

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust dscp

spanning-tree portfast

***Interface connected to main site***

interface FastEthernet1/0/48

description Connection to NP LES 100

switchport trunk encapsulation dot1q

switchport trunk native vlan 33

switchport trunk allowed vlan 10,11,33,102,999

switchport mode trunk

speed 100

duplex full

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust dscp

The Voip VLAN is currently VLAN 102, can i simply add this to the OSPF routing, remove it from the trunk and expect the QoS to remain?

Apologies for the lengthy post any help much appreciated.

Cheers

Jonathan

8 REPLIES

Re: 3750 > 3550 QoS

I think you should be fine...

The QoS parameters defined are at the port level and hence should not make any difference

Narayan

Re: 3750 > 3550 QoS

Excellent, thanks for the reply. I have one more question... The Interface on the 3550 that connects the remote site to the main site is set to "mls qos trust cos"

Will this need to be changed to "mls qos trust dscp"? as the connection will become a Layer 3, routed conneciton rather than a trunk...

Re: 3750 > 3550 QoS

Yes or else write a qos policy under the SVI

Narayan

Re: 3750 > 3550 QoS

Excellent. Thanks for your help. If you know of any helpful configuration guides for this sort of scenario that would be great...

I am going to see if i can come up with some correct configs and then check them through before going live.

Re: 3750 > 3550 QoS

The "Enterprise QoS" design guide at http://www.cisco.com/en/US/netsol/ns656/networking_solutions_program_home.html is an excellent resource.

HTH - Paul

Re: 3750 > 3550 QoS

Hi, Thanks for the link, is a good document.

I have just been looking at the config of both my 3750 and my 3550 and have noticed one thing:

the interface in the 3550 that connects the remote site is:

interface FastEthernet0/22

description Connection to Culverhay LES 100

switchport trunk encapsulation dot1q

switchport trunk native vlan 33

switchport trunk allowed vlan 10,11,33,102,999

switchport mode trunk

speed 100

duplex full

mls qos trust cos

auto qos voip trust

wrr-queue bandwidth 20 1 80 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

The connection back to the main site from the remote site:

interface FastEthernet1/0/48

description Connection to NP LES 100

switchport trunk encapsulation dot1q

switchport trunk native vlan 33

switchport trunk allowed vlan 10,11,33,102,999

switchport mode trunk

speed 100

duplex full

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust dscp

So these two interfaces are connected to each other via a 100Mbps LES Circuit. My question, why is one set to mls qos trust dscp and the other set to mls qos trust cos? And will this have any impact if i decide to remove VLAN 102 from the trunk and cause it to be routed instead?

Many thanks

Jonboy

Re: 3750 > 3550 QoS

Removing the VLAN should have no effect, just make sure the routed link has the same treatment.

I looked to see if I could find anything on trusting cos vs. dscp on a trunk link, I didn't find anything during a *quick* look. Presumably if the dscp-to-cos maps are the way you want them, trust cos should be fine. I personally use trust dscp just about everywhere, since that's what I mark. If anyone knows any negative implications of that I'd love to hear about it.

Paul

Re: 3750 > 3550 QoS

Hi Paul,

On investingating the rest of the network, it seems that everywhere is set to Trust Dscp except that single interface, so i think i am going to change it to trust Dcsp, remove the VLAN from the trunk and add it to the OSPF routing process..

Thanks for your help

Jonboy

192
Views
0
Helpful
8
Replies
CreatePlease to create content