Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

3750 inter-vlan routing

does the ip-base image do inter-vlan routing, or do i need the ipservices image?

thanks!

matt

9 REPLIES
New Member

Re: 3750 inter-vlan routing

ip-base image support for inter-vlan routing

the difference betweeb IP-Base and Ipservices is as follows:-

Base

Entry level package

IP Base, Enterprise Base

Services

Addition of MPLS, NetFlow, VoIP, VoFR, and ATM

SP Services, Enterprise Services

HTH

Imran

New Member

Re: 3750 inter-vlan routing

don't mean to sound stupid, but does that mean it does support inter-vlan routing?

New Member

Re: 3750 inter-vlan routing

I apologize for the wrong information:-

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_guide_chapter09186a00805a65c0.html

IP routing between VLANs (inter-VLAN routing) for full Layer 3 routing between two or more VLANs, allowing each VLAN to maintain its own autonomous data-link domain are avilable on IP service Images

New Member

Re: 3750 inter-vlan routing

does inter-vlan routing still occur if the vlans only exist on trunk ports?

i have a 3750G-12S (12 fiber gbics). so far i just have ports 1 and 12 being used. port 1 trunks to a 2950 (just vlan 1) and port 12 trunks to another 2950 (vlans 1 and 2). vlan 1 is native on both trunks. i have ip routing enabled but i can't get any traffic to pass from vlan 2 to vlan 1 or vice versa. communication from client workstations to the vlan SVIs is good. any thoughts?

thanks,

Matt

Re: 3750 inter-vlan routing

Hi

for u r first question if r not going to use trunk links then u have to use a seprate link for each vlan and terminate it at the routing device.

for u r second question,have u enabled ip routing on u r switch and created vlan SVI's.

Configure the gateway on clients on the individual vlans the SVI of the 3750 switch.

Thanks

Mahmood

Purple

Re: 3750 inter-vlan routing

Its really as simple as turning on ip routing . Create your layer 3 SVI's and your layer 2 definition or make a routed port with address on it and make sure the client default gateway on the nic card points to that address on either the routed port or the SVI for that vlan . Base versions support static routing and RIP I believe whereras services supports most routing protocols. check your trunk setup , "show interface trunk and see if it is trunking correctly .

vtp domain ---> match on all attached switches.

trunked ports

int g0/2

switchport mode dynamic desirable---->on each side of the trunk link

conf t

vlan 2

exit

conf t

interface vlan 2

ip address 192.168.2.254 255.255.255.0

client default gateway pointed to this address

conf t\

interface g0/1

switchport

switchport access vlan 2

switchport host

no shut

end

New Member

Re: 3750 inter-vlan routing

the trunks from the 2950s to the 3750 are working. my clients on the vlan 2 2950 can all ping their gateway svi on the 3750) for vlan 2 (trunk port gig1/0/1). likewise my vlan 1 clients can all ping the vlan 1 svi as well (trunk port gig 1/0/12). i have enabled ip routing. vtp params all match. other than that nothing else is configured on the switch yet. my clients on vlan 1 just cannot seem to ping clients on vlan 2. i can't even do an extended ping specifying an address in vlan 2 with a destination of vlan 1's SVI... when i get a chance i'll post my config for the 3750. any thoughts in the meantime? i'm not sure if this has something to do with the dot1q native vlan or what...

Purple

Re: 3750 inter-vlan routing

default gateway on the clients nic card correct ? You would be able to ping the local SVI without a gateway on the nics but you could not get off the connected network which is what it sounds like .

New Member

Re: 3750 inter-vlan routing

Okay, here's my config on the 3750. As you can see, my vlan SVIs are up and running and I can ping a host on vlan 1. however, when i try to use extended ping to reach that same vlan 1 host from vlan 2's SVI, it times out. my vlan 1 host does have the vlan 1 SVI as its default gateway.

Please help!!

Matt

Switch#

Switch#show run

Building configuration...

Current configuration : 1136 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

no aaa new-model

switch 1 provision ws-c3750g-12s

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

!

!other interfaces omitted...

!

!

interface GigabitEthernet1/0/12

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

!

interface Vlan1

ip address 20.40.254.254 255.255.0.0

!

interface Vlan2

ip address 10.135.254.254 255.255.0.0

!

ip classless

ip http server

!

!

control-plane

!

!

line con 0

line vty 0 4

no login

line vty 5 15

no login

!

!

end

___________________________________________

Switch#ping 20.40.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.40.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/9 ms

Switch#ping

Protocol [ip]:

Target IP address: 20.40.1.1

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 10.135.254.254

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.40.1.1, timeout is 2 seconds:

Packet sent with a source address of 10.135.254.254

.....

Success rate is 0 percent (0/5)

Switch#

450
Views
20
Helpful
9
Replies
CreatePlease to create content