Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750 Inter-VLAN Routing

Need a little help on this one. I am using a Catalyst 3750 for my L3 switch. I need to add 4 servers in one subnet to a VLAN, and 4 other servers in a different subnet to a second VLAN, then configure the switch to provide routing between the two VLANs. I am simulating my company's disaster recovery solution in a lab environment. Any help would be GREATLY appreciated! This is driving me nuts!

8 REPLIES
Purple

Re: 3750 Inter-VLAN Routing

It should look like this .

ip routing

int vlan 2

ip address 192.168.2.254 255.255.255.0

no shut

in vlan 3

ip address 192.168.3.254 255.255.255.0

no shut

to put interfaces into vlan

int g1/0/1

switchport access vlan 2

int g1/0/2

switchport access vlan 3

New Member

Re: 3750 Inter-VLAN Routing

Here's an example, hopefully you can clarify a little bit on what commands I run.

Say I have VLAN 2 (IP's 160.190.100.20-23) and VLAN 3 (IP's 20.20.90.10-13). VLAN 2 is on ports 1-4, and VLAN 3 on ports 13-16.

Would I have to run int g1/0/1-4 with the switchport access vlan 2 command, or 3 command? And do I do that on all ports?

Sorry, I'm fairly new Cisco equipment. not quite sure how to do all this. I have the VLANs configured with the 8 systems (4 in each of the 2 VLANs). Just don't know how to move on from there.

New Member

Re: 3750 Inter-VLAN Routing

If a host IP falls within your VLAN 2 IP range, then it's port should be given the following commands:

switchport mode access

switchport access vlan 2

Same applies to host IPs within your VLAN 3 range.

I'm not sure what size subnets you are running but assuming the following:

VLAN 2 = 160.190.100.0/27

VLAN 3 = 20.20.90.0/27

On your L3 switch:

ip routing

int vlan 2

ip address 160.190.100.1 255.255.255.224

no shut

int vlan 3

ip address 20.20.90.1 255.255.255.224

no shut

to place interfaces into the appropriate VLAN

int range g1/0/1 - 4

switchport mode access

switchport access vlan 2

int range g1/0/13 - 16

switchport mode access

switchport access vlan 3

Assuming your hosts are plugged into your L3 switch, the VLANs will be created once you assign ports to them without you having to create them through other commands. You should see a message similar to "VLAN 3 does not exist, creating VLAN 3" or something like that. Verify that they were actually created with the show vlan command.

New Member

Re: 3750 Inter-VLAN Routing

Ok...So in the

int vlan 2

ip address 160.190.100.1 255.255.255.224

no shut

int vlan 3

ip address 20.20.90.1 255.255.255.224

no shut

the ip addresses 100.1 and 90.1 are my gateway addresses, correct?

Cisco Employee

Re: 3750 Inter-VLAN Routing

Hi Friend,

Yeah you got it right!!

IP 160.190.100.1 will be gateway for your machines which are in vlan 2

IP 20.20.90.1 will be the gateway for your machines which are in vlan 3

HTH

Ankur

*Pls rate all helpfull post

New Member

Re: 3750 Inter-VLAN Routing

Ok. I must be doing something wrong. I still cannot get this to work. Here's the setup. Maybe this can help:

Vlan 2

sys 1 - 160.190.100.20 255.255.255.0

sys 2 - 160.190.100.21 255.255.255.0

sys 3 - 160.190.100.22 255.255.255.0

sys 4 - 160.190.100.23 255.255.255.0

vlan 3

sys 1 - 20.20.90.10 255.255.255.224

sys 2 - 20.20.90.11 255.255.255.224

sys 3 - 20.20.90.12 255.255.255.224

sys 4 - 20.20.90.13 255.255.255.224

All systems connected directly to the 3750. VLAN 2 ports 1-4, VLAN 3 ports 13-16. None of the systems have a default gateway.

I've attached a MS Word doc showing the commands I'm running. Can someone help me sort through this please? Thanks for all the great help everyone!

Re: 3750 Inter-VLAN Routing

please configure default gateway on systems otherwise servers in one VLAN will not be able to communicate with servers in second VLAN.

so, servers in VLAN 2 will be configured with 160.190.100.1 while servers in VLAN 3 will be configured with 20.20.90.1 as default gateway.

secondly, in your document, you mentioned that while configuring VLAN 2, you get message saying it overlaps VLAN 1, so probably if you are not using VLAN 1, shut the interface like this.

interface vlan 1

shutdown

try to ping between PCs which are in different VLAN and let us know with the results.

Purple

Re: 3750 Inter-VLAN Routing

Your client nics must have their default gateway pointed to the router address of the vlan they are attached to.

173
Views
0
Helpful
8
Replies
CreatePlease to create content