Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750 internal DHCP server to serve specific VLAN

Hi,

I have set up what i hope to be a correct configuration for the DHCP server internally on my 3750.

I want to be able use the pool 'wifi_pool' only for one SVI (vlan 20), and not respond to requests from other VLANs.

I've been looking around but cannot find how to do this.

Can anyone help please?

Mark

ip dhcp excluded-address 10.82.48.81 10.82.48.84

!

ip dhcp pool wifi_pool

network 10.82.48.80 255.255.255.240

domain-name wifinet

dns-server 10.82.49.15 10.82.49.22

default-router 10.82.48.81

lease 7

!

interface Vlan20

ip address 10.82.48.81 255.255.255.240

!

interface Vlan25

ip address 10.82.48.65 255.255.255.240

!

interface GigabitEthernet2/0/13

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet2/0/14

switchport access vlan 25

switchport mode access

!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: 3750 internal DHCP server to serve specific VLAN

Hi Mark,

This should work and device connected to Gi 2/0/13 will receive ip address. The device connected to Gi 2/0/14 will not receive IP from this switch.

The only thing i will suggest you shoud also configure "Spanning-tree portfast" on Gi 2/0/13.

I think in global configuration you may have to issue command "Service DHCP" but i am sure by default this service is turned on on 3750s.

Please also Check you have IP routing enabled and there is at least 1 more device active in Vlan25 so you can perform Ping test. The Vlan will not be up unless you have a trunk link up/up or at least 1 device up/up in each Vlan.

You are good to go

Hope this Helps please rate the post....

Shaheen

3 REPLIES

Re: 3750 internal DHCP server to serve specific VLAN

Hi Mark,

This should work and device connected to Gi 2/0/13 will receive ip address. The device connected to Gi 2/0/14 will not receive IP from this switch.

The only thing i will suggest you shoud also configure "Spanning-tree portfast" on Gi 2/0/13.

I think in global configuration you may have to issue command "Service DHCP" but i am sure by default this service is turned on on 3750s.

Please also Check you have IP routing enabled and there is at least 1 more device active in Vlan25 so you can perform Ping test. The Vlan will not be up unless you have a trunk link up/up or at least 1 device up/up in each Vlan.

You are good to go

Hope this Helps please rate the post....

Shaheen

New Member

Re: 3750 internal DHCP server to serve specific VLAN

That's great. Works a treat.

I have been reading about portfast, and have enabled it on another cisco switch which is to have end-users attached to the ports.

However, the documentation suggests that it should only be used for that, and not any interfaces which have another switch/hub etc attached.

The port is to be attached to a wireless hub, so there will not be any STP messages traveling to it. Should i enable port-fast?

Mark

Hall of Fame Super Blue

Re: 3750 internal DHCP server to serve specific VLAN

Mark

No you shouldn't enable portfast on this port. Porfast basically bypasses STP listening/learning states and goes straight to forwarding. You absolutely don't want this on a port connected to a hub.

Jon

498
Views
0
Helpful
3
Replies
CreatePlease to create content