Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

3750 Routing issue... EIGRP not working.

Hi Pros!

I seem to be cursed with getting these annoying issues...

I have three devices involved with this:

3640 router (12.2(17a))

3750-48PS-S (IPServices image, just upgraded from IPBase, 12.2(44)SE2)

4503-E with SupIV (12.2(40)SG)

The 3640 and 4503 are connected to the 3750 on VLAN 59 (192.168.59.0/24)

IP Routing is enabled on the 3750 and 4503.

I am trying to get EIGRP to run between the three devices. I enable EIGRP AS 1 on all three routers... nothing. I do a debug eigrp packets, debug ip eigrp etc etc and I'm not seeing any EIGRP traffic on any of the devices.

I can get OSPF to come up between the three of them, I can get BGP to come up between them, but no EIGRP and oddly enough, no RIP either.

Pertinent configs:

3640:

interface FastEthernet0/0

description LAN link for Ops Center

ip address 192.168.59.1 255.255.255.0

no ip proxy-arp

ip route-cache flow

load-interval 30

speed 100

full-duplex

router eigrp 1

redistribute connected

network 192.168.0.0

auto-summary

3750:

ip routing

interface FastEthernet1/0/48

description Uplink Cisco 3640

switchport access vlan 59

switchport mode access

switchport nonegotiate

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

macro description cisco-phone | cisco-switch

spanning-tree portfast

spanning-tree bpduguard enable

spanning-tree link-type point-to-point

service-policy input AutoQoS-Police-CiscoPhone

interface FastEthernet1/0/13

description Uplink to 4503

switchport access vlan 64

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 859

switchport port-security maximum 3

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

macro description cisco-phone

service-policy input AutoQoS-Police-CiscoPhone

end

interface Vlan59

ip address 192.168.59.254 255.255.255.0

router eigrp 1

redistribute connected

network 192.168.0.0

4503-E:

interface Gi2/1

description uplink to 3750

switchport trunk encapsulation dot1q

switchport mode trunk

interface Vlan59

ip address 192.168.59.253 255.255.255.0

router eigrp 1

network 192.168.0.0

redistribute connected

1 REPLY
Bronze

Re: 3750 Routing issue... EIGRP not working.

Wow, I feel dumb. I fixed it... changed the network statement under EIGRP to network 192.168.59.0 0.0.0.255 and all 3 came up.

1401
Views
0
Helpful
1
Replies