Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

3750 switch need internet connection through linksys modem

hi

we already using linsys router for internet for different vlans

now we take 3750 as core switch for another  differents vlans 10,20 we create vlans 20,20 also create dhcp servers and we need internet for vlans 10,20 through linksys router how should we configure

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

3750 switch need internet connection through linksys modem

If you have PCs etc on VLANs 10 and 20 the normal way to do this would be to create a new VLAN lets say 30.

Configure an access port in VLAN 30 and connect your router there.

Give the SVI for VLAN 30 an ip address on the same subnet as the inside interrface of your router. Then set a default route on the 3750 pointing to the IP address of the router.

Something like this

interface gig1/3

    switchport access vlan 30

interface vlan 30

     ip address 192.168.1.7 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.1

The above assumes that the inside address of your router is 192.168.1.1/24

5 REPLIES
New Member

3750 switch need internet connection through linksys modem

If you have PCs etc on VLANs 10 and 20 the normal way to do this would be to create a new VLAN lets say 30.

Configure an access port in VLAN 30 and connect your router there.

Give the SVI for VLAN 30 an ip address on the same subnet as the inside interrface of your router. Then set a default route on the 3750 pointing to the IP address of the router.

Something like this

interface gig1/3

    switchport access vlan 30

interface vlan 30

     ip address 192.168.1.7 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.1

The above assumes that the inside address of your router is 192.168.1.1/24

New Member

3750 switch need internet connection through linksys modem

hi

vlan30 is accesing internet but for vlan10,vlan20 internet is not working  please check the configuration

Switch#sh run
Building configuration...

Current configuration : 1445 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750g-12s
ip subnet-zero
!
ip dhcp pool vlan10
   network 10.1.2.0 255.255.255.0
   default-router 10.1.2.1
   dns-server 10.1.1.1
!
ip dhcp pool vlan20
   network 10.1.3.0 255.255.255.0
   default-router 10.1.3.1
   dns-server 10.1.1.1
   lease 0 4
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface Vlan1
ip address 10.1.1.10 255.255.255.0
no ip route-cache
!
interface Vlan10
ip address 10.1.2.1 255.255.255.0
no ip route-cache
!
interface Vlan20
ip address 10.1.3.1 255.255.255.0
no ip route-cache
!
interface Vlan30
no ip address
no ip route-cache
!
interface Vlan40
no ip address
no ip route-cache
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end

New Member

3750 switch need internet connection through linksys modem

hi

we try for default route for vlan20 ,vlans 10 but internet is not  working for vlan10 vlans 20

New Member

3750 switch need internet connection through linksys modem

Your problem is here:

interface Vlan30

no ip address

no ip route-cache

You have no IP address on the switch on VLAN 30.

You need to add teh foillwing:

interface Vlan30

     ip address X.X.X.X Y.Y.Y.Y

ip route 0.0.0.0 0.0.0.0 Z.Z.Z.Z

Replace x.x.x.x y.y.y.y with an ip address from the subnet that your linksys router is on. Repklace z.z.z.z with teh ip address of your :Linksys router.

You will also need to add a static route on your linksys router pointing back at the 3750 for the subnets for VLAN 10 and 20 etc. I suggest just point ing 10.1.0.0 at whatever IP address you use for x.x.x.x above.

New Member

3750 switch need internet connection through linksys modem

hi

yeh ur correct i try i got

2260
Views
0
Helpful
5
Replies
CreatePlease to create content