Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

3750 Voice Traffic

Hi,

I am trying to policed voice traffic on a 3750 and remarked it from CS3 to dscp 8

interface FastEthernet 0

switchport access vlan 10

switchport mode access

switchport voice vlan 20

(Are these commands correct ?)

mls qos trust device cisco-phone

mls qos trust cos

spanning-tree portfast

service-policy input mark-sccp

policy-map mark-sccp

class mark-sccp

set dscp cs3

police 9000 8000 exceed-action policed-dscp-transmit

class-map match-all mark-sccp

match access-group 101

access-list 101 permit tcp any any eq 2000

!

mls qos map policed-dscp 24 to 8

(Do I need this ?)

mls qos map cos-dscp 0 8 16 24 32 46 48 56

How do you see that the marking has changed if it exceeds 9000 in the scenario?

No matter how much traffic I put , i don't seem to see any change in the statistics.

Any help appreciated.

Thank you.

4 REPLIES

Re: 3750 Voice Traffic

If remeber well, you cannot place this policy on a physical (layer2) interface with a standard image switch. It must be placed on a layer3 interface instead.

In this case, you should configure it on the voice vlan (20)

regards,

Leo

Re: 3750 Voice Traffic

Hi pjchen,

Are you trying to police voice payload traffic or voice signalling traffic.

Your config polices the signalling traffic which is pretty low bandwidth anyway.

To police voice payload traffic you need to change your class map statement to the following:

class-map match-all mark-voicertp

match ip rtp 16384 16383

Community Member

Re: 3750 Voice Traffic

Hi James,

Thanks for the reply. I am trying to police voice traffic, my mistake.

Are the rest of the configs correct then ?

Thanks,

Paul

Re: 3750 Voice Traffic

Hi Paul

The config below should do what you are trying to achieve.

CAT3750(config)#mls qos map policed-dscp 0 24 46 to 8

! Excess traffic marked 0 or CS3 or EF will be remarked to CS1

CAT3750(config)#

CAT3750(config)#class-map match-all IPPHONE-VOICE

CAT3750(config-cmap)# match access-group name IPPHONE-VOICE

CAT3750(config-cmap)#class-map match-all IPPHONE-SIGNALING

CAT3750(config-cmap)# match access-group name IPPHONE-SIGNALING

CAT3750(config-cmap)#exit

CAT3750(config)#

CAT3750(config)#policy-map IPPHONE-PC

CAT3750(config-pmap)#class IPPHONE-VOICE

CAT3750(config-pmap-c)# set ip dscp 46 ! IPphone VoIP is marked to DSCP EF

CAT3750(config-pmap-c)# police 128000 8000 exceed-action policed-dscp-transmit

! Out-of-profile IPPhone voice traffic is marked down to Scavenger (CS1)

CAT3750(config-pmap-c)#class IPPHONE-SIGNALING

CAT3750(config-pmap-c)# set ip dscp 24 ! Signaling is marked to DSCP CS3

CAT3750(config-pmap-c)# police 32000 8000 exceed-action policed-dscp-transmit

! Out-of-profile Signaling traffic is marked down to Scavenger (CS1)

CAT3750(config-pmap-c)#class class-default

CAT3750(config-pmap-c)# set ip dscp 0

CAT3750(config-pmap-c)# police 5000000 8000 exceed-action policed-dscp-transmit

! Out-of-profile data traffic is marked down to Scavenger (CS1)

CAT3750(config-pmap-c)# exit

CAT3750(config-pmap)#exit

CAT3750(config)#

CAT3750(config)#interface GigabitEthernet0/1

CAT3750(config-if)# service-policy input IPPHONE-PC ! Applies policy to int

CAT3750(config-if)#exit

CAT3750(config)#

CAT3750(config)#ip access list extended IPPHONE-VOICE

CAT3750(config-ext-nacl)# permit udp any any range 16384 32767 ! VoIP ports

CAT3750(config-ext-nacl)#

CAT3750(config-ext-nacl)#ip access list extended IPPHONE-SIGNALING

CAT3750(config-ext-nacl)# permit tcp any any range 2000 2002 ! SCCP ports

CAT3750(config-ext-nacl)#end

This is based upon the Enterprise QoS Design Guide at the link below:

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/QoSDesign.html

210
Views
0
Helpful
4
Replies
CreatePlease to create content