Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750 with LLDP-MED

LLDP-MED is now supported in the 3750 switch with 12.2(37)SE. The release notes gives a description of LLDP and LLDP-MED and the Configuration Guide tells how LLDP is on by default and that through the Network Policy TLV the switch can notify the IP phone of the VLAN number to use.

But - nowhere in the Configuration Guide, or the Command Reference does it state how to configure LLDP-MED to use a VLAN number.

On my switch I want to use vlan 10 for data and vlan 910 for voice.

How do I configure the switch to use LLDP-MED to tell a connected IP phone to use VLAN 910?

10 REPLIES
New Member

Re: 3750 with LLDP-MED

I have this issue , Has anyone resolved this.

In my case I am using Nortel 1120E phones. I cant ge the Cisco 3560 running 12.2(37)SE to send the voice vlan number using LLDP-MED

Re: 3750 with LLDP-MED

Testing LLDP-MED in the lab with Nortel phones. Same result here, no dice. I see the phone under "show LLDP neighbors" but no Voice VLAN. What is the trick to making this work?

New Member

Re: 3750 with LLDP-MED

Ther is a very bad bug in the Nortel LLDP firmware, fixed in an upcoming release. I had to push Nortel but they screwed up. I have tested the new code on a 3750 and it works fine

Re: 3750 with LLDP-MED

What version of code are you running on the PBX and VOIP handsets?

ITG, Succession or BCM?

New Member

Re: 3750 with LLDP-MED

It should be on by default, there is a bug.

To get LLDP-MED to work you need to enable "IP Routing" in the interim

Cheers Steve

Re: 3750 with LLDP-MED

Steve - That worked, cool. Do you have a BugID on this? How did you discover that "IP ROUTING" fixes LLDP?

Re: 3750 with LLDP-MED

Tried the new code 12.2(40) with the same result. Steve - Do you know the bug status and/or number?

New Member

Re: 3750 with LLDP-MED

Hi,

See below

BugID: CSCsj87991

What Changed: Status Group, Bug Status

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsj87991

cheers

Steve

Re: 3750 with LLDP-MED

Can any of you guys running LLDP with Nortel phones test something out for me? When I turn on port security, I've noticed it blocks the LLDP hellos from the i2004, and the devices drop out of the LLDP neighbors list. However, the phones still get their VVID from LLDP-MED. Can someone try this in their environment and verify the results. Running 12.2(44)SE.

Sample interface config

interface FastEthernet1/0/4

switchport access vlan 16

switchport mode access

switchport voice vlan 116

switchport port-security maximum 3

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

no logging event link-status

no logging event power-inline-status

no mdix auto

spanning-tree portfast

ip dhcp snooping limit rate 10

Re: 3750 with LLDP-MED

FYI - Cisco engineering has identified the bug CSCsm95859. May not be publicly accessible yet. It has to do with installing the right internal ACL for LLDP when port security is turned on.

815
Views
10
Helpful
10
Replies