Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3750-X and ASA LAN and VPN routing question

Hi,

I'm having a little problem maybe with my understanding or with my routing.

I have a 3750X (192.168.1.1) stack and an ASA 5510 (192.168.1.2).

The ASA has some VPN tunnels established through internet to several other ASA locations/subnets (192.168.2, 192.168.3, 192.168.4...), plus I have other routed subnets in the LAN (routed through the 3750X).

In the 3750X, I have this satic route entered, and routes for routed ports on the switch :

ip route 0.0.0.0 0.0.0.0 192.168.1.2  (the ASA)

Now, I want my servers/users to have the 3750X as their default gateway (192.168.1.1) so that they can access everything, from the Internet to the routed subnets, to the ASA tunneled subnet.  Am I doing it right ?

In theory, it works, but in practice, something's wrong because it looks like the packets coming from the VPN/tunelled subnets get lost when they return, the TTL changes (by an increment of 1).

If I ping from 192.168.1.200 to 192.168.2.200 :

Forward Trip

(user1: 192.168.1.200) ---> (switch: 192.168.1.1) ---> (asa1: 192.168.1.2) <<vpntunnel>> (asa2: 192.168.2.2) ---> (user2: 192.168.2.200)

Return Trip

(user2: 192.168.2.200 ---> (asa2: 192.168.2.2) <<vpntunnel>> (asa1: 192.168.1.2) <<direct-lan>> (user1: 192.168.1.200)

It seems to confuse the applications as it looks like the forward and return trip are not exactly the same ?  Am I missing something in the ASA, should the packets be pushed back to the 3750X when it returns ?  If so, how do I do this ?

This is causing problems with almost every applications in terms of disconnection, network errors.

The only way to 'fix' those problems is to put the ASA as the default route on the users/servers workstations, instead of using the 3750X as the default route.

What's the right way to to this ?

Thanks !

JFG

Everyone's tags (2)
1 REPLY
Hall of Fame Super Blue

Re: 3750-X and ASA LAN and VPN routing question

You need a separate subnet between the 3750 and the ASA. There are 2 ways to do this  -

1) use a L3 routed port from the 3750 to the ASA

or

2) create a new vlan and use an SVI for the connection to the ASA.

You would also need to update your routing tables on the switch and ASA for both 1) and 2)

Which one to use depends on how many addresses you need in that subnet. If it is just the switch and ASA you can use either. But if, for example, you were going to be adding another ASA as a standby for redundancy you can only use option 2).

I generally use option 2.

So -

option 1

======

subnet = 192.168.5.0 255.255.255.252

3750

-------

int gi0/0 <---- this connects to ASA

no switchport

ip address 192.168.5.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 192.168.5.2

ASA

-------

on the ASA assign 192.168.5.2 255.255.255.252 to the inside interface

then for each subnet routed on the 3750 you now need routes eg.

route inside 192.168.1.0 255.255.255.0 192.168.5.1

Option 2

======

subnet = 192.168.5.0 255.255.255.248

vlan = 10 (this should be a new vlan)

ASA configuration is exactly the same except the subnet mask is different ie. 192.168.5.2 255.255.255.248

3750

-------

vlan 10

int gi0/0  <-- this connects to ASA

switchport

switchport mode access

switchport access vlan 10

int vlan 10

ip address 192.168.5.1 255.255.255.248

no shut

ip route 0.0.0.0 0.0.0.0 192.168.5.2

Jon

170
Views
0
Helpful
1
Replies
CreatePlease to create content