Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

3750-X stack not routing

Hi, I have just had a to revert a customer due to a failed install. Hoping someone can help.

 

Replacing an HP core with Cisco 3750's configured up all the vlan s and IP addresses. Created two port channels, 11 and 12 to take 10gig uplinks from cisco fabric interconnects (Currently they have 1gig connections into the HP). Plugged the 10 gigs, vlans cane up.. Dang switch wont ping the UCS manager on vlan 220 from either default vlan or using vlan 220 as a source. all VM's lost connections within the UCS (they are supposed to switch inside the FI's). Must be something wrong with my config pasted below... Had a laptop plugged into a port I configures as an access port on VLAN 220, could ping the ip address of the vlan 220 interface but not the interface of vlan 1 or the ucs manager. ANy help or pointers appreciated and apologies for the long post.

 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.05.30 08:24:31 =~=~=~=~=~=~=~=~=~=~=~=
sh run
Building configuration...

Current configuration : 13110 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vvvv
!
boot-start-marker
boot-end-marker
!
enable secret 5 vvv
!
username root privilege 15 secret 5 vvvv
!
!
no aaa new-model
switch 1 provision ws-c3750x-48
switch 2 provision ws-c3750x-48
system mtu routing 1500
ip routing
!
!
ip domain-name vvv
ip name-server 192.168.220.31
ip name-server 192.168.220.59
!
!
crypto pki trustpoint TP-self-signed-2806828672
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2806828672
 revocation-check none
 rsakeypair TP-self-signed-2806828672
!
!
crypto pki certificate chain TP-self-signed-2806828672
 truncated


  quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,5,205,210,220,230,246,250
 switchport mode trunk
!
interface Port-channel2
 switchport access vlan 20
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
!
interface Port-channel3
 switchport access vlan 20
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
!
interface Port-channel4
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,215,217,220,230
 switchport mode trunk
!
interface Port-channel5
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
!
interface Port-channel6
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
!
interface Port-channel7
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,220
 switchport mode trunk
!
interface Port-channel8
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,215,217,220
 switchport mode trunk
!
interface Port-channel9
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,215,217,220
 switchport mode trunk
!
interface Port-channel10
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,220
 switchport mode trunk
!
interface Port-channel11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel12
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel13
!
interface FastEthernet0
 no ip address
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
!
interface GigabitEthernet1/0/1
 description "Connected_to_Checkpoint_Internal_Interface"
 switchport mode access
!
interface GigabitEthernet1/0/2
 switchport access vlan 215
 switchport mode access
!
interface GigabitEthernet1/0/3
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/0/4
 switchport access vlan 217
 switchport mode access
!
interface GigabitEthernet1/0/5
 switchport access vlan 215
 switchport mode access
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
 switchport access vlan 220
 switchport mode access
!
interface GigabitEthernet1/0/14
 switchport access vlan 220
 switchport mode access
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,220
 switchport mode trunk
 channel-group 10 mode active
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,215,217,220
 switchport mode trunk
 channel-group 9 mode active
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet1/0/29
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,215,217,220
 switchport mode trunk
 channel-group 8 mode active
!
interface GigabitEthernet1/0/30
!
interface GigabitEthernet1/0/31
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,220
 switchport mode trunk
 channel-group 7 mode active
!
interface GigabitEthernet1/0/32
!
interface GigabitEthernet1/0/33
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/34
!
interface GigabitEthernet1/0/35
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 5 mode active
!
interface GigabitEthernet1/0/36
!
interface GigabitEthernet1/0/37
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,215,217,220,230
 switchport mode trunk
 channel-group 4 mode active
!
interface GigabitEthernet1/0/38
!
interface GigabitEthernet1/0/39
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet1/0/40
!
interface GigabitEthernet1/0/41
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
 switchport trunk allowed vlan 1,5,205,210,220,230,246,250
 channel-group 1 mode active
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
!
interface GigabitEthernet1/0/46
!
interface GigabitEthernet1/0/47
!
interface GigabitEthernet1/0/48
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 11 mode on
!
interface TenGigabitEthernet1/1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 12 mode on
!
interface GigabitEthernet2/0/1
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet2/0/13
!
interface GigabitEthernet2/0/14
!
interface GigabitEthernet2/0/15
!
interface GigabitEthernet2/0/16
!
interface GigabitEthernet2/0/17
!
interface GigabitEthernet2/0/18
!
interface GigabitEthernet2/0/19
!
interface GigabitEthernet2/0/20
!
interface GigabitEthernet2/0/21
!
interface GigabitEthernet2/0/22
!
interface GigabitEthernet2/0/23
!
interface GigabitEthernet2/0/24
!
interface GigabitEthernet2/0/25
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,220
 switchport mode trunk
 channel-group 10 mode active
!
interface GigabitEthernet2/0/26
!
interface GigabitEthernet2/0/27
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,215,217,220
 switchport mode trunk
 channel-group 9 mode active
!
interface GigabitEthernet2/0/28
!
interface GigabitEthernet2/0/29
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,215,217,220
 switchport mode trunk
 channel-group 8 mode active
!
interface GigabitEthernet2/0/30
!
interface GigabitEthernet2/0/31
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,201,205,210,220
 switchport mode trunk
 channel-group 7 mode active
!
interface GigabitEthernet2/0/32
!
interface GigabitEthernet2/0/33
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet2/0/34
!
interface GigabitEthernet2/0/35
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 5 mode active
!
interface GigabitEthernet2/0/36
!
interface GigabitEthernet2/0/37
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,215,217,220,230
 switchport mode trunk
 channel-group 4 mode active
!
interface GigabitEthernet2/0/38
!
interface GigabitEthernet2/0/39
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet2/0/40
!
interface GigabitEthernet2/0/41
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,205,210,220,230
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet2/0/42
!
interface GigabitEthernet2/0/43
 switchport trunk allowed vlan 1,5,205,210,220,230,246,250
 channel-group 1 mode active
!
interface GigabitEthernet2/0/44
!
interface GigabitEthernet2/0/45
!
interface GigabitEthernet2/0/46
!
interface GigabitEthernet2/0/47
!
interface GigabitEthernet2/0/48
!
interface GigabitEthernet2/1/1
!
interface GigabitEthernet2/1/2
!
interface GigabitEthernet2/1/3
!
interface GigabitEthernet2/1/4
!
interface TenGigabitEthernet2/1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 11 mode on
!
interface TenGigabitEthernet2/1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 12 mode on
!
interface Vlan1
 description Default
 ip address 192.168.240.1 255.255.255.0
!
interface Vlan5
 description VPN_Backup
 no ip address
!
interface Vlan200
 description Win7_Desktops
 ip address 192.168.200.1 255.255.255.0
 ip helper-address 192.168.220.50
 ip helper-address 192.168.220.138
!
interface Vlan201
 description XenServer_6.1
 ip address 192.168.201.1 255.255.255.0
 ip helper-address 192.168.220.50
 ip helper-address 192.168.220.138
!
interface Vlan205
 description XP_Desktops
 ip address 192.168.205.1 255.255.255.0
 ip helper-address 192.168.220.50
 ip helper-address 192.168.220.138
!
interface Vlan210
 description Thin_Clients
 ip address 192.168.210.1 255.255.255.0
 ip helper-address 192.168.220.50
 ip helper-address 192.168.220.138
 ip helper-address 192.168.220.58
!
interface Vlan215
 description DMZ_Internal
 no ip address
!
interface Vlan217
 description DMZ_External
 no ip address
!
interface Vlan220
 description Servers
 ip address 192.168.220.1 255.255.255.0
!
interface Vlan225
 no ip address
!
interface Vlan230
 description Voice_MXe
 ip address 192.168.230.1 255.255.255.0
!
interface Vlan246
 description CCTV
 no ip address
!
interface Vlan250
 description Xconnect_to_Foundry
 ip address 192.168.250.220 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.240.254
ip http server
ip http secure-server
!
snmp-server community iwontusepublic RO unrestricted
snmp-server contact "Mark Guest" location "DP Core Switch"
snmp-server enable traps config-copy
snmp-server host 192.168.220.42 iwontusepublic
!
!
line con 0
 exec-timeout 30 0
 logging synchronous
 login local
line vty 0 4
 exec-timeout 30 0
 logging synchronous
 login local
 transport input telnet ssh
line vty 5 15
 exec-timeout 30 0
 logging synchronous
 login local
 transport input telnet ssh
!
ntp server 192.168.220.31
end

 

4 REPLIES
Cisco Employee

Hmm. Did you create those

Hmm. Did you create those VLANs on the switch? :) Also, check spanning-tree and check the trunk ports and make sure that the VLANs are allowed across. Also, make sure you allow the VLANs on the trunk from the FIC/UCS side as well. 

Community Member

Vlan Database..Vlan 1..Vlan 2

Vlan Database..Vlan 1..Vlan 2 etc.. Right.. Yep did that but have been cought out here before :-)

Unless I am missing something "ip routing" should just spring it all to life shouldn't it?

The PO's were up and both links in them forwarding so the negotiation worked I assumed.

Vlans mush be assigned from the UCS side because it's working no, plugged into an HP switch (at 1g)

vlans were allowed because PO11 and 12 were configed with switchport mode trunk only

Could the UCS have been set to 220 native? Would that cause my issue?

Community Member

OK so on more research the

OK so on more research the UCS only uses LACP so the channel group needs to be active not on.

int range ten 1/1/1, ten 1/1/2

no channel-group 11 mode on

channel-group 11 mode active...

etc.

 

I'll keep researching.

Cisco Employee

Sorry I somehow missed your

Sorry I somehow missed your previous comment.

About the native VLAN: You should definitely have it matching on both sides. Otherwise, it can definitely cause issues. For instance, if it is native 220 on the UCS but 1 on the switch then traffic from the UCS on VLAN 220 would come untagged across the trunk. Since the traffic does not have a VLAN tag the switch would assume that it should be riding on VLAN 1 (the local native VLAN) and vice-versa

You should issue show interface trunk and show CDP neighbor detail on the switch and post the output here.

About the port-channeling protocol: I have not worked much with UCS but even if it did support channel-group on, I would still recommend that you use LACP

A couple of other things to test:

1. From your test machine on VLAN 220, can you ping another host on that switch that is in a different VLAN?

2. From the same test machine can you ping another upstream device/IP. For instance, the default gateway or an upstream router/L3 switch...basically something other than UCS and hosts behind it

 

137
Views
0
Helpful
4
Replies
CreatePlease to create content