Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750-x with C3KX-NM-10G not recognizing SFP

I have a 3750-x switch with module C3KX-NM-10G.  In slots 1 and 3 I have GLC-T inserted, no problem.  When I try to insert GLC-T into slots 2 or 4, I receive the log messages that are listed below.  I can swap/mix and match different GLC-T's in slots 1,2,3, and 4, the SFP's are recognized every time in slots 1 and 3, and are never recognized in slots 2 or 4. 

Slots 2 and 4 also double as the Ten Gig interfaces, which we are not using right now.

Is there some trick to getting the switch to recognize SFPs in slots 2 and 4?

Switch model: WS-C3750X-24

Module: C3KX-NM-10G

IOS: 12.2(53)SE2 (IP Base)

Log messages:

.Jul 30 17:52:02: %PHY-4-SFP_NOT_SUPPORTED: The SFP in Gi1/1/2 is not supported

.Jul 30 17:52:02: %PM-4-ERR_DISABLE: gbic-invalid error detected on Gi1/1/2, putting Gi1/1/2 in err-disable state

.Jul 30 17:55:58: %PHY-4-SFP_NOT_SUPPORTED: The SFP in Gi1/1/4 is not supported

.Jul 30 17:55:58: %PM-4-ERR_DISABLE: gbic-invalid error detected on Gi1/1/4, putting Gi1/1/4 in err-disable state

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Re: 3750-x with C3KX-NM-10G not recognizing SFP

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Just wondering, are the 10 gig ports shutdown?

PS:

Just found this:

This module has four slots. Two slots support only 1-Gigabit SFP modules, two slots support either 1-Gigabit SFP or 10-Gigabit SFP+ modules.

Note The GLC-T SFP is not supported on the SFP+ slots of C3KX-NM-10G.

The four slots are grouped as two pairs with each pair consisting of one SFP slot and one SFP+ slot. Each pair supports either two 1-Gigabit SFP modules or one 10-Gigabit SFP+ module. A 10-Gigabit SFP+ module cannot operate at the same time as the corresponding 1-Gigabit SFP module in the pair.

Supported combinations of SFP and SFP+ modules:

•Slots 1, 2, 3, and 4 populated with 1-Gigabit SFP modules.

•Slots 1 and 2 populated with 1-Gigabit SFP modules and Slot 4 populated with one 10-Gigabit SFP+ module.

•Slot 2 populated with one 10-Gigabit SFP+ module and Slots 3 and 4 populated with 1-Gigabit SFP modules.

•Slot 2 and Slot 4 each populated with 10-Gigabit SFP+ modules.

6 REPLIES
Super Bronze

Re: 3750-x with C3KX-NM-10G not recognizing SFP

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Just wondering, are the 10 gig ports shutdown?

PS:

Just found this:

This module has four slots. Two slots support only 1-Gigabit SFP modules, two slots support either 1-Gigabit SFP or 10-Gigabit SFP+ modules.

Note The GLC-T SFP is not supported on the SFP+ slots of C3KX-NM-10G.

The four slots are grouped as two pairs with each pair consisting of one SFP slot and one SFP+ slot. Each pair supports either two 1-Gigabit SFP modules or one 10-Gigabit SFP+ module. A 10-Gigabit SFP+ module cannot operate at the same time as the corresponding 1-Gigabit SFP module in the pair.

Supported combinations of SFP and SFP+ modules:

•Slots 1, 2, 3, and 4 populated with 1-Gigabit SFP modules.

•Slots 1 and 2 populated with 1-Gigabit SFP modules and Slot 4 populated with one 10-Gigabit SFP+ module.

•Slot 2 populated with one 10-Gigabit SFP+ module and Slots 3 and 4 populated with 1-Gigabit SFP modules.

•Slot 2 and Slot 4 each populated with 10-Gigabit SFP+ modules.

New Member

3750-x with C3KX-NM-10G not recognizing SFP

Huh I missed the part about GLC-T not being supported, that seems rather random.  Thanks for finding that!

And yes, the 10g ports are shut down.

New Member

3750-x with C3KX-NM-10G not recognizing SFP

I have a WS-C3750X-24T-S running 15.02.SE. I'm trying to bring up 10gig with SFP-10GBase-LR media. While trobleshooting the fiber plant, I did a loop between the SFP+ ports, the port went green, and I then got the message:

*Mar 26 17:54:20.622: %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on TenGigabitEthernet2/1/2. (C3750X-DC-P10-2)

*Mar 26 17:54:20.622: %PM-4-ERR_DISABLE: loopback error detected on Te2/1/2, putting Te2/1/2 in err-disable state (C3750X-DC-P10-2)

The port went amber.

I tried to shut/no shut and the port stays amber (with no media attached).

How do I reset the port?

Hall of Fame Super Gold

3750-x with C3KX-NM-10G not recognizing SFP

Reboot.

New Member

3750-x with C3KX-NM-10G not recognizing SFP

Thanks for the reply.

I have two stacks of 3750X supporting data center to data center traffic. I rebooted about two weeks ago when I upgraded to 15.02.SE.

Are you saying that when a NM port goes err-disable, the only recovery is reboot?

Is that a bug? I've never seen that on any Cisco switch I've ever worked on.

Can I reset the NM somehow instead - either via command or remove/reinstall the NM?

VIP Super Bronze

3750-x with C3KX-NM-10G not recognizing SFP

Are you saying that when a NM port goes err-disable, the only recovery is reboot?

Usually when a port goes to err-disable you sh and no sh the port and that will clear things up.

If you have already done this the next solution would be to reboot.  If reboot does not help, you can take the NM module out and reinsert it back.  I have seen a couple cases where the NM module does not get inserted all the way.  So, redoing it may help. Also, make sure the NM module seats in the slot correctly.

HTH

7570
Views
0
Helpful
6
Replies
CreatePlease login to create content