Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

3750E ACL marked traffic are not in the correct Queue

Hi, Qos question.

We tested a QoS in a Cisco 3750E, IOS: 12.2(58)SE2.

Voice traffice in the correct Q without any problem, but all the others traffic the Defualt Q (0), tried to capture the traffic and tcp/udp port are correct.

Any thing wrong with my ACL or DSCP - CoS?? ( that ACL works fin on 4500 and 6500)

Thanks ahead.

LAB-C3750e-24pd#show mls qos int g1/0/1 statistics
GigabitEthernet1/0/1 (All statistics are in packets)

  dscp: incoming
-------------------------------

  0 -  4 :      135997            0            0            0            0
  5 -  9 :           0            0            0            0            0
10 - 14 :           0            0            0            0            0
15 - 19 :           0            0            0            0            0
20 - 24 :           0            0            0            0           18
25 - 29 :           0            0            0            0            0
30 - 34 :           0            0            0            0            0
35 - 39 :           0            0            0            0            0
40 - 44 :           0            0            0            0            0
45 - 49 :           0         1313            0            0            0
50 - 54 :           0            0            0            0            0
55 - 59 :           0            0            0            0            0
60 - 64 :           0            0            0            0
  dscp: outgoing
-------------------------------

  0 -  4 :       68438            0            0            0            0
  5 -  9 :           0            0            0            0            0
10 - 14 :           0            0            0            0            0
15 - 19 :           0            0            0            0            0
20 - 24 :           0            0            0            0            0
25 - 29 :           0            0            0            0            0
30 - 34 :           0            0            0            0            0
35 - 39 :           0            0            0            0            0
40 - 44 :           0            0            0            0            0
45 - 49 :           0            0            0          220            0
50 - 54 :           0            0            0            0            0
55 - 59 :           0            0            0            0            0
60 - 64 :           0            0            0            0
  cos: incoming
-------------------------------

  0 -  4 :      137335            0            0            0            0
  5 -  7 :           0            0            0
  cos: outgoing
-------------------------------

  0 -  4 :       68789            0            0            0            0
  5 -  7 :           0          220           80
  output queues enqueued:
queue:    threshold1   threshold2   threshold3
-----------------------------------------------
queue 0:           0           0           0

LAB-C3750e-24pd#show mls qos maps dscp-cos
   Dscp-cos map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 00 00 00 00 00 00 00 01 01
      1 :    01 01 01 01 01 01 02 02 02 02
      2 :    02 02 02 02 03 03 03 03 03 03
      3 :    03 03 04 04 04 04 04 04 04 04
      4 :    05 05 05 05 05 05 05 05 06 06
      5 :    06 06 06 06 06 06 07 07 07 07
      6 :    07 07 07 07

LAB-C3750e-24pd#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 46 48 56


******

Here is the config:

interface GigabitEthernet1/0/1

switchport access vlan 874

switchport mode access

srr-queue bandwidth share 5 30 40 10

srr-queue bandwidth shape 0 0 0 0

queue-set 2

priority-queue out

service-policy input QOSMARK

mls qos map cos-dscp 0 8 16 26 32 46 48 56

class-map match-any VoIP

description Voice IP Phone RTP

match access-group 157

(deleted)

class-map match-any Others

description Generic TCP, TFTP

match access-group 151

policy-map QOSMARK

class VoIP

   set dscp ef

(deleted)

class Others

   set dscp cs1

class class-default

set dscp default

access-list 151 remark * Others class (IP Precedence 1)

access-list 151 remark * Bulk NFS and File transfer

access-list 151 permit tcp any any eq 445

access-list 151 permit tcp any eq 445 any

access-list 151 permit tcp any eq 139 any

access-list 151 permit tcp any any eq 139

access-list 151 permit tcp any eq 2049 any

access-list 151 permit tcp any any eq 2049

access-list 151 permit UDP any eq 2049 any

access-list 151 permit UDP any any eq 2049

access-list 151 permit tcp any eq 8447 any

access-list 151 permit tcp any any eq 8447

access-list 151 remark - TFTP traffic

access-list 151 permit udp any any eq tftp

access-list 151 permit udp any eq tftp any

access-list 151 remark ***

access-list 151 remark ****

.

.

.

.

access-list 157 remark * VoIP class (IP Precedence 5)

access-list 157 remark - voice RTP packets

access-list 157 permit udp any any range 16384 32767

access-list 157 permit udp any range 16384 32767 any

access-list 157 remark ***

access-list 157 remark ****

3 REPLIES
Hall of Fame Super Bronze

3750E ACL marked traffic are not in the correct Queue

You won't see the counters incrementing as the QoS tag is applied on ingress.

In order to verify if the QoS tag is applied correctly, you need to verify the counters in the egress port from this switch.

The order of operations is the counters are done before the QoS tag is applied.

BTW, you should modify the cos-to-dscp mapping by following this document:

Table 2-3

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/QoSDesign.html#wp999437

Community Member

3750E ACL marked traffic are not in the correct Queue

*****

In order to verify if the QoS tag is applied correctly, you need to verify the counters in the egress port from this switch.

The order of operations is the counters are done before the QoS tag is applied.

*****

to verify the counters in the egress port - you mean L3 interface? that uplink ports on both side set with mls qos trust dscp.

any command for that (show policy-map interface or others )

Sorry, I am still new in the QoS field.

Hall of Fame Super Bronze

3750E ACL marked traffic are not in the correct Queue

The interface being used as the egress for these packets, being L2 or L3.

The point I'm trying to make is that you won't see counters for packets being tagged while entering the switch.

You will see the counters if the packet has the QoS marking from the end device while entering the switch.

If the switch is tagging the packet at ingress, you will see the marking counters at the egress port.

329
Views
0
Helpful
3
Replies
CreatePlease to create content