Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750G forwarding and routing

Hello,

I have a WS-C3750G-24TS-E1U that needs to act as a simple switch (just forwarding frames) and also do static routing.

For this prefix it just needs to act as a simple switch with default config: 10.10.10.192/27.

Upstream gateway:10.10.10.222. Two fibers plugged from upstream for redundancy.

IP 10.10.10.200 configured on the switch needs to statically route to 10.10.99.0/24.

Which means 10.10.10.200 and 10.10.99.1 will be configured on the router.

Anyone can help me with the proper configuration?

Thanks

Everyone's tags (3)
4 REPLIES
Cisco Employee

3750G forwarding and routing

You can configure all interfaces as SVIs.

For example:

interface vlan 100

  ip address 10.10.10.193 255.255.255.224  <--- first ip address in range 10.10.10.192/27, you will need to put all interfaces in to vlan 100

addresses 10.10.10.200 and 10.10.10.222 are in the same range with 10.10.10.193, so switch won't route traffic to upstream gw, it will switch (so links to upstream gw has to be either trunk or access link in vlan 100)

other ip addresses can be configured in the same way:

interface vlan 101

  ip address  10.10.99.2 255.255.255.0

Can you please explaine a bit more detailed about "IP 10.10.10.200 configured on the switch needs to statically route to 10.10.99.0/24."

If upstream device is a switch - fiber links can be configured as ether-channel

HTH,

Alex

New Member

3750G forwarding and routing

10.10.99.0/24 needs to be routed through 10.10.10.200 (this device).

Or in other words next-hop is set to 10.10.10.200 on the upstream router.

I don't have access to change configuration or setup on upstream.

Below you can see how my current config looks like. From the switch I have access to internet (ping yahoo.com responds for instance). But from a server with IP 10.10.99.4 connected to the switch I don't have access to internet. It doesn't router, as you were saying. Can you tell me how should I change the config?

#show runn
Building configuration...

Current configuration : 1879 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXXX
!
boot-start-marker
boot-end-marker
!
enable secret 5 XXXXXXX
enable password XXXXXXX
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
# ... just lis to of interfaces here ....

interface Vlan1
 ip address 10.10.99.1 255.255.255.0 secondary
 ip address 10.10.10.200 255.255.255.224
!
ip default-gateway 10.10.10.222
ip classless
!
!
ip sla enable reaction-alerts
!
!
!
line con 0
 exec-timeout 0 0
line vty 0 4
 password XXXXXXXXX
 login
line vty 5 15
 password XXXXXXXXX
 login
!
end

Thank you

Re: 3750G forwarding and routing

Why do you want to have this as your next hop yet it is an interface on this router?

ip address 10.10.10.200 255.255.255.224

You need a static route for this:

10.10.99.0/24 needs to be routed through 10.10.10.200 (this device).

ip route 10.10.99.0 255.255.255.0 [next hop ip address].


New Member

3750G forwarding and routing

10.10.10.200 is set as next-hop on the upstream router.

So my switch needs to have 10.10.10.200 configured on it and do routing.

516
Views
0
Helpful
4
Replies
CreatePlease to create content