Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3750X QoS issue

Hi,

i recently configured QoS on 3750x (12.2(55)SE1 ip base)to mark packets regarding access lists (here is a config extract)

*******************

mls qos

class-map match-any test

match access-group name ACL-Test

!

policy-map Ports-access

class test

  set dscp ef

class class-default

  set dscp default

interface GigabitEthernet1/0/1

desc access port

switchport access vlan 30

switchport mode access

duplex full

service-policy input Ports-access

interface GigabitEthernet4/1/4

description Inter switch link

no switchport

ip address XXXXXXXXX

ip pim dense-mode

ip ospf hello-interval 1

ip ospf dead-interval 3

mls qos trust dscp

ip access-list extended ACL-test

permit ip host 172.16.30.21 any

permit ip host 172.16.30.22 any

permit ip host 172.16.30.30 any

**********************************************

The object of this policy is just to mark packets. It's working well (sniffer shows packets marked as expected)

However for an unknown reason, the traffic marked is "policed" to 35% of global bandwidth.

When i apply service policy on interface, and i use a jperf i see only 35Mb/s on jperf server

When i remove service policy, i'm able to see 90Mb/s

Jperf client and server are on the same stack

Thanks for your help

regards

  • LAN Switching and Routing
Everyone's tags (2)
7 REPLIES

3750X QoS issue

You have auto-qos enable in the same segment ?

New Member

Re: 3750X QoS issue

Hi,

no auto qos is not applied on same segment. The config is exactly the one depicted in my post

regards

Re: 3750X QoS issue

Hi Jerome,

Could you please post the below outputs?

show inter Gi1/0/1 | in drops|queue|output

show mls qos inter Gi1/0/1 queueing

show platform port-asic stats drop Gi1/0/1

NOTE : Do clear the counters before taking these outputs. keep the service-policy applied. Generate the traffic using Jperf & record the outputs.

Also, as rizwan stated, was auto-qos enabled ? Basically what happens is, Auto-QoS configures the priority Q to be 25% of the bandwidth. If there is an exceed in the traffic, then default behaviour is to police the traffic. Probably, you can add the statement priority-Queue out on your uplink & see if the issue resolves. But do post the outputs for those above commands.

Thanks

Vivek

New Member

Re: 3750X QoS issue

Hi Vivek,

I'm waiting for infos from on site engineer.

Regards

New Member

Re: 3750X QoS issue

XXX#show interfaces gigabitEthernet 3/0/3 | in drps |                ops | queue | output
  input flow-control is off, output flow-control is unsupported
  Last input never, output 00:00:00, output hang never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  5 minute output rate 12000 bits/sec, 13 packets/sec
     8930986 packets output, 1939664289 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


XXX#show mls qos interface gigabitEthernet 3/0/3 queueing
GigabitEthernet3/0/3
Egress Priority Queue : enabled
Shaped queue weights (absolute) :  0 0 0 0
Shared queue weights  :  1 97 1 1
The port bandwidth limit : 100  (Operational Bandwidth:100.0)
The port is mapped to qset : 1

XXX#show platform port-asic stats drop gigabitEthernet 3/0/3

  Interface Gi3/0/3 TxQueue Drop Statistics
    Queue 0
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 1
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 2
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 3
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 4
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 5
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 6
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 7
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
12P-SWH-C001#

Re: 3750X QoS issue

Hello Jerome,

Is this the interface which is carrying outbound traffic? Looks like not. I need the outputs from the interface which is carrying traffic outbound. The config shows the port to be Gi1/0/1, but your outputs are from 3/0/3 ?

Let me know which interface you have your Jperf client / server sitting on?

Thanks

Vivek

New Member

Re: 3750X QoS issue

try updating the ios to 15.0

2273
Views
0
Helpful
7
Replies