Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

3850 qos question

Hi,

i ve done some qos configuring on the 3850 switch. The Q is What am i doing wrong?

It seems that traffic from my laptop is being put in the high prio queue, or i made a mistake. (I ve checked wireshark, my laptop traffic: dscp 0x00. There is no ip phone connected to the port.

here is a little test config, i want to check here if cos 0 is being put in the low prio queue (priority level 2)  but i only see traffic output in the high prio queue?

I m sure the laptop is sending packets with dscp 0x00

class-map match-any CM_ANY
match dscp default
match cos 0
class-map match-any CM_VOIP
match dscp ef
match cos 5

policy-map TEST
class CM_VOIP
priority level 1 percent 5
class CM_ANY
priority level 2 percent 5

interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
switchport voice vlan 20
trust device cisco-phone
spanning-tree portfast
service-policy output TEST

sh policy-map interface GigabitEthernet 1/0/1

GigabitEthernet1/0/1

Service-policy output: TEST

queue stats for all priority classes:
Queueing
priority level 1

(total drops) 0
(bytes output) 1191

queue stats for all priority classes:
Queueing
priority level 2

(total drops) 0
(bytes output) 0

Class-map: CM_VOIP (match-any)
Match: dscp ef (46)
Match: cos 5
Priority: 5% (500 kbps), burst bytes 12500,

Priority Level: 1

Class-map: CM_ANY (match-any)
Match: dscp default (0)
Match: cos 0
Priority: 5% (500 kbps), burst bytes 12500,

Priority Level: 2

Class-map: class-default (match-any)
Match: any


(total drops) 0
(bytes output) 0

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

3850 qos question

Hi,

traffic from pc and phone is entering this port not exiting and an output policy is for packets exiting a port not entering.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
5 REPLIES
Purple

3850 qos question

Hi,

traffic from pc and phone is entering this port not exiting and an output policy is for packets exiting a port not entering.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

3850 qos question

Hi Alain

ok, ofcourse that makes sense ;-)

I was wondering why all output traffic ends up in prio queue 1.

So what i m seeing in the output of prio queue 1 must be traffic from the switch towards the port the laptop is connected to.

Like stp. I ll do some tests to put that traffic in a different queue since i only want voip in prio queue 1.

Thanks!

.

VIP Purple

3850 qos question

What is your test topology ? Is it single 3850 switch or any other switches ? we understand you connect a laptop to G1/0/1 & you configure QoS on that port ? Traffic comming out of that port, from where it is coming ?

Pls provide more info to see why you get all traffic in high priority queue

Rasika

3850 qos question

Hi, Rasika

thanks for your reply.

Correct, 1 switch and 1 laptop connected to Gi 1/0/1.

I think it must be management traffic coming from the switch going towards the laptop.

i ll do some tests with some class-maps to try and match it and send it to another queue and check wireshark to see what traffic it is. .

VIP Purple

3850 qos question

Connect another PC on to different swichport & check what happens when you communicating with each other. Most of the time in practical scenario, a packet traverse across more than 1 switch. So if you can set up two switches via a trunk link and two end points connect to two differnt switches, that will give you better understanding how each port needs to be configured for QoS

Let us know how you goes with this

Rasika

345
Views
0
Helpful
5
Replies