Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3850 Switch port based DHCP not working

I have a 3850 WS-C3850-48T-E. I've been trying to get port based DHCP working by following this guide:

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_dhcp/configuration/xe-3se/3850/dhcp-xe-3se-3850-book/dhcp-prt-bsd-aa.html

 

It is not working. I've tried a number of interface names such as "Gi1/0/31" and "GigabitEthernet1/0/31" but none of these work. Plain Jane normal, DHCP works just fine.

I'm experiencing this issue with the following IOS's:

cat3k_caa-universalk9ldpe.SPA.03.06.00.E.152-2.E.bin
cat3k_caa-universalk9.SPA.03.03.03.E.150-1.EZ3.bin

 

----config snippet------

ip dhcp use subscriber-id client-id
ip dhcp subscriber-id interface-name
ip dhcp excluded-address 172.16.0.1 172.16.6.0
!
!
ip dhcp pool test
 network 172.16.0.0 255.255.248.0
 default-router 172.16.6.254
   address 172.16.6.1 client-id "Gi1/0/31" ascii

   !!!!! Have also tried: address 172.16.6.1 client-id "GigabitEthernet1/0/31" ascii !!!!!!

 

Any hints? I've Wiresharked the port in question and the DHCP events look normal. My client only receives the first available normal DHCP 172.16.6.2. I always makes sure I release the binding on the client and the switch when trying different combinations.

I have a funny feeling the interface nomenclature may be at fault.

Thanks!

 

 

Everyone's tags (1)
2 REPLIES
Green

HiMy take on this is, lets

Hi

My take on this is, lets say for interfaces gi1/0/31-48

!
ip dhcp use subscriber-id client-id
ip dhcp subscriber-id interface-name
ip dhcp excluded-address 172.16.0.1 172.16.6.0
!
!
ip dhcp pool test
 network 172.16.0.0 255.255.248.0
 default-router 172.16.6.254
 domain-name yournet.com
 dns-server 1.1.1.1 2.2.2.2 3.3.3.3 
!
!
int range gi1/0/31 - gi1/0/48
ip dhcp server use subscriber-id client-id
!
end


Can you test something like that

Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

I have the same problem with

I have the same problem with a new 3850.  The Port-Based DHCP worked on a 3750, but after transferring the config it does no work on the 3850.

 

 

- Tim

 

426
Views
0
Helpful
2
Replies