Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

4507 Config - channel-groups

I have a Dell PE 2650 server which has two Intel Pro/1000 NICs which are teamed, so 1 IP between the two. They plug into my 4507, where each port is in a different channel-group. Each channel-group has a second member port, which is connected to a disabled NIC on the PE (and so in Not-connect state on the Cisco).

My understanding of channel-groups is that they allow two connections to the same physical server by creating a virtual interface - this prevents the spanning-tree protocol from seeing them as a potential loop and blocking one. I was expecting to see the two active ports on the PE in the same channel-group, or, failing that, to only have traffic on one, with the other blocked by the spanning-tree protocol. But both ports show both inbound and outbound traffic?

Any explanation for a tired brain?

4 REPLIES
Cisco Employee

Re: 4507 Config - channel-groups

Hi Thom,

As you mentioned you have 2 nics which are teamed together in your server then you connect in on to the switch ports which are in different channel-group? is what confusing me. Are you saing that the 2 cables which come out from your 2 nics from your server connect to 2 ports on switch and those 2 ports are in different channel group?

If this is the case then the configuration is wrong and both the ports on the switch shoud have same channel group number so they can be bundled together in port-channel interface.

HTH

Ankur

New Member

Re: 4507 Config - channel-groups

Hi Ankur

Yes - the cables from the server (from the teamed NICs) connect to two ports on the switch, and the ports on the switch belong to different channel-groups.

The configuration is working - there is traffic going in both directions through both ports, and the different port-channels both show traffic. Given that, I'm reluctant to make changes, but I don't understand why it is working ....

Cisco Employee

Re: 4507 Config - channel-groups

Hi Thom,

Can you please confirm if the 2 ports on the switch are in same vlan or different vlan?

Can you post the config for both the ports and also configs for port-channel interfaces?

Regards,

Ankur

New Member

Re: 4507 Config - channel-groups

Here are the port configs:

interface GigabitEthernet3/32

switchport access vlan 2

switchport mode access

spanning-tree portfast

channel-group 3 mode on

end

interface GigabitEthernet3/34

switchport access vlan 2

switchport mode access

spanning-tree portfast

channel-group 4 mode on

end

... and the port-channels:

interface Port-channel3

switchport

switchport access vlan 2

switchport mode access

end

interface Port-channel4

switchport

switchport access vlan 2

switchport mode access

end

Thanks,

Thom

420
Views
0
Helpful
4
Replies
CreatePlease to create content