Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

6500 Boot query..

Hi i am trying to configure the boot variable as below in 6506 switch having to sup720

boot system disk0:s72033-advipservicesk9_wan-mz.122-18.SXF17.bin
boot system slavedisk0:s72033-advipservicesk9_wan-mz.122-18.SXF17.bin

when giving the 2nd command "boot system slavedisk0:s72033-advipservicesk9_wan-mz.122-18.SXF17.bin" I see
error message saying

00:23:33: %PFREDUN-SP-4-BOOTSTRING_INVALID: The bootfile slaveslavedisk0:s72033-
advipservicesk9_wan-mz.122-18.SXF17.bin is not present in standby

why the filename showing wrong in error message...
can't we set boot system from slavedisk0: ?


Router#dir slavedisk0:
Directory of slavedisk0:/

    1  -rw-    80940580  May 25 2010 08:33:12 +00:00  s72033-advipservicesk9_wan-mz.122-18.SXF17.bin

127893504 bytes total (46952448 bytes free)
Router#

everytime i reload the switch, active sup changes from slot 5 to slot6 and vice versa. is it normal behavior?

regards
Amar

5 REPLIES

Re: 6500 Boot query..

Hi there!

You have HA configured there?

I have searched for your error:

%PFREDUN-4-BOOTSTRING_INVALID: The bootfile [chars] is not present in standby This message indicates that the bootfile that is configured is not  present on the redundant supervisor engine. If the redundant supervisor  engine resets, it will not come up because it will not find the image  specified  in the bootstring.

Recommended Action: No action is required.

Related documents- No specific documents apply to this  error message.

Actually this doesn't give us too much new information

Then from:

http://www.ciscosysteme.org/en/US/prod/collateral/switches/ps5718/ps708/prod_white_paper09186a0080088874.html

Dual supervisor engines provide hardware  redundancy for the forwarding intelligence of the Cisco Catalyst 6500  Series. The Cisco Catalyst 6500 Series can support up to two supervisor  engines (slots 1 and 2 for the Supervisor Engine 1A and Supervisor  Engine 2; and slots 1 and 2 in the Cisco Catalyst 6503 and 6504 chassis,  slots 5 and 6 in the Cisco Catalyst 6506 and 6509 chassis, and slot 7  and 8 in the Cisco Catalyst 6513 chassis for the Supervisor Engine 32  and Supervisor Engine 720) with one being the running, or active,  supervisor engine and the other being the standby supervisor engine. The  active supervisor engine is the first one to go online. This can be  confirmed by the "Active" LED on the supervisor or by typing the show  module command from the console.

Maybe this is the reason why your SUP are swinging over all the time.

You have exact the same config on both SUPs?

I have here a C6506 and I have tested:

R8-C6506(config)#do sh run | i boot
boot-start-marker
boot system disk0:s72033-adventerprisek9_wan-mz.122-33.SXH3.bin
boot-end-marker

Applied the command:

boot system slavedisk0:s72033-adventerprisek9_wan-mz.122-33.SXH3.bin

R8-C6506(config)#do sh run | i boot                                       
boot-start-marker
boot system disk0:s72033-adventerprisek9_wan-mz.122-33.SXH3.bin
boot system slavedisk0:s72033-adventerprisek9_wan-mz.122-33.SXH3.bin
boot-end-marker

Searching some more I found this bug in your IOS version:

CSCsc96868 -http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsc96868&from=summary

Need CCO account to visit the link above

Symptom:
With the internal boot disk adapter present in  the SP slot, both of the sup-bootflash: and slavesup-bootflash: entries  are missing on standby RP.
Conditions:
Supervisor  with internal boot disk adapter.

Workaround:
Use  sup-bootdisk instead of sup-bootflash

It's not exactly your issue, but I've tried:

boot system slave-sup:disk0:s72033-adventerprisek9_wan-mz.122-33.SXH3.bin

I hope one of this advices will help. Take care if your device is in productive environment and especially if it's remote. You don't want to be stuck with a  not-booting device. Mine is in the test lab, that's why I could test all commands.

If helps, please rate!

Calin

Re: 6500 Boot query..

Amar,

disk0 and disk1 are slots on the sup 720 engine for compactflash type 11 cards and the reason why you are seeing the error is compactflash might not be present in that slot on the card.

Francisco.

New Member

Re: 6500 Boot query..

Hi guys,

Thanks guys for support but still not clear why the error is comming...

I have the compact disk in both(active and standby sup) disk0:

also both sup boots correctely when i try to boot sepretely with there disk0:

since it was not in production hence tried all the options and now somwhat comfortable with boot process in 65xx.. ;-)

I had added the "boot system slavdisk0:" because i thought if master sup fails to boot from disk0: then it will boot from slavedisk0:

when i issue command it accept but when i save then only error comes it means the error is comming after the config sync.

Regards

Amar

New Member

Re: 6500 Boot query..

Hi,

what is type 11 cards

Regards

amar

Cisco Employee

6500 Boot query..

Hi Amar


I want you to paste the outputs of the following to narrow down the issue:


1. Show run

2. Show boot

3. Dir all-filesystems

4. Show module


Thanks

Prabhdeep Nijjar

1306
Views
4
Helpful
5
Replies