Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

6500 police/rate-limit egress

I am trying to do an egress rate-limit on a 6500 Sup720/PFC3B 10/100 port. Everything I read seems to say it supports egress rate-limiting, but it will never let me bind a policy-map "output" on my interface. I am trying to rate-limit a 100Mbps interface to 10mbps/10Mbps. This is what I have so far. My ingress rate-limit seems to be working just fine. Any help would be greatly appreciated! Much Thanks....ahead of time.

access-list 100 remark QOS ACL For Rate-limiting Traffic

access-list 100 permit ip any any

class-map match-any limit_10Mb

description Rate-Limit 10Mb Ingress

match access-group 100

policy-map 10Mb_ingress

description Police 10Mbps Ingress

class limit_10Mb

police cir 10485500 bc 327671 be 327671 conform-action transmit exceed-action drop violate-action drop

interface FastEthernet4/29

switchport

switchport access vlan 136

switchport mode dot1q-tunnel

switchport nonegotiate

mtu 9216

no ip address

load-interval 30

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

service-policy input 10Mb_ingress

4 REPLIES

Re: 6500 police/rate-limit egress

Use.

Generic Traffic Shaping or Rate-limit (CAR)on the interface.

Best would be Generic Traffic Shaping.

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfgts.html

CAR

http://www.cisco.com/en/US/docs/ios/11_1/feature/guide/CAR.html

Regards,

Pravin

New Member

Re: 6500 police/rate-limit egress

I apprecaite your help, but both GTS and CAR in the two links you sent me are for a layer3 interface.

I need to do egress rate limiting on a layer2 interface. Both the "rate-limit" and "traffic-shaping" commands are only allowed on a layer3 interface.

Do you happen to know somthing for layer2?

Thanks!

Re: 6500 police/rate-limit egress

Hi,

Sorry.

On layer 2 you can implement srr-queue

Its works a bit different:

Switch(config-if)# srr-queue bandwidth ?

limit -Configure bandwidth-limit for this interface

shape -Configure shaping on transmit queues

share -Configure shared bandwidth

below is the link for cisco 2690 switch.

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_44_se/configuration/guide/swqos.html#wp1163879

regards,

Pravin

New Member

Re: 6500 police/rate-limit egress

Pravin,

I actually use the "srr-queue bandwidth" command currently on some of my 3560G switch's and it works fine, but my 6500's seem to only support Weighted Round-Robin queuing?

I an running ver 12.2(18)SXF8 on Sup720-3B's?

Do you know if I can do anything with egress rate-limiting and the "wrr-queue bandwidth" command, because it won't let me set a limit and seems to only let me specify a weight to queue ratio.

Thanks for your help!

4263
Views
0
Helpful
4
Replies