Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

6500 QoS COS Egress Not Marked

Problem: My traffic coming inbound appears to be marked but is not marked when egressing.


Setup:

  • Ingress from encoder G3/9->> Egress G8/1
  • Default DSCP/COS map table (DSCP 24 is COS3)

   Cos-dscp map:

         cos:   0  1  2  3  4  5  6  7

     ------------------------------------

        dscp:   0  8 16 24 32 40 48 56


1. Any reason COS 3 is not marked outbound on this traffic? I'm determining this by doing a wireshark off of interface g8/1. The traffic appears to be marked on the ingress correctly but does not maintain its mark on the egress. I can confirm this with equipment on other Ethernet links in produciton as well as my test port listed in the config below with wireshark.

FYI: Unfortunately with my cards in the 6509 I cannot port mirror and see outbound multicast (determined through a TAC case). Because the STB does not understand tagged traffic I setup the native vlan for it to function. To see the multicast with tags I temporarily remove the native command and do the wireshark to see the multicast. It still shows a COS setting of 0. I will try to attach a capture of a multicast packet.

interface GigabitEthernet3/9

description Mulicast Encoder

switchport

switchport access vlan 962

switchport mode access

logging event link-status

load-interval 30

service-policy input MARK_IP_PREC_3

!

PhatCat#sho policy-map int g3/9

GigabitEthernet3/9

Service-policy input: MARK_IP_PREC_3


    class-map: ALL_TRAFFIC (match-all)

      Match: access-group 47

      set dscp 24:

      Earl in slot 6 :

3268388676 bytes

30 second offered rate 4074264 bps

aggregate-forwarded 3268388676 bytes


    Class-map: class-default (match-any)

      0 packets, 0 bytes

      30 second offered rate 0000 bps, drop rate 0000 bps

      Match: any

        0 packets, 0 bytes

        30 second rate 0 bps

2. I've continued to try and mark on the egress but have problems with the configuration. I'm ingressing on g3/9 and egressing on 8/1 for my test.

Egress Attempt 1:

PhatCat(config)#int g8/1

PhatCat(config-if)#service-policy output MARK_OUTBOUND_VIDEO

MQC features are not supported in output direction for this interface

Egress Attempt 2:

PhatCat(config)#int vlan 781

PhatCat(config-if)#service-policy output MARK_OUTBOUND_VIDEO

set cos cannot be configured on output direction for this interface

Configuration failed!

%'set cos cos-inner' for 'class OUT_VIDEO' on Vlan781 is not supported

('set cos cos-inner' is only supported on a class with 'match vlan' or on 'class class-default')


Configuration:

interface GigabitEthernet8/1

description STB-NET8-TEST

switchport

switchport access vlan 781

switchport trunk encapsulation dot1q

switchport trunk native vlan 781

switchport trunk allowed vlan 781

switchport mode trunk

logging event link-status

load-interval 30

no cdp enable

end

interface Vlan781

description NET8

ip address 10.239.56.1 255.255.248.0

ip helper-address 10.100.141.40

ip pim dense-mode

end


Everyone's tags (6)
2 REPLIES
New Member

6500 QoS COS Egress Not Marked

Try this

no mls qos rewrite ip dscp


6500 QoS COS Egress Not Marked

Hi,

Check the class-map OUT_VIDEO that has unsupported action. remove and reapply policy and it should accept it.

set cos cannot be configured on output direction for this interface

Configuration failed!

%'set cos cos-inner' for 'class OUT_VIDEO' on Vlan781 is not supported

1227
Views
0
Helpful
2
Replies
CreatePlease login to create content