Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

6500 Sup 720 in rommon

I have read many threads on this subject, and have not been able to get any of them to work...

My problem started by saving a config file onto the 6500, and subsequently when the 6500 is booted, it comes back with the error about the first file on the flash is not an IOS image as I had not configured boot system sup-bootflash:<filename> when the 6500 was up.

I have been trying to follow the published recovery procedure, to no avail: i.e. put a disk in the supy with the IOS on and do boot disk0:<filename>. In SP rommon, a dir disk0: comes back with "device does not contain a valid magic number", even though this came from another 6500 that has booted off of the disk.

What I can see is in SP rommon, dir bootflash: shows a valid image, for which I can boot from SP rommon to RP rommon.

At RP rommon, if I try to dir any of the file systems shown by the dev command, no files are found. If I try boot sup-bootflash:<filename>, the RP boot just crashes, although at this point I can then dir bootflash: and see an image, but I suspect at this time it has gone back to SP rommon, and that is why I see a file.

The fact SP rommon boots from the bootflash:<filename> image must mean that the image is not corrupt, so I would have thought there should be a way of getting the RP to boot from it (hence trying boot sup-bootflash:<filename>).

Any ideas greatly appreciated, as this is due to go live on Wednesday...!

4 REPLIES
New Member

Re: 6500 Sup 720 in rommon

Although the situation has improved, I'm not quite there yet:

I had the flashdisk taken to another site, where on insertion, messages about the format came up (this was a new flashdisk out of a box). I have now formatted it in another 6500, copied the IOS on and had it taken back to the broken 6500.

At SP rommon, a dir disk0: now returns the IOS filename.

If I boot disk0:, then the SP boots from the disk, however the RP still does not boot, and shows the message boot: cannot determine the first file name on device "bootflash:". The recovery procedure for a sup 720 says that the boot disk0: at SP rommon should make the SP and RP both boot.

New Member

Re: 6500 Sup 720 in rommon

I also tried the xmodem download of a boot image straight into the RP, as per the recovery procedure.

Still no joy.

I eventually got a hardware support call out for it, and the engineer replaced the Sup720 saying "the software on the card is corrupt".

New Member

Re: 6500 Sup 720 in rommon

Hi Foster,

A few basic steps which you can try is to verify the disk using the 'verify' command and if possible do update the IOS version you are using.

Try to reseat the flash card in the slot once again properly and let us know what happens.

Regards,

podhillo.

New Member

Re: 6500 Sup 720 in rommon

Thanks, but as I put in the previous post, the sup720 has now been changed out and it is working.

I just put an update on in case anyone came looking for a fix to their problem, but could not see how you are supposed to "close" a thread on the forum.

2873
Views
0
Helpful
4
Replies