Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

6500 VSS policy-maps and classification

Hello group,

Another QoS related question, this time it deals with a 6500 running VSS with IOS 12.2(33)SXI3. I have a policy map that is applied to a physical interface that is looking for UDP video traffic and marking it as AF41. After applying the service-policy to the physical interface I look at the policy-map and I see matches on the interface like it is marking, but a sniff tells me otherwise. This is the almost the exact opposite of the 3750 problem that I was seeing in this bug report: http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCec08205

I have been doing some reading and I know that VSS does QoS differently across the VSL (i.e. COS only, unchangeable COS to DSCP mappings) but does that matter on physical ethernet ports for servers and uplinks to other switches?

Below is the config from the VSS switch. For the record I have tried QoS on the VLAN as well and no such luck.

ip access-list extended SXDMSWMS1-Multicast
permit udp host 10.255.2.228 any eq 25385
permit udp host 10.255.2.228 any eq 30657
ip access-list extended SXDMSWMS2-Multicast
permit udp host 10.255.2.200 any eq 25385
permit udp host 10.255.2.200 any eq 30657

!

class-map match-any SXDMSWMS-Multicast-cmap
  match access-group name SXDMSWMS1-Multicast
  match access-group name SXDMSWMS2-Multicast

policy-map QoS-Policy-Cisco-DMS
  class SXDMSWMS-Multicast-cmap
   set dscp af41

!

interface GigabitEthernet1/1/31
description SXDMSWMS2
switchport
switchport access vlan 3098
switchport mode access
mls qos trust dscp
spanning-tree portfast edge
service-policy input QoS-Policy-Cisco-DMS

Hopefully someone can tell me where I'm going wrong.

Thank you,

AJ Schroeder

5 REPLIES
New Member

Re: 6500 VSS policy-maps and classification

mls qos trust dscp

I don't think you are allow to do this and manually rewrite QoS values. It's either or.

-Ben

New Member

Re: 6500 VSS policy-maps and classification

I thought I read that at some point, but I was under the impression that it only applied to PFC2 and below.

I will try your suggestion and get back to you.

Thank you,

AJ

New Member

Re: 6500 VSS policy-maps and classification

Removing the "mls qos trust dscp" command did not seem to resolve the issue. FYI.

I'm at a loss, I am following these directions http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a008014a29f.shtml#config_service and traffic is not being marked.

New Member

Re: 6500 VSS policy-maps and classification

Just to double check make sure you try removing and adding the policy back once "mls qos trust dscp" was removed. They might have gotten into an argument with each other as the "trust" command sets a bit in our internal header that precludes remarking policies.

If your packet captures show that the traffic is *still* not being marked then I think you need to open a case with the TAC to look into this as the next step would be along the lines of ELAM and other things that are not documented externally.

-Ben

New Member

Re: 6500 VSS policy-maps and classification

Does the command "mls qos 10g-only" command have anything to with the VSS not marking traffic on a non 10GE port? I have noticed this command in the global configuration on the switch, would that be ignoring the marking?

AJ

666
Views
0
Helpful
5
Replies