Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

6506 line card failure?

Have a 6506 running IOS Version 12.2(18)SXF8 connected to a 3750 running IOS Version 12.2(25)SEE3 via fiber. The setting for the interface on 6506 is interface GigabitEthernet1/3

switchport

switchport access vlan 123

switchport mode access

switchport nonegotiate

no ip address

speed nonegotiate

The setting for the interface on the 3750 is

interface GigabitEthernet1/0/25

switchport access vlan 123

switchport mode access

switchport nonegotiate

spanning-tree portfast

Currently the 3750 has a link light and shows port 25 connected (Note swithcport is turned on but it doesn't show when doing a sho run). The 6506 has no link light and shows port 3 not connected. Every once in a while the 3750 will put the port in err-disable. I tried setting both to speed nonegotiate and to no speed nonegotiate. Either of those give me no link lights on either machine. Ran a diagnostic and the line card passed. Never seen that speed nonegotiate option before so I don't know I may be using it wrong. Anyone have any tips on what the next troubleshooting step should be?

10 REPLIES
Hall of Fame Super Bronze

Re: 6506 line card failure?

Based on the configuration provided, you have a speed/duplex mismatch.

The 6500 has autonegotiation disabled and the 3750 has it enabled.

I suggest you leave the port on the 6500 as is, and configure speed 1000 / full duplex on the 3750.

Do a shut and no shut on the respective interfaces and post back with results.

HTH,

__

Edison.

New Member

Re: 6506 line card failure?

Do you know what exactly is causing the port to err-disable?? You should be able to see it in the log, or run "show int status err-disable"

New Member

Re: 6506 line card failure?

spanning-tree portfast is a realy bad idea on the link between switches. =)

New Member

Re: 6506 line card failure?

Will try messing with these options today, I thought I had done this but I've been configuring so much equipment in the past few days I may not have, don't remember. Could you please elaborate on why spanning-tree portfast on these interfaces is a bad idea? Will post this afternoon on any results. Thanks!

New Member

Re: 6506 line card failure?

Portfast is a feature configured on links to end-users, merely interface with portfast transits almost immediately to forwarding state. BPDUs never expected on this port. It will cause bridging loops and spanning tree instability if this link attached to the device which actively participate in spanning tree topology (bridge/switch). Depending on the global options configured on the switch (BPDU guard) when interface with portfast enabled recieves BPDU it will be transited into error disable state.

New Member

Re: 6506 line card failure?

I guess I should have mention that there is no dual connectivity anywhere in the network. There are no redundant connections, everything is 1-to-1 so I didn't think that would need spanning-tree bpduguard but I'll try enabling that, and also disabling spanning-tree portfast to see if either help. Thanks to all for your help in this matter.

New Member

Re: 6506 line card failure?

Well there's no dual connectivity anywhere in this particular network, no redundant connections anywhere. Turned off portfast anyway on the interface on the 3750 and still get the same result. Green link light and a sho int status of connected on the 3750 end and no link light what-so-ever and a sho int status of notconnected on the 6506 end.

New Member

Re: 6506 line card failure?

If port is up on the one end and down on the other then it's a problem with the fiber, 3750 sees the light from the 6506 but not the other way around.

New Member

Re: 6506 line card failure?

Loop can be easily introduced even if not intended by administrator by simply adding multihomed host with bridging enabled for example. Here is the article about BPDU Guard

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a008009482f.shtml

New Member

Re: 6506 line card failure?

The 3750's interface is a gig fiber connection, so speed and duplex are 1000 and full. No options for otherwise. Haven't gotten anymore err-disables though so that's good.

184
Views
0
Helpful
10
Replies
CreatePlease login to create content