Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

6509 NAT on ip outside VLAN

G'morning,

I have a 6509 running version 12.2(33)SXI3 on a Sup 720-3B in native mode.  I have 2 VLAN's configured for NAT,  one "inside" and one "outside".  The inside vlan is also handing out DHCP.  The config is pretty basic and the dhcp is working fine.  Doing a traceroute from the client shows that the packets are headed out the gateway vlan, however, the NAT is doing nothing.

DC2-Core-B#sh ip nat trans

DC2-Core-B#sh ip nat stat

Total active translations: 0 (0 static, 0 dynamic; 0 extended)

Outside interfaces:

  Vlan201

Inside interfaces:

  Vlan200

Hits: 2  Misses: 0

CEF Translated packets: 0, CEF Punted packets: 1418

Expired translations: 1

Dynamic mappings:

-- Inside Source

[Id: 2] access-list 110 interface Vlan201 refcount 0

Here are the related snippets from my config.  Am I missing something here?  All of my googlinig seems to indicate that this should work however most "sample" configs are using a physical interface as the "outside".

!

no ip dhcp conflict logging

ip dhcp excluded-address 10.10.145.1 10.10.145.149

ip dhcp excluded-address 10.10.145.251 10.10.145.254

!

ip dhcp pool OneMedia_Private

   network 10.10.145.0 255.255.255.0

   default-router 10.10.145.254

    dns-server 66.xx.xx.xx 66.yy.yy.yy

    lease 0 0 1

!

!

access-list 110 permit ip 10.10.145.0 0.0.0.255 any log

access-list 110 deny   ip any any log

!

!

!

interface Vlan200

ip address 10.10.145.254 255.255.255.0

ip nat inside

!

interface Vlan201

description OneMedia Public

ip address 199.xx.xx.xx 255.255.255.248

ip nat outside

!

ip nat inside source list 110 interface Vlan201 overload

!

!

Thanks for any help getting this resolved.

Everyone's tags (5)
390
Views
0
Helpful
0
Replies