Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

6509 - SSO Redundancy Configuration is not working

Hi experts! I am configuring SSO Redundancy in a Cisco WS-C6509-NEB-A (Version 12.2(17r)S4). I have 2 Supervisor Engine 720 in modules 5 and 6.

SW#show module

Mod Ports Card Type Model Serial No.

--- ----- -------------------------------------- ------------------ -----------

1 16 SFM-capable 16 port 1000mb GBIC WS-X6516A-GBIC SAL1227W6BM

2 16 SFM-capable 16 port 1000mb GBIC WS-X6516A-GBIC SAL1231Z5LB

5 2 Supervisor Engine 720 (Cold) WS-SUP720-3B SAL1225UTBU

6 2 Supervisor Engine 720 (Active) WS-SUP720-3B SAL1224TWT2

8 48 48-port 10/100/1000 RJ45 EtherModule WS-X6148A-GE-TX SAL1232ZGD2

9 48 48-port 10/100/1000 RJ45 EtherModule WS-X6148A-GE-TX SAL1232ZYL2

Mod Sub-Module Model Serial Hw Status

---- --------------------------- ------------------ ----------- ------- -------

5 Policy Feature Card 3 WS-F6K-PFC3B SAL1225UDJ0 2.3 Ok

5 MSFC3 Daughterboard WS-SUP720 SAL1225UDVN 3.1 Ok

6 Policy Feature Card 3 WS-F6K-PFC3B SAL1224U23F 2.3 Ok

6 MSFC3 Daughterboard WS-SUP720 SAL1224U52H 3.1 Ok

I already configured the following commands:

SW#configure terminal

SW(config)#redundancy

SW(config-red)#mode sso

Changing to sso mode will reset the standby. Do you want to continue? [confirm]

Then I get the following messages:

Nov 24 16:41:11 ECU: %OIR-SP-3-PWRCYCLE: Card in module 5, is being power-cycled (RF request)

Nov 24 16:41:12 ECU: %SYS-5-CONFIG_I: Configured from console by nokia on console

Nov 24 16:41:12 ECU: %PFREDUN-SP-6-ACTIVE: Standby supervisor removed or reloaded, changing to Simplex mode

And the output of the "show redundancy" is:

Hardware Mode = Simplex

Configured Redundancy Mode = sso

Operating Redundancy Mode = sso

Maintenance Mode = Disabled

Communications = Down Reason: Simplex mode

But after a few minutes, I have:

Nov 24 16:43:26 ECU: %PFREDUN-SP-4-VERSION_MISMATCH: Defaulting to RPR mode (Different software versions)

Nov 24 16:43:27 ECU: %PFREDUN-SP-6-ACTIVE: Standby initializing for RPR mode

Nov 24 16:43:27 ECU: %SYS-SP-3-LOGGER_FLUSHED: System was paused for 00:00:00 to ensure console debugging output.

Nov 24 16:43:28 ECU: %PFINIT-SP-5-CONFIG_SYNC: Sync'ing the startup configuration to the standby Router.

Nov 24 16:43:32 ECU: %FABRIC-SP-5-CLEAR_BLOCK: Clear block option is off for the fabric in slot 5.

Nov 24 16:43:32 ECU: %FABRIC-SP-5-FABRIC_MODULE_BACKUP: The Switch Fabric Module in slot 5 became standby

Nov 24 16:43:33 ECU: %DIAG-SP-6-RUN_MINIMUM: Module 5: Running Minimal Diagnostics...

Nov 24 16:43:33 ECU: %DIAG-SP-6-DIAG_OK: Module 5: Passed Online Diagnostics

Nov 24 16:43:34 ECU: %MLS_RATE-4-DISABLING: The global switching mode is now 'truncated'. Disabling the Layer2 Rate Limiters.

Nov 24 16:43:34 ECU: %OIR-SP-6-INSCARD: Card inserted in slot 5, interfaces are now online

And the output of the "show redundancy" is:

Hardware Mode = Duplex

Configured Redundancy Mode = sso

Operating Redundancy Mode = rpr

Maintenance Mode = Disabled

Communications = Up

I Think that the righ status of SSO Configuration must be like:

Hardware Mode = Duplex

Configured Redundancy Mode = SSO

Operating Redundancy Mode = SSO

Maintenance Mode = Disabled

Communications = Up

Did any one face this problem before? Please your help! Thanks!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Re: 6509 - SSO Redundancy Configuration is not working

Carlos

Check the output of "sh module" ie.

5 001c.5869.9db0 to 001c.5869.9db3 5.6 8.5(2) 12.2(33)SXH3 Ok

6 0016.c848.57bc to 0016.c848.57bf 5.6 8.5(2) 12.2(33)SXH2 Ok

different software versions.

Jon

Re: 6509 - SSO Redundancy Configuration is not working

1) I would go with the newer one if possible.

2) you will want to copy the file over to the second supervisor. then reload the supervisor. Please see the following reference guide.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a00807714cb.shtml#native

If you have any questions feel free to ask.

Mark

13 REPLIES
Hall of Fame Super Blue

Re: 6509 - SSO Redundancy Configuration is not working

Can you post the full output from "sh module"

Jon

Community Member

Re: 6509 - SSO Redundancy Configuration is not working

Hi Jone, thanks for your answer. I already put the "show module" output. But now I am putting complete =D

SWP#show module

Mod Ports Card Type Model Serial No.

--- ----- -------------------------------------- ------------------ -----------

1 16 SFM-capable 16 port 1000mb GBIC WS-X6516A-GBIC SAL1227W6BM

2 16 SFM-capable 16 port 1000mb GBIC WS-X6516A-GBIC SAL1231Z5LB

5 2 Supervisor Engine 720 (Cold) WS-SUP720-3B SAL1225UTBU

6 2 Supervisor Engine 720 (Active) WS-SUP720-3B SAL1224TWT2

8 48 48-port 10/100/1000 RJ45 EtherModule WS-X6148A-GE-TX SAL1232ZGD2

9 48 48-port 10/100/1000 RJ45 EtherModule WS-X6148A-GE-TX SAL1232ZYL2

Mod MAC addresses Hw Fw Sw Status

--- ---------------------------------- ------ ------------ ------------ -------

1 0022.554d.2180 to 0022.554d.218f 4.6 7.2(1) 8.7(0.22)H2A Ok

2 0022.9010.8a18 to 0022.9010.8a27 4.6 7.2(1) 8.7(0.22)H2A Ok

5 001c.5869.9db0 to 001c.5869.9db3 5.6 8.5(2) 12.2(33)SXH3 Ok

6 0016.c848.57bc to 0016.c848.57bf 5.6 8.5(2) 12.2(33)SXH2 Ok

8 0022.9046.e290 to 0022.9046.e2bf 1.6 8.4(1) 8.7(0.22)H2A Ok

9 0022.9013.b6b0 to 0022.9013.b6df 1.6 8.4(1) 8.7(0.22)H2A Ok

Mod Sub-Module Model Serial Hw Status

---- --------------------------- ------------------ ----------- ------- -------

5 Policy Feature Card 3 WS-F6K-PFC3B SAL1225UDJ0 2.3 Ok

5 MSFC3 Daughterboard WS-SUP720 SAL1225UDVN 3.1 Ok

6 Policy Feature Card 3 WS-F6K-PFC3B SAL1224U23F 2.3 Ok

6 MSFC3 Daughterboard WS-SUP720 SAL1224U52H 3.1 Ok

Mod Online Diag Status

---- -------------------

1 Pass

2 Pass

5 Pass

6 Pass

8 Pass

9 Pass

Hall of Fame Super Blue

Re: 6509 - SSO Redundancy Configuration is not working

Carlos

Check the output of "sh module" ie.

5 001c.5869.9db0 to 001c.5869.9db3 5.6 8.5(2) 12.2(33)SXH3 Ok

6 0016.c848.57bc to 0016.c848.57bf 5.6 8.5(2) 12.2(33)SXH2 Ok

different software versions.

Jon

Community Member

Re: 6509 - SSO Redundancy Configuration is not working

Thank you very much Jon.

Thank you very much Mark. 2 questions:

1.- What is the recommended version? 12.2(33)SXH3 or 12.2(33)SXH2?

2.- Do you have the right process to upgrade the IOS in the supervisor?

thanks again!

Re: 6509 - SSO Redundancy Configuration is not working

Carlos,

It appears that you are running different software versions on your supervisors. A requirement to use SSO is to have the same IOS image running on both supervisors. I would recommend upgrading/downgrading one of them so they match.

Nov 24 16:43:26 ECU: %PFREDUN-SP-4-VERSION_MISMATCH: Defaulting to RPR mode (Different software versions)

HTH,

Mark

Community Member

Re: 6509 - SSO Redundancy Configuration is not working

Hi Mark. Thanks for your answer. I checked the versions and they are the same, I am sure of that. I have some doubts:

1.- Do i need to put the same configuration ("mode sso" command) in the standby Supervisor?

2.- How can I access to the standby slot?

I think this is a configuration problem.

Re: 6509 - SSO Redundancy Configuration is not working

Carlos,

Your configuration is fine. The output above from the show module does confirm you have an IOS mismatch.

5 001c.5869.9db0 to 001c.5869.9db3 5.6 8.5(2) 12.2(33)SXH3 Ok

6 0016.c848.57bc to 0016.c848.57bf 5.6 8.5(2) 12.2(33)SXH2 Ok

HTH,

Mark

Community Member

Re: 6509 - SSO Redundancy Configuration is not working

Thank you very much Mark. 2 questions more:

1.- What is the recommended version? 12.2(33)SXH3 or 12.2(33)SXH2?

2.- Do you have the right process to upgrade the IOS in the supervisor?

I really appreciate what your quick and correct answers!

Re: 6509 - SSO Redundancy Configuration is not working

1) I would go with the newer one if possible.

2) you will want to copy the file over to the second supervisor. then reload the supervisor. Please see the following reference guide.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a00807714cb.shtml#native

If you have any questions feel free to ask.

Mark

Community Member

Re: 6509 - SSO Redundancy Configuration is not working

Hi Mark, I tried to follow the process but when i reset the Slot-6 (standby supervisor), it goes to "rommon". So far, I can not upgrade the IOS of the standby supervisor. Please your help!

Re: 6509 - SSO Redundancy Configuration is not working

Are you able to console into the supervisor in rommon? What happens when you type "boot" command in rommon?

Mark

Community Member

Re: 6509 - SSO Redundancy Configuration is not working

Hi Mark, i already solved the problem, but I have to do some changes regarding to the document that you sent me. When I upgradedthe IOS images in both supervisor engines, I could configure SSO in the switch. Thank you very much for your support Mark!!!

Re: 6509 - SSO Redundancy Configuration is not working

Carlos,

I am glad your issue has been resolved.

Good Luck!

Mark

4643
Views
0
Helpful
13
Replies
CreatePlease to create content