Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

7912 to pc - no ip at pc

Guys,

I have my 7912 phone connected to the CME and it gets IP I can make calls, etc. I now wish to connect the phone to the PC but I can't seem to get an IP. Can someone see what I'm doing wrong here.

----- show int f0/1/1 switchp
Name: Fa0/1/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,20-22,100
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: 22
Appliance trust: none

----- Show Run

!

interface FastEthernet0/1/1
switchport access vlan 21
switchport mode trunk
switchport voice vlan 22
spanning-tree portfast

!

interface Vlan21
ip address 192.168.21.253 255.255.255.0
ip helper-address 192.168.20.8
h323-gateway voip bind srcaddr 192.168.21.253
!
interface Vlan22
ip address 192.168.22.253 255.255.255.0
ip helper-address 192.168.20.8
!

---- Show IP Int brief
Vlan21                     192.168.21.253  YES NVRAM  up                    up
Vlan22                     192.168.22.253  YES NVRAM  up                    up

All help appreciated.

Thanks

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: 7912 to pc - no ip at pc

Hi

Can you configure the switch port mode as access instead of trunk?

regds

3 REPLIES

Re: 7912 to pc - no ip at pc

Hi

Can you configure the switch port mode as access instead of trunk?

regds

New Member

Re: 7912 to pc - no ip at pc

!

interface FastEthernet0/1/1
  switchport access vlan 21
  switchport mode trunk
  switchport voice vlan 22

spanning-tree portfast

!

If I take out the trunk and have only

!

interface FastEthernet0/1/1
  switchport access vlan 21
  switchport voice vlan 22

spanning-tree portfast

!

The phone neither the computer gets an IP. The phone gets an IP if we have

!

interface FastEthernet0/1/1

switchport access vlan 22

spanning-tree portfast

!

This also allows the computer to get an IP but the computer IP is within the voice subnet IP and I don't want this. Do I have to do any configuration on the phone to ensure it allows the computer on its eithernet port as in assign the switch's PC port to the VLAN I wish the computer to be in?

Thanks for your assistance

New Member

Re: 7912 to pc - no ip at pc

OK. I moved the configuration to the actual switch which I will be connected to and it is working the way it should. You were correct, there was no need for the port to the phone to be a trunk.

Thanks for the assistance

!

interface FastEthernet0/21
switchport access vlan 21
switchport voice vlan 22
no logging event link-status
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust cos
no snmp trap link-status
auto qos voip trust
spanning-tree portfast
!

467
Views
0
Helpful
3
Replies
CreatePlease to create content