Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

802.1x debug not working

I'm trying to get 802.1x on a Cat6509-E to work with Microsoft IAS. I'm still working through the details, however when I issue 'debug dot1x all' and then issue a 'term mon' command, I never see any dot1x debug information.

DET1TR1E#sh deb

dot1x:

Dot1x registry info debugging is on

Dot1x redundancy info debugging is on

Dot1x packet info debugging is on

Dot1x events debugging is on

Dot1x State machine transitions and actions debugging is on

Dot1x Errors debugging is on

Here is the global dot1x config:

aaa authentication dot1x default group radius

aaa authorization network default group radius

dot1x system-auth-control

dot1x guest-vlan supplicant

here is the interface dot1x config:

dot1x pae authenticator

dot1x port-control auto

dot1x guest-vlan 900

dot1x auth-fail vlan 900

This used to work at one time. I have no idea why it doesn't show any transactions in the terminal window.

Any help is appreciated.

Shane

2 REPLIES

Re: 802.1x debug not working

Hi Shane.

I just thought I would check that debugging messages are allowed to be sent to the console? A 'show logging' will show whether debugs are allowed to the console or not.

A lot of the time engineers turn off console logging and log to buffer in order to lower the impact of debugging. Most of the time they forget to turn it back on afterwards!

Just wanted to check this wasn't the case.

Simon

New Member

Re: 802.1x debug not working

Hi Simon - this doesn't seem to be the case. I am SSH'd to the switch and verified that logging monitor is set to informational. This should send debugging and informational messages to the monitor session (in my case vty3).

Thanks,

Shane

1610
Views
0
Helpful
2
Replies