Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

857 router config query

Hello,

I am trying to understand the config of a router which has all fastethernets set with no ip address, on vlan 1 it has an ip address of 10.1.1.254 and another on dialer1 which is set to pptp connection ( external ip address )

However there are 2 networks conected to the router and for network A the gateway is the ip 192.168.1.14  and on network B there  is a gateway with ip 10.1.1.254 which obviously are 2 different ports on this router.

My question is how are the ethernet ports working since they do not have an ip address set and are showing unassigned

Why gateway of last resort is 0.0.0.0 to network 0.0.0.0

ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.240 Vlan1 permanent

there is also a dhcp pool for the 10.1.1.x network

interface Vlan1
ip address 192.168.1.14 255.255.255.240 secondary
ip address 10.1.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452

Why does vlan 1 has 2 ip addresses ?

Thanks

14 REPLIES
Hall of Fame Super Blue

Re: 857 router config query

aconticisco wrote:

Hello,

I am trying to understand the config of a router which has all fastethernets set with no ip address, on vlan 1 it has an ip address of 10.1.1.254 and another on dialer1 which is set to pptp connection ( external ip address )

However there are 2 networks conected to the router and for network A the gateway is the ip 192.168.1.14  and on network B there  is a gateway with ip 10.1.1.254 which obviously are 2 different ports on this router.

My question is how are the ethernet ports working since they do not have an ip address set and are showing unassigned

Why gateway of last resort is 0.0.0.0 to network 0.0.0.0

ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.240 Vlan1 permanent

there is also a dhcp pool for the 10.1.1.x network

interface Vlan1
ip address 192.168.1.14 255.255.255.240 secondary
ip address 10.1.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452

Why does vlan 1 has 2 ip addresses ?

Thanks

vlan 1 has 2 ip addresses because you are running 2 subnets in the same vlan. The fast etherent ports have no ip addresses because these are all assigned into vlan 1 and then any device connected to one of the fast ethernet ports is in vlan 1 and can use either a 192.168.1.x/28 address or a 10.1.1.x/24 address.

Usually you won't do this, you would have 2 separate vlans but this has been configured as one vlan - 2 subnets.

You have a default-route pointing out of dialer0 interface so if this is connected to the internet then both 192.168.1.x/28 and 10.1.1.x/24 clients can get out to the internet.

Jon

New Member

Re: 857 router config query

Hi,

"Why gateway of last resort is 0.0.0.0 to network 0.0.0.0"

Its set because of your "ip route 0.0.0.0 0.0.0.0 Dialer1" Command. If this command is "ip route 0.0.0.0 0.0.0.0 'Next-Hop-IP'" then you would see,

"Gateway of last resort is 'Nex-Hop-IP' to network 0.0.0.0"

Thanks,

ThiyaguVG.

New Member

Re: 857 router config query

so If I want I could specify 10 more different networks for VLAN 1

interface Vlan1
ip address 192.168.1.14 255.255.255.240 secondary
ip address 10.1.1.254 255.255.255.0

xxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxx

and it would work with only 1 dhcp range active but I can connect to any port right ?

But the ideal is to create VLAN2, 3, 4 etc but to add another vlan is it correct like this...


config    vlan 2

            name Guests

How do I specify the 192. range for vlan 2 and is it correct to not specify an ip address for each port or is it better to assign each port with an ip address and vlan

Actually I do not need to 2 vlans to see eachother, I only need them to both access the gateway ( Internet )

Hall of Fame Super Blue

Re: 857 router config query

aconticisco wrote:

so If I want I could specify 10 more different networks for VLAN 1

interface Vlan1
ip address 192.168.1.14 255.255.255.240 secondary
ip address 10.1.1.254 255.255.255.0

xxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxx

and it would work with only 1 dhcp range active but I can connect to any port right ?

But the ideal is to create VLAN2, 3, 4 etc but to add another vlan is it correct like this...


config    vlan 2

            name Guests

How do I specify the 192. range for vlan 2 and is it correct to not specify an ip address for each port or is it better to assign each port with an ip address and vlan

Actually I do not need to 2 vlans to see eachother, I only need them to both access the gateway ( Internet )


After a quick look at the datasheet it seems that the 857 only supports one vlan so that is why you have 2 ip subnets assigned to the same vlan interface. For more than 1 vlan you would need a different router eg. the 870 series router with the right IOS.

Yes you could add more and subnets as secondary addresses but bear in mind the 857 is only really meant to be for 10 users so ahvign multiple networks routing off it would not make much sense.

You cannot assign the IP to the fast ethernet interfaces because they are only L2 ports ie. you cannot make them L3 ports and thet would need to be L3 ports to assign an IP address to.

Jon

New Member

Re: 857 router config query

Ok Jon so all the ports are like a switch, therefore thay cannot be assigned an IP address. As you are saying since it supports only 1 vlan it does not make sense to connect to multiple networks as all of them will be in 1 broadcast domain.

So Ideally when purchasing a cisco router it needs to have more than 1 port as layer 3 device so that an address is specifically assigned to it with its particular vlan set otherwise it needs to support more that 1 vlan. Are both situations identical as regards to performance ?

Thanks

Hall of Fame Super Blue

Re: 857 router config query

aconticisco wrote:

Ok Jon so all the ports are like a switch, therefore thay cannot be assigned an IP address. As you are saying since it supports only 1 vlan it does not make sense to connect to multiple networks as all of them will be in 1 broadcast domain.

So Ideally when purchasing a cisco router it needs to have more than 1 port as layer 3 device so that an address is specifically assigned to it with its particular vlan set otherwise it needs to support more that 1 vlan. Are both situations identical as regards to performance ?

Thanks

Yes, even though you use multiple subnets they are still in one broadcast domain and for this router which is designed for approx 10 users it doesn't really make sense to have multiple subnets.

As for which router to purchase it really depends on what you are trying to do. If you are really concerned with routing between vlans then a L3 switch is a better choice than a router. Switches however have limitations ie. most only take ethernet and your WAN connection may not be ethernet. Most don't support NAT and if you are connecting to the internet you will probably need that etc...

So you could look at some of the other 800 series routers which do support 802.1q. This would allow you to have multiple vlans although note you still can't apply an IP to the fast ethernet directly but you can assign them to different vlans.

Or you could look at some of the ISRG2 routers eg. 1900/2900/3900 which will accept switch modules that can be L3 ports.

It really depends on your requirements ie. number of users/throughput/features etc.

Jon

Hall of Fame Super Blue

Re: 857 router config query

aconticisco wrote:

Ok Jon so all the ports are like a switch, therefore thay cannot be assigned an IP address. As you are saying since it supports only 1 vlan it does not make sense to connect to multiple networks as all of them will be in 1 broadcast domain.

So Ideally when purchasing a cisco router it needs to have more than 1 port as layer 3 device so that an address is specifically assigned to it with its particular vlan set otherwise it needs to support more that 1 vlan. Are both situations identical as regards to performance ?

Thanks

Yes, even though you use multiple subnets they are still in one broadcast domain and for this router which is designed for approx 10 users it doesn't really make sense to have multiple subnets.

As for which router to purchase it really depends on what you are trying to do. If you are really concerned with routing between vlans then a L3 switch is a better choice than a router. Switches however have limitations ie. most only take ethernet and your WAN connection may not be ethernet. Most don't support NAT and if you are connecting to the internet you will probably need that etc...

So you could look at some of the other 800 series routers which do support 802.1q. This would allow you to have multiple vlans although note you still can't apply an IP to the fast ethernet directly but you can assign them to different vlans.

Or you could look at some of the ISRG2 routers eg. 1900/2900/3900 which will accept switch modules that can be L3 ports.

It really depends on your requirements ie. number of users/throughput/features etc.

Jon

Hall of Fame Super Blue

Re: 857 router config query

aconticisco wrote:

Ok Jon so all the ports are like a switch, therefore thay cannot be assigned an IP address. As you are saying since it supports only 1 vlan it does not make sense to connect to multiple networks as all of them will be in 1 broadcast domain.

So Ideally when purchasing a cisco router it needs to have more than 1 port as layer 3 device so that an address is specifically assigned to it with its particular vlan set otherwise it needs to support more that 1 vlan. Are both situations identical as regards to performance ?

Thanks

Yes, even though you use multiple subnets they are still in one broadcast domain and for this router which is designed for approx 10 users it doesn't really make sense to have multiple subnets.

As for which router to purchase it really depends on what you are trying to do. If you are really concerned with routing between vlans then a L3 switch is a better choice than a router. Switches however have limitations ie. most only take ethernet and your WAN connection may not be ethernet. Most don't support NAT and if you are connecting to the internet you will probably need that etc...

So you could look at some of the other 800 series routers which do support 802.1q. This would allow you to have multiple vlans although note you still can't apply an IP to the fast ethernet directly but you can assign them to different vlans.

Or you could look at some of the ISRG2 routers eg. 1900/2900/3900 which will accept switch modules that can be L3 ports.

It really depends on your requirements ie. number of users/throughput/features etc.

Jon

New Member

Re: 857 router config query

So at this point even a layer 2 switch connected to the same router is better that the current situation since at least I would segment both networks and divide the broadcast domain. in 2

Hall of Fame Super Blue

Re: 857 router config query

aconticisco wrote:

So at this point even a layer 2 switch connected to the same router is better that the current situation since at least I would segment both networks and divide the broadcast domain. in 2

No, because you still can't segregate the vlans at L3 on the router.

Jon

New Member

Re: 857 router config query

One question to ask is:  What is a secondary?  A secondary is just  that an additional IP address that can be assigned to an interface that  already has an IP address; a second IP address, this way you can on a  particular VLAN (vlan 1 in your case) have multiple subnets.  Not best  practice though.  so YES vlan 1 in your case is running 2 networks in  the same VLAN.  OH also all ports are members of VLAN 1 by default.   0.0.0.0 0.0.0.0 is also known as Default path, it is a catch all and  basically says "if the network is unknown for some destination then send  it to Dialer1.  I hope this helps, let me know if not.  Ted

Links:

New Member

Re: 857 router config query

Thank you for the information,

what I still cannot understand is why I would not be better when connecting a layer 2 switch then leaving things as they are.

Current situation is that I have both networks connected to 1 vlan ( vlan 1 )

If I connect a switch  (layer 2) to the router I can set 1 interface of the switch to accept layer 1 and the other to accept layer 2

There is no need for the 2 networks to speak to eachother, why is this not beter than of having a sigle broadcast domain ?

Thanks

New Member

Re: 857 router config query

Read the page below about Layer 2 and Layer 3 switches and I think your questions will be answered.  If not, let me know.

http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_1-2/switch_evolution.html

Hall of Fame Super Blue

Re: 857 router config query

aconticisco wrote:

Thank you for the information,

what I still cannot understand is why I would not be better when connecting a layer 2 switch then leaving things as they are.

Current situation is that I have both networks connected to 1 vlan ( vlan 1 )

If I connect a switch  (layer 2) to the router I can set 1 interface of the switch to accept layer 1 and the other to accept layer 2

There is no need for the 2 networks to speak to eachother, why is this not beter than of having a sigle broadcast domain ?

Thanks

The networks may not need to talk to each other but presumably they both need internet access ?? If so where are you going to route these networks because you can only have one vlan interface on your router. So only one vlan will be able to route to the internet.

You have a switch anyway on the router. You could just as easily assign some of those ports into a different vlan and then you have 2 vlans again but you still have the same problem ie. how would you route those 2 vlans anywhere ?, you can only route one of them.

Jon

637
Views
0
Helpful
14
Replies
CreatePlease to create content