Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

871 ISR

Hello,

I'm attempting to setup a 871 for internet.

I've managed to get the router configured with a private and public IP.

I can access the router through either IP.

Howeever when I'm connected to the private side. I can ping public IPs from the PC.

I'm tring to ping 8.8.8.8. The router can ping 8.8.8.8, but the workstations ping fails.

I've tried searching on basic router config, basic internet router config, etc....

I've also been unable to get SDM and CCP to run correctly. They install, but they don't seem to successfully connect to the 871.

Workstation is Win7 64bit

IE version 10.

The end goal is to be able to access the internet and use a ciscos vpn client to access devices inside the network.

Thanks for any help.

Here is the router's config so far.

871#sh run
Building configuration...

Current configuration : 2908 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TSM871
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
enable secret 5 $1$cUe4$fZi9A2/EjVo2qky8qFkjx1
enable password en
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-1637833218
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1637833218
revocation-check none
rsakeypair TP-self-signed-1637833218
!
!
crypto pki certificate chain TP-self-signed-1637833218
certificate self-signed 01
  3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31363337 38333332 3138301E 170D3130 30393238 30303339
  33305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36333738
  33333231 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81008F43 668EAA1F A32977F4 F96ADD87 6C22D5F0 298CD970 77C7B667 5E6DFD9B
  1DD254AA 866BFFC6 260603F9 A41BDEB6 A64EAA52 1798C202 D3049B2C 482CF1A2
  2BA44999 7B7E736D F6CD4FA8 E8D3A130 F2FCFB5C 165DE0C7 5E439275 7F83EEB1
  E1D6B581 6967CE64 8806A4C9 E78A49DA 77490D1A 89643836 26A5FC69 1A1A9F40
  44230203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603
  551D1104 0A300882 0654534D 38373130 1F060355 1D230418 30168014 F6725181
  23F5BA6C 1D46AF5D 083DA484 F72330FF 301D0603 551D0E04 160414F6 72518123
  F5BA6C1D 46AF5D08 3DA484F7 2330FF30 0D06092A 864886F7 0D010104 05000381
  810048B7 76D324E1 71231EE2 E28DD9FE 74A6DF9C 7554DAD0 3CE3BA31 B00EC4C8
  8C45EB43 D2BC9A54 A50B2626 E5A979C4 012D5518 5C30005A C6FBF37E 4AF7164B
  089B4FCC 477CCC9B BF118248 E3B5C56D E90D74CA 67CE3050 92689929 6832ED06
  E392E7DB D83C715A 82B2726B EB327D4E 1FE7D813 30797270 FDAA95D8 8420891B A2FA
        quit
dot11 syslog
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
username test privilege 15 password 0 password
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address x.x.x.171 255.255.255.128
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
54.0
station-role root
!
interface Vlan1
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 x.x.x.174
!
!
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password virt
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

871#

2 REPLIES
New Member

871 ISR

Didn't see a way to edit original post.

I mis typed:

Howeever when I'm connected to the private side. I can ping public IPs from the PC.

I'm tring to ping 8.8.8.8. The router can ping 8.8.8.8, but the workstations ping fails.

I meant  "I can not ping public IPs from the PC".

New Member

871 ISR

Got internet working.

ip nat inside source list 1 interface FastEthernet4 overload

access-list 1 permit 192.168.2.0 0.0.0.255

Now for the remote access VPN, if anyone has config example.

160
Views
0
Helpful
2
Replies
CreatePlease login to create content