Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

871W Simple Wireless Config Problem

Hi everyone, my name is Thomas.  I have just started working for a client who has offices using 871W routers.  Their setup was pretty screwy, so I am starting from scratch with the eventual goal of interconnecting with VPNs, etc...

I have the routers configured for basic internet access/NAT, but for the life of me I cannot figure out how to get the onboard wireless working.  All is well if I plug in an external WAP, I just need to figure out how to get the onboard Dot11Radio to work on the same VLAN (same internal network) as the wired network.  Offices are small and there is no need for a bunch of subnets.  Also, they are running a Windows server that is providing DHCP so I have DHCP disabled on the routers (before anyone screams at me for not having DHCP configured :-)  )

Here's my config below, any help would be AWESOME!!!!

!!!!!snipped!!!!!
!
dot11 ssid AFS
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 myWPAkey
!
ip cef
!
!
no ip domain lookup
ip domain name domain.com
!
!
!
username admin privilege 15 secret 5 $1$o5.J$qY2t1Sj0B4lH8l.ofQthN1
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
mac-address ****.****.****
ip address dhcp client-id FastEthernet4
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers aes-ccm
!
ssid AFS
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
!
interface Vlan1
description Internal
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 dhcp
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface FastEthernet4 overload
!!!!!PAT CONFIG SNIPPED!!!!!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 23 permit any
no cdp run
!
!
!
control-plane
!
banner exec ^C
^C
banner login ^C
^C
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

  • LAN Switching and Routing
4 REPLIES
New Member

Re: 871W Simple Wireless Config Problem

Thank you for your question.  This community is for Cisco Small Business products and your question is in reference to a Cisco Elite/Classic product.  Please post your question in the Cisco NetPro forums located here:

http://forum.cisco.com/eforum/servlet/NetProf;jsessionid=E0EEC3D9CB4E5165ED16933737822748.SJ3A?page=Network_Infrastructure_discussion

This forum has subject matter experts on Cisco Elite/Classic products that may be able to answer your question.

THANKS

Bronze

Re: 871W Simple Wireless Config Problem

Hi Thomas,

You need to bridge the Wireless and Ethernet interfaces together using a bvi interface and a bridge group.

The BVI interface needs to be configured with an IP, which I suspect will be the IP currently applied to Vlan 1. You then create a bridge group and add the required Vlans and WLANs that need to communicate to the bridge group.

This doc explains all: http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html

Regards,

Paul

HTH Paul ****Please rate useful posts****
New Member

Re: 871W Simple Wireless Config Problem

Unbelievable.....  I found that doc a couple of days ago and tried it to no avail.  Tried it just now and it worked!!!  I have been beating my head against walls for over a week trying to get this to work.

paulstone:  HUGE THX!!!!

BTW sorry for posting in the wrong forum guys....pretty new to Cisco stuff

Silver

Re: 871W Simple Wireless Config Problem

Hello,

Per the suggestion above, I have moved this thread into the NetPro>LAN, Switching and Routing area.

Regards,

Cindy Toy

Cisco Small Business Support

Community Manager

Regards, Cindy If my response answered your question, please mark the response as answered. Thank you!
407
Views
0
Helpful
4
Replies
This widget could not be displayed.