Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

881w router to distribute DHCP to switch

I have a 881w router with static wan ip ssetup on fastethernet 4 and vlan1 distributes ip from fastethernet 0. It works fine when I plug a PC directly to fastethernet 0, address is assigned and internet access is connected, the problem is when I connect the fastethernet 0 to a switch no ips are distibuted and even static routing a PC connected to the switch gets no connection. Can someone please help me what I am missing?

Here is a piece of my running config:


ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool local
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 66.180.96.12
!
!
!
ip name-server 64.238.96.12
ip name-server 66.180.96.12
no ipv6 cef

!
interface FastEthernet0
 switchport mode trunk
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 ip address xxx.xxx.248.98 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 no ip address
!
interface wlan-ap0
 description Embedded Service module interface to manage the embedded AP
 no ip address
 shutdown
!
interface Vlan1
 ip address pool local
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 23 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 xxx.xxx.248.97
!
access-list 23 permit 192.168.1.0 0.0.0.255
!
!
!

3 REPLIES
Community Member

Hi, you should give an ip

Hi,

 

you should give an ip address to fe0, then define int vlan 1 on your switch, and make sure that the port which you're connecting pc is in vlan 1.

 

HTH

Houtan

Community Member

thanks for the reply, it will

thanks for the reply, it will not allow me to give fe0 and ip says "IP addresses may not be configured on L2 links."

the switch is currently setup as vlan1.

specific commands I may be missing would be greatly appreciated.

 

Community Member

Try "no switcport" on fe0,

Try "no switcport" on fe0, then apply ip address.

 

on 881

interface FastEthernet0
 no switchport
 ip address 192.168.1.1 255.255.255.0

 

on switch

interface vlan 1

no shutdown

 

 

 

57
Views
0
Helpful
3
Replies
CreatePlease to create content